Forums

Resolved
0 votes
https://i.imgur.com/qrPlrSl.png?1

You can find information about Sia via this link.



1. Going to install app-sia in a VM standalone mode without a firewall.

it is located in the "clear-updates-repositories". I did the following:

[root@localhost ~]# yum --enablerepo=clearos-updates-testing install app-sia


==========================================================================================================================================
Package Arch Version Repository Size
==========================================================================================================================================
Installing:
app-sia noarch 1:1.0.7-1.v7 clearos-updates-testing 15 k
Installing for dependencies:
app-docker noarch 1:2.6.3-1.v7 clearos-verified 10 k
app-docker-core noarch 1:2.6.3-1.v7 clearos-verified 14 k
app-mail-routing-core noarch 1:2.3.4-1.v7 clearos-verified 16 k
app-sia-core noarch 1:1.0.7-1.v7 clearos-updates-testing 13 k
audit-libs-python x86_64 2.8.4-4.el7 clearos-centos-verified 76 k
checkpolicy x86_64 2.5-8.el7 clearos-centos-verified 295 k
container-selinux noarch 2:2.42-1.gitad8f0f7.el7 private-clearcenter-verified-updates 32 k
container-storage-setup noarch 0.8.0-3.git1d27ecf.el7 private-clearcenter-verified-updates 33 k
docker x86_64 2:1.13.1-53.git774336d.el7.centos private-clearcenter-verified-updates 16 M
docker-client x86_64 2:1.13.1-53.git774336d.el7.centos private-clearcenter-verified-updates 3.7 M
docker-common x86_64 2:1.13.1-53.git774336d.el7.centos private-clearcenter-verified-updates 86 k
docker-compose noarch 1.18.0-4.el7 clearos-epel-verified 222 k
libcgroup x86_64 0.41-20.el7 clearos-centos-verified 66 k
libsemanage-python x86_64 2.5-14.el7 clearos-centos-verified 113 k
libyaml x86_64 0.1.4-11.el7_0 clearos-centos-verified 55 k
oci-register-machine x86_64 1:0-6.git2b44233.el7 private-clearcenter-verified-updates 1.1 M
oci-systemd-hook x86_64 1:0.1.14-2.git9b1e622.el7 private-clearcenter-verified-updates 32 k
oci-umount x86_64 2:2.3.1-2.gitbf16163.el7 private-clearcenter-verified-updates 30 k
php-cli x86_64 5.4.16-46.el7 clearos-centos-verified 2.7 M
php-common x86_64 5.4.16-46.el7 clearos-centos-verified 565 k
php-pear noarch 1:1.9.4-21.el7 clearos-centos-verified 357 k
php-pear-Auth-SASL noarch 1.0.6-5.el7 clearos-epel-verified 16 k
php-pear-Net-LMTP noarch 1.0.2-1.v7 clearos-verified 10 k
php-pear-Net-SMTP noarch 1.7.3-1.el7 clearos-epel-verified 24 k
php-pear-Net-Socket noarch 1.0.14-1.el7 clearos-epel-verified 13 k
php-process x86_64 5.4.16-46.el7 clearos-centos-verified 56 k
php-xml x86_64 5.4.16-46.el7 clearos-centos-verified 126 k
policycoreutils-python x86_64 2.5-29.el7_6.1 clearos-centos-verified 456 k
python-IPy noarch 0.75-6.el7 clearos-centos-verified 32 k
python36 x86_64 3.6.8-1.el7 clearos-epel-verified 67 k
python36-PyYAML x86_64 3.12-1.el7 clearos-epel-verified 149 k
python36-cached_property noarch 1.5.1-2.el7 clearos-epel-verified 18 k
python36-chardet noarch 3.0.4-1.el7 clearos-epel-verified 190 k
python36-docker noarch 2.6.1-3.el7 clearos-epel-verified 180 k
python36-docker-pycreds noarch 0.2.1-2.el7 clearos-epel-verified 15 k
python36-dockerpty noarch 0.4.1-10.el7 clearos-epel-verified 29 k
python36-docopt noarch 0.6.2-8.el7 clearos-epel-verified 29 k
python36-idna noarch 2.7-2.el7 clearos-epel-verified 98 k
python36-jsonschema noarch 2.5.1-4.el7 clearos-epel-verified 76 k
python36-libs x86_64 3.6.8-1.el7 clearos-epel-verified 8.6 M
python36-pysocks noarch 1.6.8-6.el7 clearos-epel-verified 30 k
python36-requests noarch 2.12.5-3.el7 clearos-epel-verified 109 k
python36-setuptools noarch 39.2.0-3.el7 clearos-epel-verified 631 k
python36-six noarch 1.11.0-3.el7 clearos-epel-verified 33 k
python36-texttable noarch 1.6.2-1.el7 clearos-epel-verified 23 k
python36-urllib3 noarch 1.19.1-5.el7 clearos-epel-verified 134 k
python36-websocket-client noarch 0.47.0-2.el7 clearos-epel-verified 59 k
setools-libs x86_64 3.3.8-4.el7 clearos-centos-verified 620 k
skopeo-containers x86_64 1:0.1.28-1.git0270e56.el7 private-clearcenter-verified-updates 13 k
yajl x86_64 2.0.4-4.el7 clearos-centos-verified 39 k

Transaction Summary
==========================================================================================================================================
Install 1 Package (+50 Dependent packages)



2. When accessed via the webconfig it is in a stopped state.

https://i.imgur.com/fm7saO0.png


3. Started the app.

https://i.imgur.com/krtyBLP.png

https://i.imgur.com/XYo66Uh.png


4. Created a wallet

https://i.imgur.com/di5re9v.png

Download the primary seed.

You need the primary seed to unlock your wallet. Unlocking your wallet takes some time (minutes).


5. Create wallet address.

https://i.imgur.com/EKYT7yQ.png


7. When I go to hosts storage manager I have the following error.

https://i.imgur.com/k0mKHeb.png

https://i.imgur.com/MkgzvRa.png

https://i.imgur.com/8lmQ9hb.png


6. When I want to go to the details (right window on screen) of the app there is error (see screenshot).

https://i.imgur.com/JIRdi7F.png


7. Also to notice I have no success using app-sia in gateway mode (server modus).
Saturday, November 16 2019, 03:35 PM
Share this post:
Responses (10)
  • Accepted Answer

    Monday, November 25 2019, 06:04 PM - #Permalink
    Resolved
    0 votes
    Thanks for sharing Nick.

    The app is far from finished and indeed it is very slow. The points you mention are absolutely valid.

    Do you have contact with Team India? Are they going to look into these issues?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, November 25 2019, 05:15 PM - #Permalink
    Resolved
    1 votes
    I've loaded app-sia and testing is not going well. As you said, it does not work in Gateway Mode. For me it does not work in standalone mode either. I was sat on the a screen where it says Sia is running on the right, but the panels in the middle say to start sia - see sia1.png. "docker ps" showed sia was running almost immediately. This changed after 18 minutes when I finally got a usable screen.
    Tried creating a seed but it came back with an empty file.
    Switched to Standalone - No Firewall and was able to create a seed.
    Created a wallet - question to test: how do I reuse an existing wallet
    Tried setting a storage location and (/mnt/sia) and got the same error message as Marcel - Ooops! 404 - Refer to API.md

    Other things noticed.
    Sia does not auto start on boot even if it was running before shutdown
    Guidance is needed for setting Hosting Settings
    App documentation does not exist
    What is the Announce Host in the My Account panel?
    If run from a machine on your LAN, is any port-forwarding needed? If so, can it play with uPnP?
    How do you re-use any wallet or or keys?

    Before doing much more testing some documentation would be helpful.
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 09:13 PM - #Permalink
    Resolved
    0 votes
    There will not be anything obvious in app-storage that relates to app-sia. It is more likely that app-sia uses some of app-storage's library functions.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 07:12 PM - #Permalink
    Resolved
    0 votes
    okay, good information. I'll have a look.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 03:22 PM - #Permalink
    Resolved
    0 votes
    I don't know what the requirements are. I just seemed to remember a conversation saying something like app-storage was needed for app-sia. As you have 2.6.24-1.v7, you have the latest.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 12:32 PM - #Permalink
    Resolved
    0 votes
    System testing on is a ClearOS Community 7.7 version.

    Installed Packages
    app-storage.noarch 1:2.6.24-1.v7 @clearos-updates


    Do I need app-storage to let app-sia work?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 12:09 PM - #Permalink
    Resolved
    0 votes
    If you have a new install you'll still be on the paid repos. Please can you confirm your version of app-storage? If it is app-storage-2.6.15-1.v7, can you please try updating to the Community version:
    yum update app-storage --enablerepo=clearos-updates
    We have not pushed app-storage to Home/Business for a while as it is still not up to scratch. Community here is some way ahead of business.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 11:20 AM - #Permalink
    Resolved
    0 votes
    Yes Nick!
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 09:45 AM - #Permalink
    Resolved
    0 votes
    Does the target folder actually exist?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, November 17 2019, 09:16 AM - #Permalink
    Resolved
    0 votes
    The issue of keeping me testing this further is adding a folder to app sia. I tried everything what I could think of. For example:

    /mnt/sia
    //mnt//sia
    \mnt\sia
    \\mnt\\sia
    \
    \\

    It is not accepting any input.

    The error you receive is a 404 so it can't find the location I presume.

    Has anybody a idea?
    The reply is currently minimized Show
Your Reply