Forums

Resolved
0 votes
Hi,

For those who are interested you can update Webapp and Z-push with the Kopano repositories.

webapp.repo
[Kopano-Webapp]
name=Builds of final releases (RHEL_7)
type=rpm-md
baseurl=https://serial:YOURSERIALNUMBER@download.kopano.io/supported/webapp:/final/RHEL_7/
gpgcheck=1
enabled=1


z-push.repo
[z-push]
name=Z-Push noarch Enterprise Linux 7 - $basearch
baseurl=http://repo.z-hub.io/z-push:/final/RHEL_7
failovermethod=priority
enabled=1
gpgcheck=0


Not sure how this will effect the update coming through COS, but don't think it will have any influence.


I think the main Kopano packages could also be updated, but not yet tried....

kopano.repo
[Kopano-Core]
name=Builds of final releases (RHEL_7)
type=rpm-md
baseurl=https://serial:YOURSERIALNUMBER@download.kopano.io/supported/core:/final/RHEL_7/
gpgcheck=1
gpgkey=https://serial:YOURSERIALNUMBER@download.kopano.io/supported/core:/final/RHEL_7/repodata/repomd.xml.key
enabled=1
Saturday, December 08 2018, 06:39 PM
Share this post:
Responses (68)
  • Accepted Answer

    Saturday, October 12 2019, 03:52 PM - #Permalink
    Resolved
    0 votes
    The first four lines come from terminating kopano-search and the last from terminating kopano-server. As this is during a restart process the subsequent starts work OK. I am not sure I can do anything about it.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, October 12 2019, 02:24 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    In 8.7.5 you can comment out the mysql_host line as it defaults to empty.

    Nick,

    In messages.log i see an error, but the kopano-search is running.

    Oct 12 16:10:57 pdebrabander kopano-search: Terminating on signal 15
    Oct 12 16:10:57 pdebrabander systemd: kopano-search.service: main process exited, code=exited, status=1/FAILURE
    Oct 12 16:10:57 pdebrabander systemd: Unit kopano-search.service entered failed state.
    Oct 12 16:10:57 pdebrabander systemd: kopano-search.service failed.
    Oct 12 16:11:03 pdebrabander kopano-server: Error in my_thread_global_end(): 16 threads didn't exit
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, October 12 2019, 01:26 PM - #Permalink
    Resolved
    1 votes
    In 8.7.5 you can comment out the mysql_host line as it defaults to empty.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, October 12 2019, 09:04 AM - #Permalink
    Resolved
    0 votes
    Hmm. It works on 8.5.8 but it looks like on 8.7.5 you also have to set mysql_host to localhost (not 127.0.0.1) or leave it empty. I've tested setting it to localhost. I'm pretty sure I forced this to 127.0.0.1 in the update script for some reason but I can reverse that bit.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, October 11 2019, 06:08 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    That's the one. Give it a go, restarting kopano-server. To prove it, I stopped kopano for a few minutes then I started it so the logs would be separate.

    i tried it, but still the error during startup:

    2019-10-11 20:06:04,115 - search - ERROR - Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/kopano/log.py", line 103, in log_exc
    try: yield
    File "/usr/lib/python2.7/site-packages/kopano_search/__init__.py", line 393, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
    File "/usr/lib/python2.7/site-packages/kopano/server.py", line 853, in sync
    return _ics.sync(self, self.mapistore, importer, state, max_changes, window=window, begin=begin, end=end, stats=stats)
    File "/usr/lib/python2.7/site-packages/kopano/ics.py", line 253, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
    File "/usr/lib/python2.7/site-packages/MAPICore.py", line 1346, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
    MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, October 11 2019, 05:54 PM - #Permalink
    Resolved
    0 votes
    That's the one. Give it a go, restarting kopano-server. To prove it, I stopped kopano for a few minutes then I started it so the logs would be separate.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, October 11 2019, 05:07 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I have a fix for the search error. Kopano is using system-mysql so it does not use the default socket. In server.cfg change:
    mysql_socket		=

    to:
    mysql_socket = /var/lib/system-mysql/mysql.sock

    Nick, is this related to this error ?
    https://www.clearos.com/clearfoundation/social/community/update-kopano,-webapp-and-z-push#reply-271511
    The reply is currently minimized Show
  • Accepted Answer

    Friday, October 11 2019, 04:39 PM - #Permalink
    Resolved
    0 votes
    I have a fix for the search error. Kopano is using system-mysql so it does not use the default socket. In server.cfg change:
    mysql_socket		=

    to:
    mysql_socket = /var/lib/system-mysql/mysql.sock
    The reply is currently minimized Show
  • Accepted Answer

    Monday, October 07 2019, 03:12 PM - #Permalink
    Resolved
    0 votes
    Here is a new set files, mainly with kopano-condrestart doing httpd first and then the kopano services. There are a few other tidy ups.

    Note that in the install script httpd is still started after the kopano services and I believe that works fine as it always has so I am a bit perplexed with your issue.
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 06 2019, 03:30 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    That is frustrating. I've done a number of trial upgrades and I've not seen that. Perhaps httpd needs to restart before kopano-???. I don't really want to restart httpd twice as the restart is slow. There is no such process as kopano-webapp, so perhaps apache should be brought to the beginning of the restarts? When I've upgraded all I've had to do is refresh the webapp page in the browser and it comes up with the new version (requiring a login).

    Where were you seeing the message? In your browser?

    Maybe because my webapp was not update because i was already on the latest version.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 06 2019, 01:41 PM - #Permalink
    Resolved
    0 votes
    That is frustrating. I've done a number of trial upgrades and I've not seen that. Perhaps httpd needs to restart before kopano-???. I don't really want to restart httpd twice as the restart is slow. There is no such process as kopano-webapp, so perhaps apache should be brought to the beginning of the restarts? When I've upgraded all I've had to do is refresh the webapp page in the browser and it comes up with the new version (requiring a login).

    Where were you seeing the message? In your browser?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 06 2019, 12:39 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Hi Patrick, can you please clarify? Are you talking about the upgrade to 8.7.5? If so, the last part of the /usr/clearos/apps/kopano/deploy/upgrade script does a "kopano-condrestart" which restarts apache (httpd). Or are you talking about the manual upgrade from 8.4.5 to 8.5.8? Even then, the last step is to restart the services including httpd. Or are you perhaps using a different version of PHP from the PHP Engines app.

    Sure.
    I did an upgrade from 8.5.8 to 8.7.5.
    After the upgrade I checked the Webapp and this was telling to restart http-server to reload php.ini for mapi (don't know the exact message anymore)

    But something like this :
    Not Found: PHP mapi extension not found

    If you have upgraded Kopano Core, please restart Apache

    Kopano WebApp can't start because of incompatible configuration.

    Please correct above errors, a good start is by checking your 'php.ini' file.

    You can disable this configuration check by editing the file '/usr/share/kopano-webapp/config.php', but this is not recommended.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 06 2019, 12:06 PM - #Permalink
    Resolved
    0 votes
    Hi Patrick, can you please clarify? Are you talking about the upgrade to 8.7.5? If so, the last part of the /usr/clearos/apps/kopano/deploy/upgrade script does a "kopano-condrestart" which restarts apache (httpd). Or are you talking about the manual upgrade from 8.4.5 to 8.5.8? Even then, the last step is to restart the services including httpd. Or are you perhaps using a different version of PHP from the PHP Engines app.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 06 2019, 09:27 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    I did the upgrade on my production server.
    Upgrade went smoothly and the kopano server is running without any (know) issues at this moment.
    Emails are coming in.

    The only thing to add to the upgrade script is to restart the http server. Webapp is asking for it after the upgrade to reload the php.ini
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, September 28 2019, 08:43 AM - #Permalink
    Resolved
    0 votes
    That, fortunately for me, is not an upgrade issue. That is a separate marketplace issue. Can you try a general "yum update" first?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 27 2019, 06:55 PM - #Permalink
    Resolved
    0 votes
    Nick,

    I'm trying to update from 8.4.5, but unfortunately the upgrade is not working
    ClearOS release 7.6.0 (Final)

    ENABLE_BETA=True yum upgrade "*kopano*" "lib*" "python*"
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    ClearCenter Marketplace: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:618)
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-amsterdam.clearos.com
    * clearos-centos-sclo-rh: download1.clearsdn.com
    * clearos-contribs: mirror2-amsterdam.clearos.com
    * clearos-fast-updates: download1.clearsdn.com
    * clearos-infra: mirror2-amsterdam.clearos.com
    No packages marked for update


    On an other image it worked.
    Upgrade from 8.4.5 -> 8.5.8 -> 8.7.5
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 27 2019, 11:00 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Perhaps I should remove presence.cfg as well as it is no longer used.

    Yep.

    Also Kopano Web meetings is installed standard.
    This is an extra paid package with a difference license
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 26 2019, 02:02 PM - #Permalink
    Resolved
    0 votes
    Perhaps I should remove presence.cfg as well as it is no longer used.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 26 2019, 11:28 AM - #Permalink
    Resolved
    0 votes
    Those parameters don't exist in the 8.5.8 install. You can check in /usr/share/doc/kopano/example-config.

    Anyway I have fixed it and added back in backing up of the configs during the upgrade but I did not bump the version (and don't intend to or I'd have run out of numbers by now!)
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 26 2019, 08:15 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Hmm. Was that originally an 8.4.5 installation? If so, I'll have to install one. Those parameters are are missing completely from native 8.5.8 configs.

    It was an upgrade from 8.5.8 to 8.7.5
    I'll check tonight, but i thought was a originally a 8.5.8 install
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 26 2019, 07:52 AM - #Permalink
    Resolved
    0 votes
    Hmm. Was that originally an 8.4.5 installation? If so, I'll have to install one. Those parameters are are missing completely from native 8.5.8 configs.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, September 25 2019, 05:19 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I think it is all working now for installs and updates.

    From the zip file, ..........................

    work for the moment.


    Hi Nick,

    I did a upgrade test from 8.5.8 to 8.7.5 and the upgrade package went smoothly execpt kopano-server did not start.
    The following error is shown:


    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: [crit ] Config error: Unknown option "server_tcp_enabled" found!
    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: [crit ] Config error: Unknown option "server_tcp_port" found!
    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: [crit ] Config error: Unknown option "server_ssl_enabled" found!
    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: [crit ] Config error: Unknown option "server_ssl_port" found!
    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: An error occurred: no access (0x8004011c). Please check logfile file:/var/log/kopano/server.log for details.
    Sep 25 19:14:23 server2.pdebrabander.nl kopano-server[5207]: [=======] Server shutdown complete.
    Sep 25 19:14:23 server2.pdebrabander.nl systemd[1]: kopano-server.service: main process exited, code=exited, status=255/n/a
    Sep 25 19:14:23 server2.pdebrabander.nl systemd[1]: Unit kopano-server.service entered failed state.
    Sep 25 19:14:23 server2.pdebrabander.nl systemd[1]: kopano-server.service failed.


    I have comment them out in server.cfg to start the kopano-server.
    This should be added in your update script
    The reply is currently minimized Show
  • Accepted Answer

    Monday, September 23 2019, 10:33 AM - #Permalink
    Resolved
    0 votes
    The previous packages worked to upgrade 8.5.8 or do a fresh install, but needed reworking to accommodate a direct upgrade from 8.4.5.

    Note that if you are using these files to upgrade directly from 8.4.5 following these instructions (amending the yum command to the one in this thread) you will need to start kopano-server, kopano-gateway and kopano-dagent manually at the end of the upgrade process. I will update the upgrade instructions when this package gets released.

    New files are attached.
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Friday, September 20 2019, 11:55 AM - #Permalink
    Resolved
    0 votes
    I think it is all working now for installs and updates.

    From the zip file, place kopano.repo in /etc/yum.repos.d. Then edit the repo file, replacing "YOURSERIALNUMBER" with your serial number that you should be able to find from your Webconfig.

    Place the four rpm's in a folder of your choice then, in ssh, navigate to that folder and run:

    yum update app-kopano* kopano-webapp* --enablerepo=Kopano-Core,z-push,Kopano-Webapp --nogpgcheck


    In the Webconfig, you can now set a port to **blank** and it will disable the service.

    You will find in the webconfig that the "Secure iCal Port" is blank. This is because, although it shows as 8443 with Kopano 8.5.8, it is actually disabled due to another pref and the certificates are not set up to enable it to work. In 8.7.5 upgrade, I have set up the certificates to work but not enabled it as this, in effect, changes a current preference which the user may not want to do. If you want to enable "Secure iCal Port", just set it to 8443 or a port of your choice and it should work. In a fresh installation, "Secure iCal Port" is enabled by default.

    I have also changed kopano-conderstart to do a proper condrestart i.e to only restart if the app is running. Formerly it just did a restart and there was a cron job in the background triggering this every night (among other things) so it was impossible for anyone to shutdown Kopano or any of its features for more than a day!

    If you want to try a fresh installation, place and edit the files as before then do a:
    yum install app-kopano* --enablerepo=Kopano-Core,z-push,Kopano-Webapp --nogpgcheck


    Note I am doing a --nogpgcheck as I can't get the webapp key to work for the moment.
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 17 2019, 04:25 PM - #Permalink
    Resolved
    0 votes
    ***** Hmm. I tried updating the attachment. I could delete it but can't re-add it. Please wait for an update. *****


    I have some updated files to test a full upgrade to Kopano 8.7.5.0 and z-push to 2.5. App-kopano goes to 2.3.16. Anyone with a valid Kopano licence can test. Without a valid licence you cannot pull the updates from the Kopano repo.

    I posted earlier today but have just bumped the app-kopano for a minor fix.

    If you would like to test, unzip the attached kopano.zip file and place the kopano.repo file in /etc/yum.repos.d. Then edit the repo file, replacing "YOURSERIALNUMBER" with your serial number that you should be able to find from your Webconfig.

    Place the two rpm's in a folder of your choice then, in ssh, navigate to that folder and run:

    yum update app-kopano* --enablerepo=Kopano-Core,z-push


    In the Webconfig, you can now set a port to and it will disable the service.

    You will find in the webconfig that the "Secure iCal Port" is blank. This is because, although it shows as 8443 with Kopano 8.5.8, it is actually disabled due to another pref and the certificates are not set up to enable it to work. In 8.7.5 upgrade, I have set up the certificates to work but not enabled it as this, in effect, changes a current preference which the user may not want to do. If you want to enable "Secure iCal Port", just set it to 8443 or a port of your choice and it should work. In a fresh installation, "Secure iCal Port" is enabled by default.

    I have also changed kopano-conderstart to do a proper condrestart i.e to only restart if the app is running. Formerly it just did a retsart and there was a cron job in the background triggering this every night (among other things) so it was impossible for anyone to shutdown Kopano or any of its features for more than a day!.

    I have not yet tested a fresh installation, only an upgrade.

    I have also not tested the Webapp upgrade, but you should be able to test with:

    yum update kopano-webapp* --enablerepo=Kopano-Webapp
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 17 2019, 10:02 AM - #Permalink
    Resolved
    0 votes
    Post deleted so the wrong files can't be downloaded
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 29 2019, 06:09 PM - #Permalink
    Resolved
    0 votes
    Patrick de Brabander wrote:
    Since you try to run the updates through the Clear repos, it is possible to make a dependency which update the kopano-condrestart script ?
    I've already checked in the change. The /usr/sbin/kopano-condrestart script belongs to app-kopano which is the ClearOS app I need to update for the webconfig (done) and the update script (started on). The update script is the bit which will change the old cfg parameters to the new ones and fix some of the other issues I've found such as the certificate permissions. I will also need to do the install script for a fresh installation.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 29 2019, 05:54 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Slight bad news for you.

    You = Me ;)

    Since you try to run the updates through the Clear repos, it is possible to make a dependency which update the kopano-condrestart script ?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 29 2019, 10:11 AM - #Permalink
    Resolved
    0 votes
    Slight bad news for you. 8.5.8 came with both systemd unit files and sysvinit init files for starting kopano hence the difference in behaviour (seeing the green OK with the service command). 8.7.5 only comes with systemd unit files so the green OK disappears.

    Also in kopano-condrestart, the condrestart needs to be changed to restart to maintain the same behaviour as before of always restarting the apps whether they are started or not. I am not going to rename the file to kopano-restart or I'd have to find where it is used (unless my arm is twisted).
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 29 2019, 07:50 AM - #Permalink
    Resolved
    0 votes
    All the systemctl documentation seems to say:
    systemctl condrestart X
    is directly equivalent to:
    service X condrestart
    It does not appear to be the case :(

    The "service X condrestart" command run on a systemctl unit file will start the program if it is not running, however the "systemctl condrestart X" won't. I suspect this is buggy implementation of sysvinit -> systemd conversion upstream so I'll stick with the "service" command so as to not change the behaviour. The risk then, is an upstream change to rectify this behaviour.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 08:57 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Have you checked that all cfg files exist?

    That was the trick.

    I missed dagent.cfg, monitor.cfg, presence.cfg, search,cfg, spooler.cfg and unix.cfg
    Don not know which was the problem and why they were not there.
    Copied from other install and it is working.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 08:51 PM - #Permalink
    Resolved
    0 votes
    Have you checked that all cfg files exist?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 08:45 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Attached are my three files but with the original lines commented out rather than removed - if the forum accepts zip files.

    Thanks, but no difference.
    Looks like it is in ical.cfg or gateway.cfg ?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 08:39 PM - #Permalink
    Resolved
    0 votes
    Attached are my three files but with the original lines commented out rather than removed - if the forum accepts zip files.
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 08:30 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    That error will only happen if either you have not changed _port to _listen in line 119 of both files, or you have not added the new xxxx_listen parameters to your gateway.cfg and ical.cfg files.

    In the ical.cfg were indeed not the new parameters.
    I've added those, but or now getting error : File not found.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 07:55 PM - #Permalink
    Resolved
    0 votes
    That error will only happen if either you have not changed _port to _listen in line 119 of both files, or you have not added the new xxxx_listen parameters to your gateway.cfg and ical.cfg files.

    And no, I'm afraid I can't look at the backup location. It is rather beyond my skill set. I am not a PHP programmer at all but can do very minor things because of general coding knowledge. If they don't work, I don't know how to debug. If anyone wants to try it, there is a section of code in app-storage which may be usable.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 07:20 PM - #Permalink
    Resolved
    0 votes
    Nick,

    I applied the changes to Kopano_Gateway.php and Kopano_iCal.php, but no change in the webconfig menu.
    Maybe I missed something ?

    Can you also look into the backup path (/usr/clearos/apps/kopano_basic/libraries/Kopano_Basic.php) ;-)
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 03:57 PM - #Permalink
    Resolved
    0 votes
    If you want to enter a blank port to disable it, make the following changes:
    /usr/clearos/apps/kopano/controllers/kopano_settings.php
    Change TRUE to FALSE on lines 126 to 131

    /usr/clearos/apps/kopano/libraries/Kopano_iCal.php
    Change the line added:
            $port = "*:".$port;
    to:
            if ( ! empty($port)) 
    $port = "*:".$port;

    and in the same file change line 211 from:
            if (! Network_Utils::is_valid_port($port))
    to:
            if (( ! empty($port)) and (! Network_Utils::is_valid_port($port)))


    /usr/clearos/apps/kopano/libraries/Kopano_Gateway.php
    Repeat the changes made to Kopano_Ical.php. Change the line added:
            $port = "*:".$port;
    to:
            if ( ! empty($port)) 
    $port = "*:".$port;

    and in the same file change line 211 from:
            if (! Network_Utils::is_valid_port($port))
    to:
            if (( ! empty($port)) and (! Network_Utils::is_valid_port($port)))
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 27 2019, 01:54 PM - #Permalink
    Resolved
    0 votes
    Abandoning the Search error for the moment (I'm posting to the Kopano forums), I think I have the webconfig working. The following changes are needed:
    /usr/clearos/apps/kopano/libraries/Kopano_Gateway.php
    At line 119 change:
            $port = $file->lookup_value("/^${service}_port\s*=\s*/i");
    $port = trim($port);
    to:
            $port = $file->lookup_value("/^${service}_listen\s*=\s*/i");
    $port = preg_replace('/.*:/', '', trim($port));

    And at line 162 change:
            $key = $service . '_port';
    to:
            $key = $service . '_listen';

    $port = "*:".$port;


    /usr/clearos/apps/kopano/libraries/Kopano_Ical.php
    The changes here are the same. At line 119 change:
            $port = $file->lookup_value("/^${service}_port\s*=\s*/i");
    $port = trim($port);
    to:
            $port = $file->lookup_value("/^${service}_listen\s*=\s*/i");
    $port = preg_replace('/.*:/', '', trim($port));

    And at line 162 change:
            $key = $service . '_port';
    to:
            $key = $service . '_listen';

    $port = "*:".$port;
    I've not tested the effect on the original line 168 in Kopano_Gateway.php and Kopano_Ical.php as it seems irrelevant. If the parameters are missing in the cfg files the webconfig fails anyway which is what we have been seeing when we commented out the values pop3_port etc.

    It would seem to me to be relatively easy to also accept a blank value as well if you want to disable the port. A blank port would also need to be allowed in the port number validation validate_port(). The function set_port() would need to be changed to prepend the string "*:" to the port number only if the port number were not blank. This would be done to the $port line I added.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 26 2019, 05:03 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    /usr/sbin/kopano-condrestart needs to be rewritten for systemd:
    #!/bin/sh

    /usr/bin/systemctl condrestart kopano-dagent
    /usr/bin/systemctl condrestart kopano-server
    /usr/bin/systemctl condrestart kopano-gateway
    /usr/bin/systemctl condrestart kopano-ical
    /usr/bin/systemctl condrestart kopano-monitor
    /usr/bin/systemctl condrestart kopano-spooler

    /usr/bin/systemctl condrestart kopano-search
    /usr/bin/systemctl condrestart httpd
    kopano-indexer no longer exists.

    It is worth noting that the httpd restart is slow but it was not restarting before at all as /etc/init.d/httpd did not exist.


    Correct. Good point.
    The advantage of Service instead of Systemctl is that you see the progress during the execution of kopano-condrestart
    The reply is currently minimized Show
Your Reply