Forums

Resolved
0 votes
Please help...

I was getting an error about php module php-mapi so I removed it based on a google search. After I did this I realized zarafa stopped working. Then I tried to follow some other online guides to remove php so I could install a fresh php 5.2 so to get everything working again. I kept original php.ini file backed up before I removed the php. After trying a couple of times to remove and reinstall, I see, to have messed up some modules. I am getting the below errors when I do a php -v:

PHP Warning:  PHP Startup: wddx: Unable to initialize module                    
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/module
s/xmlreader.so' - /usr/lib64/php/modules/xmlreader.so: undefined symbol: dom_nod
e_class_entry in Unknown on line 0
PHP Warning: PHP Startup: xmlwriter: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/module
s/xsl.so' - /usr/lib64/php/modules/xsl.so: undefined symbol: dom_node_class_entr
y in Unknown on line 0
PHP Warning: PHP Startup: mapi: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
PHP 5.4.19 (cli) (built: Sep 2 2013 22:09:58)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies


When I try and yum remove php-* I get:

[root@g8 root]# yum remove php-*                                                
Loaded plugins: clearcenter-marketplace, fastestmirror
Setting up Remove Process
No Match for argument: php-common-5.2.17-2.clearos.i686.rpm
ClearCenter Marketplace: fetching repositories...
Loading mirror speeds from cached hostfile
* clearos: mirror2-dc.clearsdn.com
* clearos-addons: mirror2-dc.clearsdn.com
* clearos-extras: mirror2-dc.clearsdn.com
* clearos-updates: mirror2-dc.clearsdn.com
* contribs: download1.clearsdn.com
* private-clearcenter-antispam: download4.clearsdn.com:80
* private-clearcenter-backuppc: download4.clearsdn.com:80
* private-clearcenter-dyndns: download4.clearsdn.com:80
* private-clearcenter-plex: download4.clearsdn.com:80
* private-clearcenter-rbs: download4.clearsdn.com:80
* private-clearcenter-roundcubemail: download4.clearsdn.com:80
* private-clearcenter-serviio: download4.clearsdn.com:80
* private-clearcenter-smart-monitor: download4.clearsdn.com:80
* private-clearcenter-zarafa-community: download4.clearsdn.com:80
No Match for argument: php-mapi-7.1.1-37812.x86_64.rpm
No Match for argument: php-mapi-7.1.1-37812.x86_64.rpm.1
No Packages marked for removal


I also cannot access owncloud, any wordpress site I have on the server, or the newly purchased webmail module (roundcube) from the app store.

Can someone please point me in the right direction?

Thanks,

AC
Wednesday, July 02 2014, 04:45 PM
Share this post:
Responses (15)
  • Accepted Answer

    Friday, May 15 2015, 02:53 AM - #Permalink
    Resolved
    0 votes
    Well CRAP!!! I spoke too soon. Owncloud is working and can be accessed by devices but when trying to access it in a browser its coming up a blank page
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 15 2015, 01:36 AM - #Permalink
    Resolved
    0 votes
    Sorry for the delay guys..... I found my problem. When I went to uninstall php it wasnt removing ALL of it. It was leaving a few files behind for some reason. At least thats what Im thinking happened. Then off to to grab the original 5.3 and reinstall zarafa and owncloud and all was good
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 10 2015, 09:01 AM - #Permalink
    Resolved
    0 votes
    Sorry but Zarafa build requires the original ClearOS version of PHP5.3.3 to support the php-mapi extension (or don't use webaccess/z-push/webapp). The php-mapi extension is built as part of the Zarafa package so is not part of the REMI repo

    FYI Owncloud 7 will work with PHP5.3 and newer versions, but Owncloud 8 requires PHP5.4+ hence why it hasn't been built for Clearos6 yet... but will be for ClearOS7

    There is a working build of PHP5.4 in my timb repo and PHP5.5 in timb-testing as I have been experimenting with different ways to bring to ClearOS. At present due to the vast amount of php extensions the Remi build is still the most reliable way to upgrade / install.

    To get back to a working install please check all existing php packages 'rpm -qa | grep php' and remove/reinstall - as Nick notes you had a left over php-cli and php-common installed blocking your yum installation. Please note this may force you to uninstall other app-xx packages which will also need reinstalling.
    If you are familiar with the command line you can perform an inplace downgrade using rpm instead of yum - which will save you having to remove them first and breaking other apps. Download all the old equivalent PHP rpm packages from a mirror into a folder locally using wget and install using 'rpm -Uvh --oldpackage *.rpm'. Note you will have to satisfy all the dependancy issues manually...
    http://mirror2.timburgess.net/clearos/community/6/os/x86_64/Packages/
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 10 2015, 06:47 AM - #Permalink
    Resolved
    0 votes
    I really don't know the correct answers and I don't use owncloud or zarafa, but from your first post today it looks like you still had Tim's version of php-common and php-cli installed before you downgraded. You could try removing them as well. Try "yum list installed | grep timb" and see if there is anything else lying around from Tim's 5.4.

    I seem to remember that Tim has switched to the REMI repo for php where he found the missing php-mapi and so on.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 10 2015, 02:08 AM - #Permalink
    Resolved
    0 votes
    Crap.... owncloud works great but Im still get the above php-mapi error when trying to hit webaccess.
    If it helps

    [root@server ~]# rpm -qa | grep ^php | sort
    php-5.4.19-1.clearos.x86_64
    php-cli-5.4.19-1.clearos.x86_64
    php-common-5.4.19-1.clearos.x86_64
    php-gd-5.4.19-1.clearos.x86_64
    php-imap-5.4.19-1.clearos.x86_64
    php-intl-5.4.19-1.clearos.x86_64
    php-ldap-5.4.19-1.clearos.x86_64
    php-mapi-7.0.15-42709.x86_64
    php-mbstring-5.4.19-1.clearos.x86_64
    php-mcrypt-5.4.19-1.clearos.x86_64
    phpMyAdmin-4.0.10.5-1.v6.noarch
    php-mysql-5.4.19-1.clearos.x86_64
    php-pdo-5.4.19-1.clearos.x86_64
    php-pear-1.9.4-4.el6.noarch
    php-pear-Auth-SASL-1.0.6-1.el6.noarch
    php-pear-MDB2-2.5.0-0.9.b5.el6.noarch
    php-pear-MDB2-Driver-mysqli-1.5.0-0.8.b4.el6.noarch
    php-pear-Net-Curl-1.2.5-4.el6.noarch
    php-pear-Net-LMTP-1.0.2-1.v6.noarch
    php-pear-Net-SMTP-1.6.1-1.el6.noarch
    php-pear-Net-Socket-1.0.10-1.el6.noarch
    php-process-5.4.19-1.clearos.x86_64
    php-soap-5.4.19-1.clearos.x86_64
    php-xml-5.4.19-1.clearos.x86_64



    I cant get it back on php version 5.3 or Im doing something wrong
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 10 2015, 01:47 AM - #Permalink
    Resolved
    0 votes
    I enabled tims repo and tried again and it installed version 5.4. Crap I was sitting without email had to get something back on there so zarafa could run
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 10 2015, 01:36 AM - #Permalink
    Resolved
    0 votes
    I screwed mine up as well.

    Im getting this when I try to go to zarafa webaccess
    Not Found: PHP mapi extension not found
    If you have upgraded zarafa, please restart Apache

    Zarafa WebAccess can't start because of incompatible configuration.

    Please correct above errors, a good start is by checking your '/etc/php.ini' file.

    Or if you wish, you can disable this config check by editing the file '/usr/share/zarafa-webaccess/config.php', but this is not recommend.


    I had 5.4 installed so I completely uninstalled php, rebooted the server and then did a yum install php and now Im getting the info below:


    Resolving Dependencies
    --> Running transaction check
    ---> Package php.x86_64 0:5.3.3-40.el6_6 will be installed
    --> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-5.3.3-40.el6_6.x86_64
    --> Processing Dependency: php-cli(x86-64) = 5.3.3-40.el6_6 for package: php-5.3.3-40.el6_6.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-5.3.3-40.el6_6.x86_64 (clearos)
    Requires: php-common(x86-64) = 5.3.3-40.el6_6
    Installed: php-common-5.4.19-1.clearos.x86_64 (@timb)
    php-common(x86-64) = 5.4.19-1.clearos
    Available: php-common-5.3.3-40.el6_6.x86_64 (clearos)
    php-common(x86-64) = 5.3.3-40.el6_6
    Error: Package: php-5.3.3-40.el6_6.x86_64 (clearos)
    Requires: php-cli(x86-64) = 5.3.3-40.el6_6
    Installed: php-cli-5.4.19-1.clearos.x86_64 (@timb)
    php-cli(x86-64) = 5.4.19-1.clearos
    Available: php-cli-5.3.3-40.el6_6.x86_64 (clearos)
    php-cli(x86-64) = 5.3.3-40.el6_6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, March 28 2015, 02:23 AM - #Permalink
    Resolved
    0 votes
    I had the same problem, after downgrading webaccess was complaining about missing mapi extension..
    For some reason all the PHP extensions where installed in /usr/lib64/php/modules/ instead of /usr/lib/php/modules/ ...
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 12 2015, 11:44 PM - #Permalink
    Resolved
    0 votes
    I am facing the same issue.
    Already want to install Owncloud 8. This required a newer version of minimal PHP 5.4.

    Is there a save way of how I can get a php 5.3 upgrade to minimal PHP 5.4.
    I´ve heard of some way of parrallel install of PHP versions which would not effect the Clearos "system" php but can used by apache webserver. Perhaps this was only suitable at COS 5.2?
    Am I right on this?

    @Tim: Your advice as always will be highly appreciated!

    Thanks,
    Harald
    The reply is currently minimized Show
  • Accepted Answer

    Cas Nuy
    Cas Nuy
    Offline
    Saturday, November 22 2014, 12:52 PM - #Permalink
    Resolved
    0 votes
    I am facing a similar issue.
    Already had installed Owncloud myself a long time ago (versions 5 & 6) and now wanted to upgrade to version 7. This required a newer version of PHP. So i followed the route for the upgrade which gave me php 5.4.19. This then broke my Zarafa installation.
    So I had to revert back to standard 5.3.3, this worked without a problem so I am back in business :)

    Still would like to know how I can get a php 5.3 upgrade to minimal version 5.3.8

    Your advice will be highly appreciated.

    Thanks,
    Cas
    The reply is currently minimized Show
  • Accepted Answer

    Friday, July 04 2014, 12:53 PM - #Permalink
    Resolved
    0 votes
    The database warning occurs when you have installed an older version of Zarafa than you had previously been using, what version did you have? I gather from your other post you have fixed the Zarafa issues now

    Does your owncloud install work? if not run /usr/clearos/apps/owncloud/deploy/install again and post the output, thanks
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, July 03 2014, 06:34 PM - #Permalink
    Resolved
    0 votes
    Tim thank you for all of your help... I managed to get 5.3 installed will all modules as well. I have to remove dependencies that ties into Zarafa which basically removed Zarafafro the system. I got that reinstalled but it will not start due to error: WARNING: Database version (42779) is newer than the server version (62). I am guessing when I removed zarafa, it saved my old database and is now conflicting with the newly installed server which is wanting to use the new version. This is a good thing as I did not have a backup of the mail store and need to gain access to my old email account with emails, attachments, and public folders. I also noticed that my ldap does not seem to work with owncloud.

    Any additional advice?

    Here is the output for the rpm -qa | grep ^php | sort:

    php-5.3.3-27.el6_5.x86_64
    php-cli-5.3.3-27.el6_5.x86_64
    php-common-5.3.3-27.el6_5.x86_64
    php-gd-5.3.3-27.el6_5.x86_64
    php-imap-5.3.3-27.el6_5.x86_64
    php-intl-5.3.3-27.el6_5.x86_64
    php-ldap-5.3.3-27.el6_5.x86_64
    php-mapi-7.0.15-42709.x86_64
    php-mbstring-5.3.3-27.el6_5.x86_64
    php-mcrypt-5.3.3-3.el6.x86_64
    phpMyAdmin-3.5.8.2-1.v6.noarch
    php-mysql-5.3.3-27.el6_5.x86_64
    php-pdo-5.3.3-27.el6_5.x86_64
    php-pear-1.9.4-4.el6.noarch
    php-pear-Auth-SASL-1.0.4-1.el6.noarch
    php-pear-Mail-Mime-1.8.4-1.el6.noarch
    php-pear-Mail-mimeDecode-1.5.5-1.el6.noa rch
    php-pear-MDB2-2.5.0-0.9.b5.el6.noarch
    php-pear-MDB2-Driver-mysqli-1.5.0-0.8.b4 .el6.noarch
    php-pear-Net-Curl-1.2.5-4.el6.noarch
    php-pear-Net-IDNA2-0.1.1-3.el6.noarch
    php-pear-Net-LMTP-1.0.2-1.v6.noarch
    php-pear-Net-SMTP-1.6.1-1.el6.noarch
    php-pear-Net-Socket-1.0.10-1.el6.noarch
    php-process-5.3.3-27.el6_5.x86_64
    php-pspell-5.3.3-27.el6_5.x86_64
    php-xml-5.3.3-27.el6_5.x86_64
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, July 03 2014, 04:54 PM - #Permalink
    Resolved
    0 votes
    Al - that repo is for general testing and was for ClearOS 5.2

    ClearOS 6.x mirrors are here
    http://mirrorlist.clearfoundation.com/mirrorlist/

    The official version of PHP is available via yum (yum install php) which will pull in PHP v5.3.3 from the clearos-os repo, or for example:-
    http://mirror1.timburgess.net/clearos/community/6/os/x86_64/Packages/

    I note you have also mixed up architectures... your PHP output suggests you are running a 64bit system (x86_64) but you have installed i686 RPMs... which wont work. If you post the output of the command I put above we can help clean up the mess...
    rpm -qa | grep ^php | sort
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, July 03 2014, 12:03 PM - #Permalink
    Resolved
    0 votes
    Tim, when looking through the repo's, all I am seeing is "php-common-5.4.19". Where can I find 5.3.x?

    BTW, I am on 6.5 version of ClearOS. I had to go into ClearOS 5 repo's to find anything less than 5.4 in "http://download.clearfoundation.com/community/timb80/repo/clearos/";

    I did find 5.3 on your repo under 5.2. ftp://timburgess.net/repo/clearos/5.2/testing/php-common-5.3.8-5.clearos.i686.rpm - will this work with my 6.6 version of ClearOS? I have 64bit system (Kernel Version 2.6.32-431.17.1.v6.x86_64).

    Thank you for your help!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 02 2014, 09:08 PM - #Permalink
    Resolved
    0 votes
    Hi, unfortunately upgrading php will break zarafa due to the lack of a compatible php-mapi extension

    To get back to a working state you need to remove 5.4.19 completely and reinstall 5.3.x from the clearos repos.

    To help please identify whats installed
    rpm -qa | grep ^php | sort

    Edit: which version of ClearOS are you running? 5.2.17 is a build for ClearOS 5?
    The reply is currently minimized Show
Your Reply