FB Twitter YouTube LinkedIn GitHub G+
USB 3G UMTS as failover/loadbalancing?

Community Forum

Resolved
0 votes
Is clear os 5.1 compatible with samsung 3G UMTS modem and able to use it as wan interface and use it as failover/backup even loadbalancer for my existing adsl connection? Currently I'm using pfsense as my firewall/router/proxy problem and I don't have any problems with it except it does not support my 3G modem as failover/loadbalancer.

My laptop has ubuntu 9.10 installed and the samsung 3G usb modem works just fine. Since clear os also based on linux I guess there is high chance that clear os should be able to detect it too. If somebody can confirm it I'm migrating to clear os straight away!
Wednesday, January 27 2010, 03:21 PM
Share this post:
Responses (48)
  • Accepted Answer

    Wednesday, October 06 2010, 07:34 PM - #Permalink
    Resolved
    0 votes
    I hope this can eventually be feasible with kernel upgrades, etc. COS 6 perhaps???

    I've used the Cradlepoint CBA250 with excellent results. But it is an additional cost.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 05 2010, 01:40 PM - #Permalink
    Resolved
    0 votes
    Scumback and dope,

    I guess you are right. COS 5.2 does not claim to support USB 3G - and it does not seem to do so with simple hacking anymore - 5.1 did.

    My answer was to move the dongle to a Windows Machine and simply use Windows internt sharing as an interime solution until we get a cable based connection and I can reinstate my COS server. Your respective solutions seems equally good - except that in the case of zeroshell, I would seriously miss the mail server capability, so that is not a long term option for me.

    Sad but true.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    dope
    dope
    Offline
    Thursday, August 05 2010, 07:37 AM - #Permalink
    Resolved
    0 votes
    Peter Broch wrote:


    So, in short, what dongle are you using, what COS version are you using and did you faithfully follow the howto?

    Peter


    i was using a e220, using 5.1 with an updated kernel ,the hardware side seem to be all good as it sees the device and dials out and connects when i wvdail from shell.

    but i noticed it give a weird dns,
    11,12,13,14
    no matter what setting i used, and the webif would just show not connected.

    doesnt matter anyway i moved to zeroshell, where everything was plug and play with my modem also has a ping feature to test the connection for automatic failover.
    The reply is currently minimized Show
  • Accepted Answer

    Scumbag
    Scumbag
    Offline
    Wednesday, August 04 2010, 08:59 PM - #Permalink
    Resolved
    0 votes
    I went out and bought a Netcomm 3G18Wn - a wireless/ADSL/3G router which will do the job nicely for me. The router itself falls back to the 3G stick when the ADSL goes down. It would be nice for COS to do it, but it wasn't worth the hours in the end.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, August 04 2010, 04:00 PM - #Permalink
    Resolved
    0 votes
    Did you check that the ttyUSB* are created? I recently noticed that COS 5.2 does not seem to do this, even after coorecting the UDEV problem mentioned in my Howto mail on page 2 (I think) of this thread. I do not know why and did not have the time to investigate in detail.

    So, in short, what dongle are you using, what COS version are you using and did you faithfully follow the howto?

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    dope
    dope
    Offline
    Sunday, July 25 2010, 04:33 AM - #Permalink
    Resolved
    0 votes
    ive got a problem,
    ppp0 is displying "offline" "not in use" in multiwan
    i have no idea why it doesnt work because it is obtaining my external IP address from my ISP(static) and it looks like its connected as the modem is light is constantly lit.

    also when i type wvdial,it looks like its connects it obtains all the required info,everything looks like is connected but its not as i cant connect to it externally.

    any ideas?
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 23 2010, 11:22 AM - #Permalink
    Resolved
    0 votes
    Edit the /etc/firewall/ file to include ppp0 in the EXTIF= line, eg: EXTIF="eth0 ppp0"

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, May 16 2010, 09:56 PM - #Permalink
    Resolved
    0 votes
    I followed the post and I can connect via my 3G and DSL but I have a Prob, how do I change the ppp0 from LAN to External
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, May 11 2010, 03:21 PM - #Permalink
    Resolved
    0 votes
    Scumback,

    Review the entire howto. it is towards the bottom af page 2 of this thread. There are one or two other tricks to be mastered before it works.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Scumbag
    Scumbag
    Offline
    Monday, May 10 2010, 10:10 PM - #Permalink
    Resolved
    0 votes
    Jack Joshlin wrote:
    to make this very simple add a second wan nic and a cradle point http://www.amazon.com/Cradlepoint-CTR-350-Cellular-Travel-Router/dp/B001FWH0A0
    that will auto dial any usb 3g and just turn off the wireless and your set. it will dish out the wan its own ip and good to go. as far and the dns unless you locked by isp use googles dns 8.8.8.8 and you will see improved dns query's.


    Unfortunately :
    Currently, item can be shipped only within the U.S.


    I can probably source something similar locally, though it'll be cheaper to use an old Windows laptop, share the network connection and forward all the ports to the linux box. Either way it feels like a failure since the USB stick ought to work.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, May 10 2010, 08:13 PM - #Permalink
    Resolved
    0 votes
    to make this very simple add a second wan nic and a cradle point http://www.amazon.com/Cradlepoint-CTR-350-Cellular-Travel-Router/dp/B001FWH0A0
    that will auto dial any usb 3g and just turn off the wireless and your set. it will dish out the wan its own ip and good to go. as far and the dns unless you locked by isp use googles dns 8.8.8.8 and you will see improved dns query's.
    The reply is currently minimized Show
  • Accepted Answer

    Scumbag
    Scumbag
    Offline
    Saturday, May 08 2010, 12:44 AM - #Permalink
    Resolved
    0 votes
    Edit - I upgraded to Clearos 5.1 but have not yet installed Service Pack 1 (needs a monitor and KB hooked up for that). I located and changed the modules.alias file as described. I only see /dev/ttyUSB0 and /dev/ttyUSB1 when I ls -la /dev.

    Now I see:

    [root@orangezone1 ~]# lsusb
    Bus 001 Device 001: ID 0000:0000
    Bus 001 Device 002: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
    Bus 002 Device 001: ID 0000:0000
    Bus 002 Device 002: ID 8086:1120 Intel Corp.
    [root@orangezone1 ~]# usb_modeswitch

    * usb_modeswitch: tool for controlling "flip flop" mode USB devices
    * Version 0.9.7 (C) Josua Dietze 2009
    * Works with libusb 0.1.12 and probably other versions

    Looking for default devices ...
    Found default devices (1)
    Prepare switching, accessing device 002 on bus 001 ...
    Looking for active driver ...
    No driver found. Either detached before or never attached
    Setting up communication with interface 0 ...
    Trying to send the message to endpoint 0x01 ...
    Sending the message returned error -2. Trying to continue
    -> Run lsusb to note any changes. Bye

    [root@orangezone1 ~]#


    I only have a 2.6.18-128.2.16.v5 folder. It has a modules.alias file but it has no entries matching the one you describe.

    Does this mean I have to upgrade the kernel (and if so how do I go about that)?

    Edit - I'm running Clarkconnect Community Edition 5.0

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Friday, May 07 2010, 01:54 PM - #Permalink
    Resolved
    0 votes
    You likely suffer from a typo in COS' /lib/modules/2.6.18-164.6.1.v5/modules.alias file. The solution is below. It is a cut from my rough howto, which is towards the bottom af page 2 of this thread.

    Notice that "E620 USB Modem" is now recognised.

    Step 5: Check that ttyUSB0-ttyUSB2 have been created:

    Code:

    --------------------------------------------------------------------------------
    ls /dev/ttyUSB*
    /dev/ttyUSB0
    /dev/ttyUSB1
    /dev/ttyUSB2
    --------------------------------------------------------------------------------


    If not, you have to correct an error in the file /lib/modules/2.6.18-164.6.1.v5/modules.alias which prevents udev from establishing ttyUSB? ports for Huawei devices. Open the file and find all lines containg Code:

    --------------------------------------------------------------------------------
    icFFiscFFipFF* option
    --------------------------------------------------------------------------------

    (inclusive of the space). On my machine it is lines 3063-3081. Replace with Code:

    --------------------------------------------------------------------------------
    ic*isc*ip* option
    --------------------------------------------------------------------------------

    so the entries look like the entries above and below.



    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Scumbag
    Scumbag
    Offline
    Thursday, May 06 2010, 03:42 AM - #Permalink
    Resolved
    0 votes
    I have a K3520 and have been trying to get this working, but usb_modeswitch fails. As can be seen below, it's recognised by linux as an E620.

    The first time I ran usb_modeswitch I got this :

    [root@orangezone1 ~]# usb_modeswitch

    * usb_modeswitch: tool for controlling "flip flop" mode USB devices
    * Version 0.9.7 (C) Josua Dietze 2009
    * Works with libusb 0.1.12 and probably other versions

    Looking for default devices ...
    Found default devices (1)
    Prepare switching, accessing device 002 on bus 001 ...
    Looking for active driver ...
    OK, driver found ("option")
    OK, driver "option" detached
    Setting up communication with interface 0 ...
    Trying to send the message to endpoint 0x01 ...
    Sending the message returned error -2. Trying to continue
    -> Run lsusb to note any changes. Bye


    So I ran the following commands to list the config, and then ran usb_modeswitch again with different results:


    [root@orangezone1 ~]# lsusb
    Bus 002 Device 001: ID 0000:0000
    Bus 002 Device 002: ID 8086:1120 Intel Corp.
    Bus 001 Device 002: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
    Bus 001 Device 001: ID 0000:0000
    [root@orangezone1 ~]# tail -n5 /etc/usb_modeswitch.conf
    DefaultVendor = 0x12d1
    DefaultProduct = 0x1001
    MessageEndpoint = 0x01
    MessageContent = "55534243000000000000000000000011060000000000000000000000000000

    [root@orangezone1 ~]# usb_modeswitch

    * usb_modeswitch: tool for controlling "flip flop" mode USB devices
    * Version 0.9.7 (C) Josua Dietze 2009
    * Works with libusb 0.1.12 and probably other versions

    Looking for default devices ...
    Found default devices (1)
    Prepare switching, accessing device 002 on bus 001 ...
    Looking for active driver ...
    No driver found. Either detached before or never attached
    Setting up communication with interface 0 ...
    Trying to send the message to endpoint 0x01 ...
    Sending the message returned error -2. Trying to continue
    -> Run lsusb to note any changes. Bye


    What should I be looking at to fix this?

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 13 2010, 12:35 PM - #Permalink
    Resolved
    0 votes
    Malte,

    Excellent.

    You do not require usb_modewitch anymore. However, it does no harm so remove it at your convenience.

    Read the sierra page I linked in my previous post. Especially, read the part at the bottom of the page about sending control messages to the modem and how they are sent. Wvdial need som updating to prepare the modem and use the right port. Try running wvdialconfig to refresh the setup.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 12 2010, 10:25 PM - #Permalink
    Resolved
    0 votes
    Thanks Peter :) it seems to be working well, i've been running it on my production system for over a month now

    Glad the modem is recognised Malte in the new kernel, however I have no futher exprience with USB Modeswitch so can't help much further, sorry!
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 12 2010, 07:46 PM - #Permalink
    Resolved
    0 votes
    Hello,
    Thanks for your answers. Now I have updated the kernel to 2.6.31.12. Now the modem was automatically detected as 1199:6890. When I start USB_Modeswitch:
    Looking for target devices ...
    Found devices in target mode or class (1)
    Looking for default devices ...
    Found devices in default mode or class (1)
    Accessing device 010 on bus 001 ...
    Using endpoints 0x01 (out) and 0x81 (in)
    Not a storage device, skipping SCSI inquiry

    USB description data (for identification)
    -------------------------
    Manufacturer: Sierra Wireless, Incorporated
    Product: HSPA Modem
    Serial No.: not provided
    -------------------------
    Trying to send Sierra control message
    OK, Sierra control message sent
    Warning: ignoring MessageContent. Can't combine with special mode
    -> Run lsusb to note any changes. Bye.

    But I’m not sure: Is the USB_Modeswitch now necessary?
    Now the USBttyX devices are added. But the wvdial found no modem. The version of the Sierra driver is 1.3.7. What can I do to use my Sierra Wireless HSDPA Modem with wvdial?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 12 2010, 12:53 PM - #Permalink
    Resolved
    0 votes
    Thanks Tim, I did recall seeing something about your major opus on the forum a while ago. I did not know it had already succeded. I am impressed.

    Malte, installing Tim's new kernel is easy and might make your modem work out of the box. Only problem could be that the built-in driver is the old sierra.ko 1.3.7 which may or may not work for you. The solution to that would be downloading and installing sierra.ko 1.7.30, which can be downloaded from this sierra page. Compile and install should again be easy (see instructions in the link) and it should definitly do the job. Tim's kernel (version 2.6.31) does NOT require patching.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 12 2010, 12:08 PM - #Permalink
    Resolved
    0 votes
    Simplest option from my point of view is to try out my 2.6.31.12 kernel i've been working on here :) you can remove it afterwards if it doesn't work for you. Subsitite with the PAE kernel if you have more than 4GB RAM
    http://www.clearfoundation.com/component/option,com_kunena/Itemid,232/catid,40/func,view/id,8484/lang,en/
    If you have added any of your own modules you will also have to install kernel-devel, and recompile them

    It is feasible to use the patches on the kernel (2.6.18.x) provided by Sierra assuming they apply ok, however the full build process takes some 3-4hours, so unless you have any real objections i'd try the newer kernel first?

    2.6.31-12 has version 1.3.7 of the Sierra module in it so no worries there
    [root@starlane ~]# modinfo sierra
    filename: /lib/modules/2.6.31.12-174.2.22.timb1.i686/kernel/drivers/usb/serial/sierra.ko
    license: GPL
    version: v.1.3.7
    description: USB Driver for Sierra Wireless USB modems
    author: Kevin Lloyd, Elina Pasheva, Matthew Safar, Rory Filer


    EDIT: Just noticed on the linkt that propose only a rebuild of the usb storage modules so could be a lot easier to implement, i'll have a look
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 12 2010, 11:15 AM - #Permalink
    Resolved
    0 votes
    You may still need to do the modification of udev I mentioned in my first post on this. Without that, the UBS system does not recognize the modem.

    I have never patched, upgraded or downgraded a kernel so I don't know. But I would guess patching is the easiest approch since there would be no need to recompile other packages on the machine.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, April 11 2010, 10:31 AM - #Permalink
    Resolved
    0 votes
    Hello Peter,
    I’ve found in etc/usb_modeswitch.de a file 1199:0fff. But in this file is no target Product ID 6890. So I’ve added my target product ID, but it doesn’t work. Is it easier to update to a newer Kernel version (2.6.23 or newer) or patch the existing Kernel with the driver.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, April 11 2010, 07:02 AM - #Permalink
    Resolved
    0 votes
    Good the upgrade worked. But without /dev/ttyUSBx devices you can connect to, no cigar.

    I cannot find the special control message string you require on my setup; but it may be in your newer version of usb_modeswitch. Check the /etc/usb_modewitch.d file for any references that matches your modem name or the modem's usb ID. The string should be in that section, if it exists.

    If it does not exist, you are down to following Sierra's detailed descriptions on installing an updated driver (just like installing the updated usb_modeswitch) and patching the kernel. They are here.

    The hairy part is kernel patching which I have never attempted. But others could surely help with that. Tim, anybody?

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 10 2010, 05:28 PM - #Permalink
    Resolved
    0 votes
    Hello,
    I have edited my last post, because the update was successful. In the /dev is no file for ttyUSB0 and ttyUSB1 (like the machine with the Huawei modem). Is it correct? Can you answer my last question to the message in USB_modeswitch?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 10 2010, 04:46 PM - #Permalink
    Resolved
    0 votes
    Before going into upgrading modeswitch, take a look at this. If that does not solve the problem, follow this guide.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, April 10 2010, 04:19 PM - #Permalink
    Resolved
    0 votes
    Hello Peter,
    Now I think the problem is the usb_modeswitch. In your How to is version 0.9.7 as RPM File used. On the website of usb_modeswitch is version 1.1.1 available. I’ve updated my System to ver. 1.1.1. But the error message is the same (-71). In the config file stands:
    # Some Sierra devices can be switched by a special control
    # message.

    Where can I get the special control message for my Compass 888/889?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 08 2010, 01:01 PM - #Permalink
    Resolved
    0 votes
    I took a quick look at your link (which by the way is invalid: http:// is duplicated). I then looked at CentOS (the basis of COS 5.1 -meaning the same kernel version) and found this list of devices that are supported. It includes sierra ID 1199:6890 which is the ID you previously gave. I also checked that the sierra.ko module is present. It is. So no need to install the driver etc - it is already there.

    For starters, did you do ls /dev/*USB*/ to determine if the USB ports are created? If they are not, it likely is a matter of UDEV's config file missing rules for your device.

    Start by editing the file lib/modules/2.6.18-164.6.1.v5/modules.alias. Find the sierra section, copy one of the lines into a new line and modify that line, say the one containing "v1199p6820" to contain "v1199p6890", save the file and then insert the modem and see what happens.

    If that does not work, chances are that COS removed the kernel support and patching of the kernel to get it back is required. This is not for the faint of hart (I never dared) but it can be done. If required, this COS HowTo is helpfull to get you started. There is also a lot of information on this in the old CC forums.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 07 2010, 07:19 PM - #Permalink
    Resolved
    0 votes
    Hello,
    Yesterday I have found a manual from sierra wireless about the UMTS modems:

    Link


    Is the TRU-Install Patch Instructions necessary to use this Stick with ClearOS? If yes is a manual for updating the ClearOS Kernel available?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 07 2010, 11:53 AM - #Permalink
    Resolved
    0 votes
    Sounds like a udev problem. You will likely need to add or modify the udev rules for Sierra. /lib/modules/2.6.18-164.6.1.v5/modules.alias is the file to modify.

    I don't have the device so I do not know which changes are required but Googling for Sierra udev gave a number of promising entries for Ubuntu and other Linux distributions. These should work for CC as well since udev is linked to the kernel that is common for all.

    Peter
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 06 2010, 07:05 PM - #Permalink
    Resolved
    0 votes
    Hello,
    now I have installed usb_modeswitch to activate the modem with the following configuration:

    DefaultVendor= 0x1199
    DefaultProduct= 0x0fff

    ;TargetVendor= 0x1199
    ;TargetProduct= 0x6890

    SierraMode=1



    Here a Screenshot of my Linux Console:

    # lsusb
    Bus 001 Device 015: ID 1199:0fff Sierra Wireless, Inc.
    Bus 001 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    #usb_modeswitch

    * usb_modeswitch: tool for controlling "flip flop" mode USB devices
    * Version 0.9.7 (C) Josua Dietze 2009
    * Works with libusb 0.1.12 and probably other versions

    Looking for default devices ...
    Found default devices (1)
    Prepare switching, accessing device 015 on bus 001 ...
    Trying to send Sierra control message
    Error: sending Sierra control message failed (error -71). Aborting.

    # lsusb
    Bus 001 Device 016: ID 1199:6890 Sierra Wireless, Inc.
    Bus 001 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000

    But if I start usb_modeswitch I get error -71 and wvdial cannot find a Modem.

    Where is the mistake here?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 06 2010, 05:38 PM - #Permalink
    Resolved
    0 votes
    Hello,
    now I have changed my Huawei Modem ino a Sierra Wireless Compass 888/889 Modem. But this Modem won't be detected by my ClearOS. The wvdial command don't detected the modem too. What can I do to use this Modem on the ClearOS?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 13 2010, 01:44 PM - #Permalink
    Resolved
    0 votes
    Thanks Peter, great post!
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 13 2010, 07:01 AM - #Permalink
    Resolved
    0 votes
    After a bit of tinkering I have now got my Huawei E1550 to work consistently on COS 5.1. It took the following steps:

    Step 1: Insert the usb modem in a Windows machine, install the software (its on the stick and should install automatically) and register the modem with your ISP. This also serves to test usability (signal strenght etc.) and allows you to set various parameters, such as always using 3G rather than slower modes. The software can be deleted afterwards. Note the login details:
    APN, dial-in number (often *99# - that was mine), and - if required - username and password (not required in my case).

    Step 2: Insert the usb modem in CC and test that it is recognized by USB:

    /$ lsusb
    Bus 001 Device 009: ID 12d1:1001 Huawei Technologies Co., Ltd.
    Bus 001 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 005 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000

    Step 3: Download and install usb_modeswitch:

    /$ wget "http://rpms.arrfab.net/centos/testing/i386/usb_modeswitch/usb_modeswitch-0.9.7-1.el5.test.i386.rpm"
    /$ rpm -i ./usb_modeswitch-0.9.7-1.el5.test.i386.rpm

    Add the following to the end of the configuration file /etc/usb_modeswitch.conf (courtesy of Ahmed Soliman, http://www.ahmedsoliman.com/2009/07/12/etisalat-usb-modem-on-fedora-11/):

    # Huawei E1550
    DefaultVendor = 0x12d1
    DefaultProduct = 0x1446
    MessageEndpoint = 0x01
    MessageContent = "55534243000000000000000000000011060000000000000000000000000000

    Step 4: Run USB_Modeswitch and test that the modem is indeed detected as a modem:

    /$ usb_modeswitch
    * usb_modeswitch: tool for controlling "flip flop" mode USB devices
    * Version 0.9.7 (C) Josua Dietze 2009
    * Works with libusb 0.1.12 and probably other versions
    Looking for default devices ...
    Found default devices (1)
    Prepare switching, accessing device 010 on bus 001 ...
    Looking for active driver ...
    OK, driver found ("usb-storage")
    OK, driver "usb-storage" detached
    Setting up communication with interface 0 ...
    Trying to send the message to endpoint 0x01 ...
    OK, message successfully sent
    -> Run lsusb to note any changes. Bye

    Do as suggested:

    /$ lsusb
    Bus 001 Device 011: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
    Bus 001 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 005 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000

    Notice that "E620 USB Modem" is now recognised.

    Step 5: Check that ttyUSB0-ttyUSB2 have been created:

    ls /dev/ttyUSB*
    /dev/ttyUSB0
    /dev/ttyUSB1
    /dev/ttyUSB2

    If not, you have to correct an error in the file /lib/modules/2.6.18-164.6.1.v5/modules.alias which prevents udev from establishing ttyUSB? ports for Huawei devices. Open the file and find all lines containg
    icFFiscFFipFF* option
    (inclusive of the space). On my machine it is lines 3063-3081. Replace with
    ic*isc*ip* option
    so the entries look like the entries above and below.

    Step 6: Download and install wvdial:

    /$ yum install wvdial

    Setup wvdial to call your ISP:

    Create /etc/wvdial.conf (if it does not already exist) with the following contents (modify the lines with comments to suit your isp's requirements, see step 1):

    [Dialer Defaults]
    Init1 = ATZ
    Init2 = ATE0V1&D2&C1S0=0+IFC=2,2
    Stupid Mode = 1
    Modem TYPE = Analog Modem
    Auto dns = 0 # My ISP's DHCP is fickly (gives wrong default addresses), so better disable.
    ISDN = 0
    Phone = *99# # this is my dial-up number - yours may differ
    Init3 = AT+CGDCONT=1,"IP","fbband"; # fbband is my APN - yours will almost certainly differ
    Modem = /dev/ttyUSB0
    username = username #I do not require a username so this is a dummy
    Dial Command = ATDT
    password = password #I do not require a password so this is a dummy
    Baud = 921600

    You may have to experiment with some of these settings. Whatever your ISP likes governs.

    Start the connection:

    /$ wvdial

    and check that it is actually started:

    /$ ifconfig

    There should be a new ppp0 interface.

    Open (or create if it does not exist) /etc/sysconfig/network-scripts/ifcfg-ppp0 with the following contents:

    DEVICE=ppp0
    NAME=DSLppp0
    TYPE="dialup"
    BOOTPROTO="dialup"
    WVDIALSECT=Default
    MODEMPORT=/dev/ttyUSB0
    LINESPEED=921600
    PAPNAME=test
    USERCTL=true
    ONBOOT=yes
    PERSIST=no
    DEFROUTE=yes
    PEERDNS=no
    DEMAND=no
    IDLETIMEOUT=600

    Note: Do NOT edit the ppp0 interface from webconfig (Network -> IP Settings). That wil overwrite the dialup ppp0 file with the stock xDSL ppp0 configuration file.

    Step 7. Make the modem switching mode and connecting automagically at boot or whenever the modem is inserted.

    Create /etc/udev/rules.d/15-huawei-1550-modem.rules with the following contents in one line:

    ACTION=="add",SUBSYSTEM=="usb_device",SYSFS{idProduct}=="1446",SYSFS(idVendor}=="12d1",RUN+="/usr/sbin/usb_modeswitch"

    and save it.

    UPDATE: Find and open /etc/ppp/ip-up.local and insert the following as the first line:

    /sbin/user/wvdial

    Notes: Steps 3, 4, 5 and 7 are temporary fixes until CC's kernel version is upgrade to 2.6.20 or higher; where I understand the functionality is built-in and automatic.

    Be warned that USB modems do not always play well with wireless cards. In the worst case, it can disable the usb system or even freeze the server.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 10 2010, 10:23 PM - #Permalink
    Resolved
    0 votes
    DNS caching in windows :

    ipconfig /flushdns


    Linux :
    Flush DNS in Linux

    In Linux, the nscd daemon manages the DNS cache. To flush the DNS cache, restart the nscd daemon. To restart the nscd daemon, use the command `/etc/init.d/nscd restart`


    More on flush dns : http://www.topbits.com/how-to-flush-dns.html
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, February 10 2010, 08:43 AM - #Permalink
    Resolved
    0 votes
    Hi,
    now I have edit this file and checked the correct DNS IP adress by another Program for Windows. But my ClearOS doesn't work with this DNS. If I type an IP Adress (e.g. the IP of Google) into the Webbrowser, it works. Knows anybody where the Error could be?

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, February 07 2010, 02:33 PM - #Permalink
    Resolved
    0 votes
    # cat /etc/resolv.conf
    nameserver 194.168.4.100
    nameserver 194.168.8.100
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, February 07 2010, 02:08 PM - #Permalink
    Resolved
    0 votes
    I know my DNS Settings for the UMTS Modem. My problem is, that I can't edit the settings on the ClearOS WebGui. So I want to know where I can edit the DNS Settings in the Configuration Files of the System.

    Thanks
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 05 2010, 11:23 PM - #Permalink
    Resolved
    0 votes
    Maybe try : http://umtsmon.sourceforge.net/ on other gui linux ,and see what settigns you need for your phone ?

    http://www.void.gr/kargig/blog/2009/07/08/vodafone-cosmote-3g-on-linux-wvdial-and-umtsmon/
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 05 2010, 07:44 PM - #Permalink
    Resolved
    0 votes
    Thanks for your answer. It works. But now my ClearOS don't change the IP of the external DNS. How Can I Change the DNS to Automatic Mode from the mobile 3G Modem?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 05 2010, 04:48 PM - #Permalink
    Resolved
    0 votes
    You can manually add it to the following line, e.g. EXTIF="eth0 ppp0" in /etc/firewall. Changes in the webconfig IP settings page will cause thos modification to go unforuntately
    The reply is currently minimized Show
  • Accepted Answer

    Friday, January 29 2010, 06:24 PM - #Permalink
    Resolved
    0 votes
    Hi,
    thanks for the feedback. The wvdial works fine, but i've got another problem. I can't change the ppp0 Connection into an external LAN on the WebGUI. Can you tell me how I can change the Connectiontype of the ppp0 Connection? The How To with the Dummy ethX Card doesn't work.
    The reply is currently minimized Show
Your Reply