Forums

Sean Daks
Sean Daks
Offline
Resolved
0 votes
Hello,

Background:

Home office person here, recently I moved from opnsense over to clearos community edition. I have everything working fairly well, I even was able to troubleshoot an issue with multi-wan not working correctly, during setup the gui was stating "Multi-WAN is updating status information, this will only take a few seconds.." and never actually updating. (Turned out the service wasn't starting for some reason and going to shell and systemctl start syswatch fixed it, then systemctl enable syswatch.) I've also done some customizing of the syswatch.conf per my preferences.
My box is a commodity 4-port mini-pc with J1800 CPU and intel 82583v gigabit adapters.

Anyway, on to the (minor) issue:

The DHCP lease from my primary WAN Connection is not getting the external IP from the ISP, rather the private IP is being leased from the cable modem (in the 10.0.0.x range). The cable modem is in gateway/bridge mode. If I power it off and connect it to a PC directly and power on it will initially assign a 10.0.0.x IP but then it will auto-refresh and the PC will show the external wan IP (usually a 76.x.x.x range). If I change the MAC address that's connecting to the modem, then the modem has to be powered off/on in order to assign an internet IP. It's definitely getting an internet IP and routing traffic, it's just not showing the WAN IP in the ifconfig, ip a, or gui ip settings pages. I can find it in whatismyip and other websites.

Best of my knowledge I don't think Clearos/Centos is catching the refreshed IP Assignment from the modem. I've tried all combinations of starting the cable modem from power off/on and clearos box off/on order. I've also tried manually to ifconfig down/up and dhclient -r enp1s0 to refresh the DHCP, but it's sticking with the 10.0.0.x leases.

All this said, connections to the internet are working fine, so perhaps it's just a cosmetic issue?
Tuesday, June 30 2020, 06:44 PM
Share this post:
Responses (7)
  • Accepted Answer

    Saturday, July 11 2020, 08:53 AM - #Permalink
    Resolved
    0 votes
    As another thought, if you don't have the file /etc/dhcp/dhclient.conf, create one, then put in it:
    supersede dhcp-server-identifier 255.255.255.255;
    I used to do it for a different reason (where the ISP was sending back an invalid DHCP server in the reply), but another user has reported success where he was not getting an IP address at all.

    [edit]
    Have a look in this thread for more info. I used that setting for years until I changed ISP but, as noted in the thread, it caused me a problem once.
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Sean Daks
    Sean Daks
    Offline
    Saturday, July 04 2020, 02:22 AM - #Permalink
    Resolved
    0 votes
    Thanks, some of the diagnostics in that thread are a bit beyond my comfort level but otherwise it does have some similarities. I've checked the /var/log/syswatch and don't see any odd messages of late, just heartbeats mostly. Will maybe try some more diagnostics to narrow down issue later this week. I have a vm setup with clearos on a different box want to see if it's happening there too. Pretty sure it was but want to validate.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, July 03 2020, 12:54 PM - #Permalink
    Resolved
    0 votes
    I don't think it is relevant but have a read of this thread. It may have some useful info. You may also want to do a tcpdump on the interface to try and watch what is happening.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, June 30 2020, 08:51 PM - #Permalink
    Resolved
    0 votes
    As it is now enabled, syswatch is one of the programs servicewatch monitors and will attempt to restart every 5 minutes.
    The reply is currently minimized Show
  • Accepted Answer

    Sean Daks
    Sean Daks
    Offline
    Tuesday, June 30 2020, 08:07 PM - #Permalink
    Resolved
    0 votes
    duplicate post pls delete
    The reply is currently minimized Show
  • Accepted Answer

    Sean Daks
    Sean Daks
    Offline
    Tuesday, June 30 2020, 08:03 PM - #Permalink
    Resolved
    0 votes
    Yeah, I think syswatch is running ok, although today it was saying the primary interface was down and it wouldn't come back online until I restarted the system. I first tried bringing the interface down/up and restarting syswatch but neither would let me ping through the primary interface. Upon restart of the clearos router hw everything was working but that's when I noticed the wan IP still was using 10.0.0.x in the lease assignment. If syswatch fails again I'll try to capture some info in the logs to figure out why.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, June 30 2020, 07:20 PM - #Permalink
    Resolved
    0 votes
    I've seen the syswatch issue elsewhere before. I may have to try to find out why. When it is installed, it should be enabled and set running automatically.

    The WAN IP issue is odd. Someone else had problems getting DHCP leases but it never got resolved. It is probably not related but you may try the version of syswatch in clearos-updates-testing, but syswatch should fire after the lease is obtained. When I had a DHCP cable modem I never had any problems with it in bridge mode so I have no experience of that issue (I did have a different problem .......). Now I have a PPPoE connection.
    The reply is currently minimized Show
Your Reply