Community Forum

Resolved
0 votes
Is it possible to install a wireless card and ClearOS act as a wireless hotspot / access point?

Thanks! :lol:
Tuesday, November 10 2009, 08:33 PM
Share this post:
Responses (73)
  • Accepted Answer

    oLdciTy
    oLdciTy
    Offline
    Saturday, April 04 2015, 05:04 PM - #Permalink
    Resolved
    0 votes
    :cheer: :) nice baby steps,. . . hehehehee eee
    The reply is currently minimized Show
  • Accepted Answer

    Intelliant
    Intelliant
    Offline
    Thursday, October 07 2010, 12:43 PM - #Permalink
    Resolved
    0 votes
    Confirmed. It works. Thanks Tony. Need to just fine tune things now and a bit of 'immutation' care.
    The reply is currently minimized Show
  • Accepted Answer

    Intelliant
    Intelliant
    Offline
    Saturday, October 02 2010, 03:59 PM - #Permalink
    Resolved
    0 votes
    Thanks Tony, Will get time to try this tomorrow. Shall revert with results.
    The reply is currently minimized Show
  • Accepted Answer

    Tony Ellis
    Tony Ellis
    Offline
    Wednesday, September 29 2010, 03:51 AM - #Permalink
    Resolved
    0 votes
    Fortunately the machine came up straigt away once connected.. so here you go. Pretty standard, sorry for the length. Key has been sanitised - XX for the real Hex characters. "/etc/sysconfig/network-scripts/ifcfg-wlan0" and "/etc/modprobe.conf" have the immutable bit set so Webconfig cannot change them. "/etc/firewall" is edited by hand as Webconfig cannot handle the device names for the USB Wireless adaptors that are occasionally enabled.


    [root@via-epia ~]# cat /etc/sysconfig/network-scripts/ifcfg-wlan0
    DEVICE=wlan0
    TYPE="Wireless"
    ONBOOT="yes"
    USERCTL="no"
    ESSID="sraellis.no-ip.com"
    CHANNEL="1"
    MODE="Managed"
    KEY="XXXXXXXXXXXXXXXXXXXXXXXXXX"
    RATE="auto"
    BOOTPROTO="static"
    IPADDR="192.168.2.15"
    NETMASK="255.255.255.0"
    #GATEWAYDEV="wlan0"
    GATEWAY="192.168.2.254"
    HWADDR="00:11:d8:8a:f1:78"
    [root@via-epia ~]#

    [root@via-epia ~]# cat /etc/modprobe.conf
    # Network
    alias eth0 tulip
    alias eth1 via-rhine
    alias eth2 rtl8150
    alias wlan0 rt2500pci
    #alias rausb0 rt2570
    #alias eth3 asix
    # I2C module options for sensors
    alias char-major-89 i2c-dev
    # Sound
    alias snd-card-0 snd-via82xx
    options snd-card-0 index=0
    options snd-via82xx index=0
    remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
    [root@via-epia ~]#

    [root@via-epia ~]# iwconfig wlan0
    wlan0 IEEE 802.11bg ESSID:"sraellis.no-ip.com"
    Mode:Managed Frequency:2.412 GHz Access Point: 0:22:B0:8E:E9:05
    Bit Rate=54 Mb/s Tx-Power=20 dBm
    RTS thr:off Fragment thr:off
    Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX
    Power Management:off
    Link Quality=47/70 Signal level=-63 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    [root@via-epia ~]#

    [root@via-epia ~]# ifconfig wlan0
    wlan0 Link encap:Ethernet HWaddr 00:11:D8:8A:F1:78
    inet addr:192.168.2.15 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::211:d8ff:fe8a:f178/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3234 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1303 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1006270 (982.6 KiB) TX bytes:191461 (186.9 KiB)

    [root@via-epia ~]#

    [root@via-epia ~]# lspci -v
    ... cut ...
    00:14.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
    Subsystem: ASUSTeK Computer Inc. WL-130g
    Flags: bus master, slow devsel, latency 32, IRQ 5
    Memory at e7000000 (32-bit, non-prefetchable) [size=8K]
    Capabilities: [40] Power Management version 2
    ... cut ...

    [root@via-epia ~]# cat /etc/firewall
    ...cut ...
    MODE="gateway"


    # Interface roles
    #----------------

    EXTIF="wlan0 eth2"
    LANIF="eth0 eth1"
    DMZIF=""
    WIFIF=""
    HOTIF=""
    DNSIF="eth2"
    ... cut...
    The reply is currently minimized Show
  • Accepted Answer

    Intelliant
    Intelliant
    Offline
    Tuesday, September 28 2010, 07:21 PM - #Permalink
    Resolved
    0 votes
    Tony, I did not do anything to /etc/firewall. Yet it may not be an issue at this stage when 'iwconfig wlan0' itself does not return satisfactory results.

    Tim, I did try with WEP 128-bit key as well. I issued the following :
    iwconfig wlan0 essid <essid>
    iwconfig wlan0 mode Managed
    iwconfig wlan0 channel 6
    iwconfig wlan0 key <128-bit WEP key>
    iwconfig wlan0 ap 00:08:5C:9D:AD:58

    Thereafter restarted the network. Also added the above lines to ifcfg-wlan0, but all to no avail even on a reboot.

    Found something confusing as well - http://linuxwireless.org/en/users/Devices/PCI
    Herein the Linksys WMP54G PCI card seems to be supported by b43 driver and is supposed to have a Broadcom chipset. Will be able to confirm the exact chipset tomorrow after checking in a Windows system which has a similar card installed and configured properly.

    Also do you think this is possible, that a Ralink driver is picked up for a Broadcom chipset? APAIK, not possible as I even observed the link to be working,although for a very short period only. May be I will give the new kernel a shot as well. But want to rule out everything else prior to that.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 28 2010, 02:32 PM - #Permalink
    Resolved
    0 votes
    P.S- you might also be intersted in trying wireless in the newer kenel i've been testing (2.6.32) which has support for more hardware out of the box
    http://download.clearfoundation.com/community/timb80/kernel/
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 28 2010, 02:30 PM - #Permalink
    Resolved
    0 votes
    Just for information the webconfig only supports WEP and parameters that can be configured by the tool iwconfig. To this extent it relies heavily on the driver functionality of your card...try each parameter one by one using iwconfig on the command line.

    So if you card and driver combo requires any others (such as using iwpriv to set the channel or rate etc) or third party binary to construct the interface (such as madwifi) then you'll need to setup manual commands in /etc/rc.d/rc.local so that you card is configured on boot. I eventually setup WPA2-PSK this way

    You will then have to maintain it outside of the webconfig, as updating the webconfig will pontetially overwrite your working config. I have found more success by keeping the parameters in ifcfg-wlan0 to a minimum.

    Oh and wireless support is flagged for ClearOS6.0 :)
    The reply is currently minimized Show
  • Accepted Answer

    Tony Ellis
    Tony Ellis
    Offline
    Tuesday, September 28 2010, 02:00 PM - #Permalink
    Resolved
    0 votes
    From memory (not necessarily trustworthy) the following were setup by hand...

    /etc/modprobe.conf, /etc/firewall and /etc/sysconfig/network-scripts/ifcfg-wlan0
    The reply is currently minimized Show
  • Accepted Answer

    Intelliant
    Intelliant
    Offline
    Tuesday, September 28 2010, 01:42 PM - #Permalink
    Resolved
    0 votes
    Can you as of now confirm if the only file with any config changes is ifcfg-wlan0 or are there other files as well?

    Patience is something I would like to practice but herein after 6 hours of reading and hunting I am clueless as I am not getting any errors in the logs as well.

    Looking forward to the config file dump as well. :)
    The reply is currently minimized Show
  • Accepted Answer

    Tony Ellis
    Tony Ellis
    Offline
    Tuesday, September 28 2010, 12:37 PM - #Permalink
    Resolved
    0 votes
    You will have to be patient...

    This machine is not currently in use, but still intact. Maybe I can find time
    to fire it up sometime soon and extract the information you want. The wireless link between my office and the cable modem has been replaced by a pair of Netgear Powerline AV+ 200 adapters that are about 3x + faster than what the wireless link was...
    The reply is currently minimized Show
Your Reply