0 votes

I have installed Web Server and Wordpress to my ClearOS 7.5 install. We have been able to configure and design the Wordpress site but the problem I am experiencing is that the site displays the standard ClearOS landing page as if no site content existed. I did do some digging through the forums but I did not find anything that explicitly links the Wordpress content to the webserver. I also looked for HowTos but only find one and the link to an external site is dead.

For example, I know that the webserver looks in /var/www/html or /var/www/html/virtual and that it also links to a flexshare that shares the name of the site.

So, do I symlink the wordpress site's folder to the Apache default, the flexshare, or copy the contents of the wordpress folder to the site's html folder? If none of those are correct, how do I go about achieving my goal of having the wordpress site be the live site?

If this is a completely noob question, I apologize but I am a noob when it comes to wordpress!

Thank you in advance to anyone who has an answer!
Thursday, November 29 2018, 04:17 PM
Share this post:
Responses (1)
  • Accepted Answer

    Friday, November 30 2018, 11:38 AM - #Permalink
    0 votes
    Yes, the content of your WordPress site and its folders should reside in /var/www/html.

    So, I'm assuming you added your website in the Webconfig and selected and enabled a php server version in its configuration, since you show a flexshare for it. You'll want to make sure you enable the php version in the Webconfig under your website configuration and in server>web>php, then make sure both the httpd and rh-phpxx-php-fpm services are running in the Webconfig, under system>settings>services. I use Joomla, not WordPress, but I'm pretty sure WordPress implements php. You'll probably also want to make sure apache has ownership of your folders and files recursively in /var/www/html, or change the user and group settings in http.conf to however you have them in your web root.

    You'll want to make sure port 80 is open on your incoming firewall rules too.
    The reply is currently minimized Show
Your Reply