Forums

Resolved
0 votes
Updates are not working properly on ClearOS 5.2, giving the following errors:

Error: Missing Dependency: liblber-2.3.so.0 is needed by package openswan
Error: Missing Dependency: libldap-2.3.so.0 is needed by package openswan



# yum repolist
Loading "protect-packages" plugin
Loading "kmod" plugin
repo id repo name status
base-console ClearOS Enterprise 5.2 - Console enabled
base-kernels ClearOS Enterprise 5.2 - Kernels enabled
base-os ClearOS Enterprise 5.2 - OS enabled
base-supplements ClearOS Enterprise 5.2 - Supplements enabled
base-updates ClearOS Enterprise 5.2 - Updates enabled
clearcentos-os ClearOS 5.x - Minified CentOS - OS enabled
clearcentos-updates ClearOS 5.x - Minified CentOS - Updates enabled


# yum update
Loading "protect-packages" plugin
Loading "kmod" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package openswan.i386 0:2.6.32-3.el5 set to be updated
--> Processing Dependency: liblber-2.3.so.0 for package: openswan
--> Processing Dependency: libldap-2.3.so.0 for package: openswan
--> Finished Dependency Resolution
Error: Missing Dependency: liblber-2.3.so.0 is needed by package openswan
Error: Missing Dependency: libldap-2.3.so.0 is needed by package openswan


# yum upgrade
Loading "protect-packages" plugin
Loading "kmod" plugin
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package openswan.i386 0:2.6.32-3.el5 set to be updated
--> Processing Dependency: liblber-2.3.so.0 for package: openswan
--> Processing Dependency: libldap-2.3.so.0 for package: openswan
--> Finished Dependency Resolution
Error: Missing Dependency: liblber-2.3.so.0 is needed by package openswan
Error: Missing Dependency: libldap-2.3.so.0 is needed by package openswan


# cat /etc/redhat-release
CentOS release 5.5 (Final)

# cat /etc/clearos-release
ClearOS release 5.2


# ls /etc/yum.repos.d
base.repo


# cat /etc/yum.repos.d/base.repo
[base-os]
name=ClearOS Enterprise 5.2 - OS
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2
http://download1.clearfoundation.com/clearos/enterprise/5.2
http://download2.clearfoundation.com/clearos/enterprise/5.2
http://download3.clearfoundation.com/clearos/enterprise/5.2
http://download4.clearfoundation.com/clearos/enterprise/5.2
gpgcheck=1

[base-console]
name=ClearOS Enterprise 5.2 - Console
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/console
http://download1.clearfoundation.com/clearos/enterprise/5.2/console
http://download2.clearfoundation.com/clearos/enterprise/5.2/console
http://download3.clearfoundation.com/clearos/enterprise/5.2/console
http://download4.clearfoundation.com/clearos/enterprise/5.2/console
gpgcheck=1

[base-updates]
name=ClearOS Enterprise 5.2 - Updates
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/updates
http://download1.clearfoundation.com/clearos/enterprise/5.2/updates
http://download2.clearfoundation.com/clearos/enterprise/5.2/updates
http://download3.clearfoundation.com/clearos/enterprise/5.2/updates
http://download4.clearfoundation.com/clearos/enterprise/5.2/updates
gpgcheck=1

[base-supplements]
name=ClearOS Enterprise 5.2 - Supplements
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/supplements
http://download1.clearfoundation.com/clearos/enterprise/5.2/supplements
http://download2.clearfoundation.com/clearos/enterprise/5.2/supplements
http://download3.clearfoundation.com/clearos/enterprise/5.2/supplements
http://download4.clearfoundation.com/clearos/enterprise/5.2/supplements
gpgcheck=1

[base-kernels]
name=ClearOS Enterprise 5.2 - Kernels
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/kernels
http://download1.clearfoundation.com/clearos/enterprise/5.2/kernels
http://download2.clearfoundation.com/clearos/enterprise/5.2/kernels
http://download3.clearfoundation.com/clearos/enterprise/5.2/kernels
http://download4.clearfoundation.com/clearos/enterprise/5.2/kernels
gpgcheck=1

[base-extras]
name=ClearOS Enterprise 5.2 - Extras
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/extras
http://download1.clearfoundation.com/clearos/enterprise/5.2/extras
http://download2.clearfoundation.com/clearos/enterprise/5.2/extras
http://download3.clearfoundation.com/clearos/enterprise/5.2/extras
http://download4.clearfoundation.com/clearos/enterprise/5.2/extras
gpgcheck=1
enabled=0

[base-plus]
name=ClearOS Enterprise 5.2 - Plus
baseurl=http://download.clearfoundation.com/clearos/enterprise/5.2/plus
http://download1.clearfoundation.com/clearos/enterprise/5.2/plus
http://download2.clearfoundation.com/clearos/enterprise/5.2/plus
http://download3.clearfoundation.com/clearos/enterprise/5.2/plus
http://download4.clearfoundation.com/clearos/enterprise/5.2/plus
gpgcheck=1
enabled=0

[clearcentos-os]
name=ClearOS 5.x - Minified CentOS - OS
baseurl=http://download.clearfoundation.com/clearcentos/5/os
http://download1.clearfoundation.com/clearcentos/5/os
http://download2.clearfoundation.com/clearcentos/5/os
http://download3.clearfoundation.com/clearcentos/5/os
http://download4.clearfoundation.com/clearcentos/5/os
gpgcheck=1
enabled=1

[clearcentos-updates]
name=ClearOS 5.x - Minified CentOS - Updates
baseurl=http://download.clearfoundation.com/clearcentos/5/updates
http://download1.clearfoundation.com/clearcentos/5/updates
http://download2.clearfoundation.com/clearcentos/5/updates
http://download3.clearfoundation.com/clearcentos/5/updates
http://download4.clearfoundation.com/clearcentos/5/updates
gpgcheck=1
enabled=1
Friday, March 23 2012, 06:37 AM
Share this post:
Responses (19)
  • Accepted Answer

    Wednesday, December 10 2014, 05:33 PM - #Permalink
    Resolved
    0 votes
    I can see from the yum output that you have a version of perl-Convert-UUlib from EPEL instead of the version that ships with ClearOS. Installing the ClearOS version might resolve the issue:

    Download perl-Convert-UUlib-1.11-1.1.v5.i386.rpm
    The reply is currently minimized Show
  • Accepted Answer

    Friday, November 28 2014, 03:40 PM - #Permalink
    Resolved
    0 votes
    ClearOS v5.2 / 32bit
    After <yum clean all>


    [root@mail ~]# yum update
    Loading "kmod" plugin
    Loading "protect-packages" plugin
    epel | 3.7 kB 00:00
    base-kernels | 951 B 00:00
    base-updates | 951 B 00:00
    clearcentos-os | 951 B 00:00
    base-supplements | 951 B 00:00
    base-os | 1.1 kB 00:00
    clearcentos-updates | 951 B 00:00
    base-console | 951 B 00:00
    Setting up Update Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package awstats.noarch 0:6.95-3.el5 set to be updated
    ---> Package perl-IO-stringy.noarch 0:2.110-5.el5 set to be updated
    ---> Package GeoIP.i386 0:1.4.8-1.el5 set to be updated
    ---> Package perl-Parse-RecDescent.noarch 0:1.965-1.el5 set to be updated
    ---> Package clamd.i386 0:0.98.4-1.el5 set to be updated
    ---> Package proftpd.i386 0:1.3.3g-4.el5 set to be updated
    ---> Package clamav.i386 0:0.98.4-1.el5 set to be updated
    ---> Package ratpoison.i386 0:1.4.5-2.el5 set to be updated
    ---> Package perl-Mail-IMAPClient.noarch 0:3.33-1.el5 set to be updated
    ---> Package libnfnetlink.i386 0:1.0.0-3.el5 set to be updated
    ---> Package perl-Mail-DKIM.noarch 0:0.39-1.el5 set to be updated
    --> Processing Dependency: perl(MIME::Lite) for package: perl-Mail-DKIM
    ---> Package jnettop.i386 0:0.13.0-5.el5 set to be updated
    ---> Package hping3.i386 0:0.0.20051105-8.el5 set to be updated
    --> Processing Dependency: libtcl8.4.so for package: hping3
    ---> Package perl-Crypt-OpenSSL-Random.i386 0:0.04-7.el5 set to be updated
    ---> Package perl-MLDBM.noarch 0:2.01-5.el5.1 set to be updated
    --> Processing Dependency: perl(FreezeThaw) for package: perl-MLDBM
    ---> Package imapsync.noarch 0:1.592-1.el5 set to be updated
    --> Processing Dependency: perl(IO::Tee) for package: imapsync
    --> Processing Dependency: perl(File::Copy::Recursive) for package: imapsync
    --> Processing Dependency: perl(Data::Uniqid) for package: imapsync
    --> Processing Dependency: perl(Authen::NTLM) for package: imapsync
    ---> Package horde.noarch 0:3.3.11-2.el5 set to be updated
    --> Processing Dependency: php-xml for package: horde
    --> Processing Dependency: php-pear(Mail_Mime) for package: horde
    --> Processing Dependency: php-pear(Log) for package: horde
    --> Processing Dependency: php-pear(File) for package: horde
    --> Processing Dependency: php-pear(DB) for package: horde
    --> Processing Dependency: perl(Convert::UUlib) >= 1.08 for package: amavisd-new
    ---> Package perl-Convert-TNEF.noarch 0:0.17-7.el5 set to be updated
    ---> Package postgrey.noarch 0:1.34-1.el5 set to be updated
    ---> Package perl-Convert-BinHex.noarch 0:1.119-5.el5 set to be updated
    ---> Package perl-Time-ParseDate.noarch 0:2013.1113-2.el5 set to be updated
    ---> Package perl-Crypt-OpenSSL-RSA.i386 0:0.25-8.el5 set to be updated
    --> Processing Dependency: perl(Crypt::OpenSSL::Bignum) for package: perl-Crypt-OpenSSL-RSA
    ---> Package clamav-db.i386 0:0.98.4-1.el5 set to be updated
    ---> Package perl-Convert-UUlib.i386 2:1.4-1.el5 set to be updated
    ---> Package perl-Sys-Hostname-Long.noarch 0:1.4-5.el5 set to be updated
    --> Running transaction check
    ---> Package perl-Data-Uniqid.noarch 0:0.12-2.el5 set to be updated
    ---> Package perl-Crypt-OpenSSL-Bignum.i386 0:0.04-7.el5 set to be updated
    ---> Package perl-NTLM.noarch 0:1.09-1.el5 set to be updated
    ---> Package perl-IO-Tee.noarch 0:0.64-1.el5 set to be updated
    ---> Package perl-FreezeThaw.noarch 0:0.43-5.el5 set to be updated
    ---> Package perl-File-Copy-Recursive.noarch 0:0.35-1.el5 set to be updated
    --> Processing Dependency: perl(Convert::UUlib) >= 1.08 for package: amavisd-new
    ---> Package tcl.i386 0:8.4.13-6.el5 set to be updated
    ---> Package php-pear-Log.noarch 0:1.12.7-1.el5 set to be updated
    --> Processing Dependency: php-pear(PEAR) >= 1.4.9 for package: php-pear-Log
    --> Processing Dependency: php-pear(Mail) for package: php-pear-Log
    --> Processing Dependency: php-pear(MDB2) >= 2.0.0 for package: php-pear-Log
    --> Processing Dependency: /usr/bin/pear for package: php-pear-Log
    --> Processing Dependency: /usr/bin/pear for package: php-pear-Log
    ---> Package perl-MIME-Lite.noarch 0:3.01-5.el5 set to be updated
    ---> Package php-xml.i386 0:5.1.6-27.v5.3.1 set to be updated
    ---> Package php-pear-File.noarch 0:1.2.2-1.el5 set to be updated
    ---> Package php-pear-Mail-Mime.noarch 0:1.4.0-2.el5 set to be updated
    ---> Package php-pear-DB.noarch 0:1.7.13-1.el5 set to be updated
    --> Running transaction check
    ---> Package php-pear-Mail.noarch 0:1.1.14-5.el5.1 set to be updated
    --> Processing Dependency: php-pear(Net_SMTP) >= 1.1.0 for package: php-pear-Mail
    --> Processing Dependency: perl(Convert::UUlib) >= 1.08 for package: amavisd-new
    ---> Package php-pear.noarch 1:1.4.9-4.el5.1 set to be updated
    ---> Package php-pear-MDB2.noarch 0:2.4.1-2.el5 set to be updated
    --> Running transaction check
    ---> Package php-pear-Net-SMTP.noarch 0:1.4.4-1.el5 set to be updated
    --> Processing Dependency: php-pear(Net_Socket) >= 1.0.7 for package: php-pear-Net-SMTP
    --> Processing Dependency: php-pear(Auth_SASL) for package: php-pear-Net-SMTP
    --> Processing Dependency: perl(Convert::UUlib) >= 1.08 for package: amavisd-new
    --> Running transaction check
    ---> Package php-pear-Auth-SASL.noarch 0:1.0.4-1.el5 set to be updated
    --> Processing Dependency: perl(Convert::UUlib) >= 1.08 for package: amavisd-new
    ---> Package php-pear-Net-Socket.noarch 0:1.0.10-1.el5 set to be updated
    --> Finished Dependency Resolution
    Error: Missing Dependency: perl(Convert::UUlib) >= 1.08 is needed by package amavisd-new
    [root@mail ~]#


    Hope is not a problem, but it is worrying ..

    After update LDAP/Password policies[Password Lockout] ... hmm, Fail2Ban stopped to block spam is activated, Snort is wrong .. alien attack?
    :huh: blocking passwords returns ..
    The reply is currently minimized Show
  • Accepted Answer

    Steven Shi
    Steven Shi
    Offline
    Thursday, April 12 2012, 03:56 PM - #Permalink
    Resolved
    0 votes
    Thank you very much Peter :)
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 12 2012, 03:23 PM - #Permalink
    Resolved
    0 votes
    Thanks!
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, April 12 2012, 01:59 PM - #Permalink
    Resolved
    0 votes
    Ugh. Sorry. It looks like I applied the "rpm" update to the wrong master mirror (and the update was then blown away on a mirror sync). The "rpm" source produces the following packages: rpm, rpm-build, rpm-libs, rpm-python, rpm-apidocs, and popt. Those packages were out of sync but are now now up-to-date.

    We're in limbo between two build systems, so there's a lot of eye-balling going on right now. In the end, it is going to be worth the effort though. In fact, a 5.x 64-bit version could come out of the process.

    @ Steven - the openldap-servers-sql should be removed. It's a driver for using an SQL database for the LDAP backend. That's not done in ClearOS, so the package is not necessary. Regardless, I'll migrate the latest build over to the repositories since older versions already exist. The new ClearOS 6 way of doing things is a lot better. A package like that is available, but tucked away in a development repository (clearos-dev to be exact).
    The reply is currently minimized Show
  • Accepted Answer

    Steven Shi
    Steven Shi
    Offline
    Wednesday, April 11 2012, 06:21 PM - #Permalink
    Resolved
    0 votes
    On mine "openldap-servers" still missing as well ...

    Error: Missing Dependency: openldap-servers = 2.4.12-5.1.v5 is needed by package openldap-servers-sql
    Error: Missing Dependency: popt = 1.10.2.3-27.v5 is needed by package rpm-build
    Error: Missing Dependency: rpm = 4.4.2.3-27.v5 is needed by package rpm-devel
    Error: Missing Dependency: rpm = 4.4.2.3-27.v5 is needed by package rpm-build
    Error: Missing Dependency: rpm-libs = 4.4.2.3-27.v5 is needed by package rpm-devel
    Error: Missing Dependency: popt = 1.10.2.3-27.v5 is needed by package rpm-devel
    Error: Missing Dependency: rpm-libs = 4.4.2.3-27.v5 is needed by package rpm-build
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2012, 04:55 PM - #Permalink
    Resolved
    0 votes
    ..... but you have other missing packages now:
    Error: Missing Dependency: popt = 1.10.2.3-27.v5 is needed by package rpm-build
    Error: Missing Dependency: rpm = 4.4.2.3-27.v5 is needed by package rpm-devel
    Error: Missing Dependency: rpm-libs = 4.4.2.3-27.v5 is needed by package rpm-build
    And I believe from another thread a python package is missing.

    I have individually updated the kernel-headers and kernel-devel because of the above errors.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2012, 04:52 PM - #Permalink
    Resolved
    0 votes
    Okay - those devel packages should be on all the mirrors by now :-)
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2012, 11:24 AM - #Permalink
    Resolved
    0 votes
    I'll push them out today instead of waiting until next week. I'll post an update here.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 11 2012, 06:57 AM - #Permalink
    Resolved
    0 votes
    Doesn't look like it. :(
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, April 10 2012, 09:12 PM - #Permalink
    Resolved
    0 votes
    Did they make it in for today?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, April 09 2012, 12:50 PM - #Permalink
    Resolved
    0 votes
    Sorry about that - some of the developer libraries have not yet been released. They will be put in the repository either this Tuesday or the next one.
    The reply is currently minimized Show
  • Accepted Answer

    nmincone
    nmincone
    Offline
    Sunday, April 08 2012, 03:35 PM - #Permalink
    Resolved
    0 votes
    Does this also cover the;
    Error: Missing Dependency: openldap = 2.4.12-5.1.v5 is needed by package openldap-devel
    fail on yum update?
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 26 2012, 10:29 AM - #Permalink
    Resolved
    0 votes
    Thanks for the heads up! The OpenSwan package was pulled for now, but will reappear in the near future. We're in the process of deploying support for multiple LDAP library versions. That will make life a lot easier for these types of packages and will also allow us to start using the new build system for version 5.x :-)
    The reply is currently minimized Show
  • Accepted Answer

    Steven Shi
    Steven Shi
    Offline
    Sunday, March 25 2012, 08:24 PM - #Permalink
    Resolved
    0 votes
    Thank you very much Nick :cheer:
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, March 25 2012, 03:07 PM - #Permalink
    Resolved
    0 votes
    Nice to see they are finally updating Openswan! Openswan released 2.6.38 on Friday so we are still behind the times. FWIW I have stuck a copy of the 2.6.38 rpm here.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 23 2012, 02:57 PM - #Permalink
    Resolved
    0 votes
    Looks like the Openswan RPM needs to be rebuilt, or pulled from the clearcentos-os repo. I'll ping the dev team :)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 23 2012, 09:05 AM - #Permalink
    Resolved
    0 votes
    Just a note - this survives a

    yum clean all

    David
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 23 2012, 08:58 AM - #Permalink
    Resolved
    0 votes
    Hi all,

    I too can confirm that the yum update returns:

    (many packages requiring update)

    --> Finished Dependency Resolution
    Error: Missing Dependency: liblber-2.3.so.0 is needed by package openswan
    Error: Missing Dependency: libldap-2.3.so.0 is needed by package openswan
    [root@cc ~]#

    is this an error in the update package?

    David
    The reply is currently minimized Show
Your Reply