Forums

Resolved
0 votes
Hi,

I installed Zarafa community on my ClearOS 7.1 and everyting seems fine except that, the service "Zarafa Search Indexer" is marked as stopped and when I try to start it I get a error message saying "Software is not installed".

/var/log/zarafa/search.log says:

2015-11-29 03:19:06,625 - search - ERROR - Traceback (most recent call last):
File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 2240, in l$
try: yield
File "/usr/lib64/python2.7/site-packages/zarafa_search/__init__.py", line 301$
new_state = self.server.sync(importer, self.state, log=self.log)
File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 652, in sy$
return _sync(self, self.mapistore, importer, state, log or self.log, max_ch$
File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 168, in _s$
exporter.Config(stream, SYNC_NORMAL | SYNC_UNICODE, importer, None, None, N$
File "/usr/lib64/python2.7/site-packages/MAPICore.py", line 1346, in Config
def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(sel$
MAPIErrorCollision: MAPI error 80040604


systemctl -l status zarafa-search.service says:

zarafa-search.service - LSB: The Search Indexer of the Zarafa Collaboration Platform
Loaded: loaded (/etc/rc.d/init.d/zarafa-search)
Active: failed (Result: exit-code) since Tue 2015-12-01 14:36:54 EST; 24min ago

Dec 01 14:36:54 hostname zarafa-search[7651]: Starting zarafa-search: Traceback (most recent call last):
Dec 01 14:36:54 hostname zarafa-search[7651]: File "/usr/bin/zarafa-search", line 3, in <module>
Dec 01 14:36:54 hostname zarafa-search[7651]: import zarafa_search
Dec 01 14:36:54 hostname zarafa-search[7651]: File "/usr/lib64/python2.7/site-packages/zarafa_search/__init__.py", line 12, in <module>
Dec 01 14:36:54 hostname zarafa-search[7651]: import zarafa
Dec 01 14:36:54 hostname zarafa-search[7651]: ImportError: No module named zarafa
Dec 01 14:36:54 hostname zarafa-search[7651]: [FAILED]
Dec 01 14:36:54 hostname systemd[1]: zarafa-search.service: control process exited, code=exited status=1
Dec 01 14:36:54 hostname systemd[1]: Failed to start LSB: The Search Indexer of the Zarafa Collaboration Platform.
Dec 01 14:36:54 hostname systemd[1]: Unit zarafa-search.service entered failed state.


Any ideas?
Tuesday, December 01 2015, 08:05 PM
Share this post:

Accepted Answer

Tuesday, December 08 2015, 06:53 PM - #Permalink
Resolved
1 votes
Yup...that's the problem.

yum -y install python-zarafa


Should solve your problem.

Sounds like a missing dependency in the Zarafa packaging...I'll dig deeper...this wasn't an issue on my test box.

B.
The reply is currently minimized Show
Responses (10)
  • Accepted Answer

    Tuesday, December 08 2015, 06:59 PM - #Permalink
    Resolved
    0 votes
    Alright that did the trick.

    One last thing is that I can't start/stop the Zarafa Search Indexer service from the ClearOS web interface still says the "Software is not installed" message. Truth is, I dont mind at all, just wanted you guys to know

    A big thanks to you and have a nice day!
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 06:46 PM - #Permalink
    Resolved
    0 votes
    package python-zarafa is not installed

    So I guess that means the marketplace doesn't install this package when installing zarafa

    Also juste an update retried it today and the /var/log/zarafa/search.log is empty

    systemctl -l status zarafa-search.service still says:
    zarafa-search.service - LSB: The Search Indexer of the Zarafa Collaboration Platform
    Loaded: loaded (/etc/rc.d/init.d/zarafa-search)
    Active: failed (Result: exit-code) since Tue 2015-12-08 13:40:22 EST; 6min ago
    Process: 17236 ExecStart=/etc/rc.d/init.d/zarafa-search start (code=exited, status=1/FAILURE)

    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: Starting zarafa-search: Traceback (most recent call last):
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: File "/usr/bin/zarafa-search", line 3, in <module>
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: import zarafa_search
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: File "/usr/lib64/python2.7/site-packages/zarafa_search/__init__.py", line 12, in <module>
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: import zarafa
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: ImportError: No module named zarafa
    Dec 08 13:40:22 Backend.egagnon.net zarafa-search[17236]: [FAILED]
    Dec 08 13:40:22 Backend.egagnon.net systemd[1]: zarafa-search.service: control process exited, code=exited status=1
    Dec 08 13:40:22 Backend.egagnon.net systemd[1]: Failed to start LSB: The Search Indexer of the Zarafa Collaboration Platform.
    Dec 08 13:40:22 Backend.egagnon.net systemd[1]: Unit zarafa-search.service entered failed state.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 06:40 PM - #Permalink
    Resolved
    0 votes
    Looks fine.

    rpm -qv python-zarafa


    B
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 06:27 PM - #Permalink
    Resolved
    0 votes
    cat /usr/bin/zarafa-search outputs:

    #!/usr/bin/env python
    import sys
    import zarafa_search

    if __name__ == '__main__':
    sys.exit(zarafa_search.main())
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 06:23 PM - #Permalink
    Resolved
    0 votes
    What's the output of:
     cat /usr/bin/zarafa-search


    B
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 06:13 PM - #Permalink
    Resolved
    0 votes
    They are exactly the same and I still get the "Software not installed" message.

    /var/log/zarafa/search.log says:

    2015-11-29 03:19:06,625 - search - ERROR - Traceback (most recent call last):
    File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 2240, in l$
    try: yield
    File "/usr/lib64/python2.7/site-packages/zarafa_search/__init__.py", line 301$
    new_state = self.server.sync(importer, self.state, log=self.log)
    File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 652, in sy$
    return _sync(self, self.mapistore, importer, state, log or self.log, max_ch$
    File "/usr/lib64/python2.7/site-packages/zarafa/__init__.py", line 168, in _s$
    exporter.Config(stream, SYNC_NORMAL | SYNC_UNICODE, importer, None, None, N$
    File "/usr/lib64/python2.7/site-packages/MAPICore.py", line 1346, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(sel$
    MAPIErrorCollision: MAPI error 80040604



    systemctl -l status zarafa-search.service says:

    zarafa-search.service - LSB: The Search Indexer of the Zarafa Collaboration Platform
    Loaded: loaded (/etc/rc.d/init.d/zarafa-search)
    Active: failed (Result: exit-code) since Tue 2015-12-01 14:36:54 EST; 24min ago

    Dec 01 14:36:54 hostname zarafa-search[7651]: Starting zarafa-search: Traceback (most recent call last):
    Dec 01 14:36:54 hostname zarafa-search[7651]: File "/usr/bin/zarafa-search", line 3, in <module>
    Dec 01 14:36:54 hostname zarafa-search[7651]: import zarafa_search
    Dec 01 14:36:54 hostname zarafa-search[7651]: File "/usr/lib64/python2.7/site-packages/zarafa_search/__init__.py", line 12, in <module>
    Dec 01 14:36:54 hostname zarafa-search[7651]: import zarafa
    Dec 01 14:36:54 hostname zarafa-search[7651]: ImportError: No module named zarafa
    Dec 01 14:36:54 hostname zarafa-search[7651]: [FAILED]
    Dec 01 14:36:54 hostname systemd[1]: zarafa-search.service: control process exited, code=exited status=1
    Dec 01 14:36:54 hostname systemd[1]: Failed to start LSB: The Search Indexer of the Zarafa Collaboration Platform.
    Dec 01 14:36:54 hostname systemd[1]: Unit zarafa-search.service entered failed state.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 05:24 PM - #Permalink
    Resolved
    0 votes
    To be clear, you're not receiving the "Software not installed" message any longer...and if you run:
    service zarafa-search start


    You can an error message...either dumped to console or to a log file (/var/log/zarafa/search.log).

    Can you post the error message again?

    B.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 08 2015, 04:51 PM - #Permalink
    Resolved
    0 votes
    Ok I tried to reinstall the whole system since I didn't get updates for about a week and the problem is still there so it doesn't seem to be a configuration problem. Anyone knows how to fix this?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 02 2015, 06:07 PM - #Permalink
    Resolved
    0 votes
    I see that the updates "app-zarafa 2.1.18" and "app-zarafa-core-2.1.18-1.v7" have been apply but I still have the same problem even after a reboot of the OS...

    Thanks for you answer though
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 01 2015, 08:53 PM - #Permalink
    Resolved
    0 votes
    I fixed that last week but forgot to push it to the mirrors.

    The update that fixes this issue is on its way to the mirrors now (app-zarafa 2.1.18)...give it a few hours.

    B.
    The reply is currently minimized Show
Your Reply