Forums

Resolved
0 votes
Hello,

Is it safe (tested) to upgrade Webapp to version 2 yet on Zarafa community edition for ClearOS?

If it is safe (tested) what are the steps to upgrade Webapp?

Will this upgrade to the new version of Webapp affect Webaccess? We still use Webaccess from our mobile devices and don't want it removed from Zarafa.

Thank you.
Thursday, August 13 2015, 01:40 AM
Share this post:

Accepted Answer

Friday, August 14 2015, 04:36 PM - #Permalink
Resolved
0 votes
Yes 7.1.10 is fine for upgrade (as greater than 7.1.5 in the 7.1.x release branch)

Sorry it's been a while since I've carried out the upgrade so forgot about the version numbering issue. For some odd reason when they compiled the new Zarafa-Webapp v2 RPMS they messed up the numbering so that it tries to overwrite v2 with v1.4 from the ClearOS repos
(for the technically minded its to do with the RPM epoch which changed to a lower value...!)
https://www.clearos.com/clearfoundation/social/community/zarafa-webapp-next-gen-preview#reply-34820

E.g
---> Package zarafa-webapp.noarch 0:2.0.2.48619-136.1 will be updated
---> Package zarafa-webapp.noarch 1:1.4-42633 will be an update

Anyway for now...you can force the upgrade with 'rpm -Uvh --force *.rpm' instead, and then block future 'downgrades' from yum by adding zarafa-webapp to an exclude list in /etc/yum.repos.d/clearos-zarafa-community.repo
[zarafa-community-71]
name=Zarafa Community 7.1 - $basearch
baseurl=http://download1.clearsdn.com/marketplace/zarafa_community_71/$releasever/$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS
exclude=zarafa-webapp
The reply is currently minimized Show
Responses (13)
  • Accepted Answer

    Saturday, December 26 2015, 10:42 AM - #Permalink
    Resolved
    0 votes
    Hi guys,
    Merry Christmas.

    Since I couldn't make the upgrade-exclude to work I want to downgrade back to webapp 1:1.3.2-42118 again.
    What is the procedure to downgrade?

    /Sven
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, November 04 2015, 08:43 PM - #Permalink
    Resolved
    0 votes
    Hi,

    I have added exclude=zarafa-webapp to all sections in /etc/yum.repos.d/clearos-zarafa-community.repo

    I still have the same problem that

    yum update
    ...
    Updating: zarafa-webapp noarch 1:1.3.2-42118 private-clearcenter-zarafa-community 3.0 M

    tries to up(down)grade.
    How can I switch that off?

    Is it ok to install WebApp 2.1.0 the same way?

    Cheers
    /Sven
    The reply is currently minimized Show
  • Accepted Answer

    Robert
    Robert
    Offline
    Friday, August 28 2015, 09:15 PM - #Permalink
    Resolved
    1 votes
    Hi,

    I just did the update and next to

    clearos-zarafa-community

    also

    private-clearcenter-zarafa-community

    tries to install the old webapp again. How do I switch that off? I could not find it in the repo folder.

    Thanks.

    Best

    Robert

    Edit: I also have the problem, that the webapp loads forever and does not show me the webpage after login. Am I missing something? I already restarted the computer.
    Like
    1
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, August 19 2015, 03:47 PM - #Permalink
    Resolved
    0 votes
    Hi Tim,

    Yes I noticed as well that Chrome and IE don't work with PDF preview (we only use Chrome in our office). The PDF preview does work with Firefox though it seems.

    Thanks.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, August 18 2015, 01:10 PM - #Permalink
    Resolved
    0 votes
    Hi Charles, I just enabled the PDF plugin and notice the same issue when trying to preview, will investigate with other browsers / Zarafa forums. Debug output suggests it can't find the PDF attachment to display ("Error stream must have data" from pdf.js)

    Tried with IE11 and Chrome...
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 17 2015, 11:34 PM - #Permalink
    Resolved
    0 votes
    Thanks very much Tim for your assistance.

    I'm was hoping the upgrade to WebApp 2.0.2 would allow the PDF Viewer to work for our office but it would seem on our test server the upgrade to 2.0.2 still shows a dark gray screen when we open the PDF view and no PDF is displayed. Have you found this same issue?

    I have the PDFBox plugin enabled...do I need to have a PDF viewer or something else installed on ClearOS to have this work in WebApp?

    Thanks very much for all your help with this Tim.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 17 2015, 12:56 PM - #Permalink
    Resolved
    0 votes
    Hi Charles, just add the one line "exclude=zarafa-webapp" to the section beginning [zarafa-community-71] so that yum does not try and downgrade the package in future
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 17 2015, 03:05 AM - #Permalink
    Resolved
    0 votes
    Hello Tim,

    Thanks for this very helpful reply. I have successfully installed WebApp 2.0.2 using your force instruction on my test box. Before I apply this to my Production machine I'll need to confirm your steps to block future 'downgrades' from yum by adding zarafa-webapp to an exclude list.

    Do I add all the following lines to the end of the /etc/yum.repos.d/clearos-zarafa-community.repo file:

    [zarafa-community-71] 
    name=Zarafa Community 7.1 - $basearch
    baseurl=http://download1.clearsdn.com/marketplace/zarafa_community_71/$releasever/$basearch
    enabled=1
    gpgcheck=0
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-ClearOS
    exclude=zarafa-webapp


    or am I only adding the exclude line to this file somewhere?

    exclude=zarafa-webapp


    Thank you Tim.
    The reply is currently minimized Show
  • Accepted Answer

    Friday, August 14 2015, 02:36 PM - #Permalink
    Resolved
    0 votes
    Hello Tim,

    Thanks for your help with this upgrade!

    We are currently running the following versions (I upgraded to these from the testing repo instructions yourself and clearcare support gave me earlier):

    WebApp: 1.5-44025
    ZCP: 7.1.10-44973

    Since we are greater than version 7.0.14 does this mean I can safely upgrade to Webapp v2.0.2?

    My test box is ClearOS Community Edition (something I fired up for this test). Perhaps the ClearOS Community Edition is different from the ClearOS Pro (Paid For) edition and that's why my community test box had the php-php-gettext error andyour upgrade to v2.0.2 didn't?

    Thanks for confirming what plugins we need at a minimum and for uploading what I need to your FTP site.

    On our Test ClearOS Box I tried using the files you've provided on your FTP Site. I've gotten past the error for php-php-getttext now, but it seems ClearOS thinks the version of WebApp I'm upgrading too is less than what I currently have? Here's a screenshot of the message I get when I issue this command:

    rpm -Uvh zarafa-webapp-*

    after downloading all the files from your FTP site.

    In case the picture I'm attaching doesn't attach, the message I get is:

    package zarafa-webapp-1:1.5-44025.noarch (which is newer than zarafa-webapp-2.0.1.47791-63.1.noarch) is already installed..


    Thanks Tim!
    The reply is currently minimized Show
  • Accepted Answer

    Friday, August 14 2015, 12:55 PM - #Permalink
    Resolved
    0 votes
    Hi Charles,

    You can solve with first command by installing the extra extension from the EPEL repo
    yum --enablerepo=clearos-epel install php-php-gettext


    The v2.0.2 RPMS didn't do that for me...anyway I've uploaded the latest set to my FTP site if you want to make it easier than downloading each file.
    wget ftp://timburgess.net/zarafa/webapp/*.rpm


    As a minimum you need zarafa-webapp, and zarafa-webapp-lang RPMS, all the rest are optional plugins

    You can upgrade from Webapp v1.5, no further user changes on their side...but I checked requirements and it appears v2.0.2 requires Zarafa > 7.0.14, or 7.1.5 due to an issue with meeting requests. What are you running?

    Note any issues and you can just reinstall the old version
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 13 2015, 06:24 PM - #Permalink
    Resolved
    0 votes
    Hi Tim,

    I thought I would fire up a test ClearOS Server to try out the upgrade (although it's not an apples to apples test in that my Test Server is ClearOS Community Edition and my production Server is ClearOS Pro Edition).

    On my ClearOS Community Edition I thought I would download the zcp-7.2.0-48204-rhel-6-x86_64-opensource.tar.gz and see what's inside.

    So what I've discovered is that the tarball has all the files for WebApp 2.02 inside. And when I issue the rpm -Uvh zarafa-webapp-* instruction it will install each and every .rpm file with the prefix 'zarafa-webapp" in that folder.

    But when I do this I'm presented with the following error message:

    error: Failed dependencies:
    php-php-gettext is needed by zarafa-webapp-2.0.1.47791-63.1.noarch

    A bit of searching and I can find php-gettext which is part of php-common but that's already installed and the latest version.

    Where would I find php-php-gettext and get past this dependency error on upgrading Zarafa to version 2?

    Thank you,
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 13 2015, 04:19 PM - #Permalink
    Resolved
    0 votes
    Thanks very much Tim for your assistance.

    Question #1:
    Just to confirm something. We currently run WebApp version - 1.5-44025. Do I need to upgrade to WebApp 1.6 first before I upgrade to version 2.02?


    Question #2: To be sure I'm downloading what I need to install.

    From the link you provided I will download the following rpm file:

    zarafa-webapp-2.0.2.48619-136.1.noarch.rpm

    Once downloaded to my ClearOS Server I will issue the following commands:

    rpm -Uvh zarafa-webapp-*
    service httpd restart

    Is there anything I'm missing? Will my users need to do anything on their side? I have delegates setup for some users as well and a shared addressbook in place for our office to use. Just want to make sure I have the upgrade performed properly and configured if required.

    Thank you.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 13 2015, 01:54 PM - #Permalink
    Resolved
    0 votes
    Hi Charles, you can manually install the latest Zarafa-webapp RPMS from the command line. It will not affect Webaccess which will continue to operate in parallel with Webapp. If you are using a lot of mobile devices consider using Zarafa Z-Push (ActiveSync) component?

    I've been running with Webapp 2.0.2 for some time and is OK. Simplest way is to download EL6 RPMS from here
    http://download.zarafa.com/community/final/WebApp/2.0.2/rhel-6/

    Or extract them from the latest tarball (don't install or upgrade the other Zarafa RPMS as 7.2 is not compatible with ClearOS 6.x)
    wget http://download.zarafa.com/community/final/7.2/7.2.0-48204/zcp-7.2.0-48204-rhel-6-x86_64-opensource.tar.gz
    tar zxvf zcp-7.2.0-48204-rhel-6-x86_64-opensource.tar.gz
    cd zcp-7.2.0-48204-rhel-6-x86_64-opensource
    rpm -Uvh zarafa-webapp-*
    service httpd restart

    Enjoy :)
    The reply is currently minimized Show
Your Reply