Profile Details

Toggle Sidebar
Recent updates
  • Hmmm

    I installed the new LAN card and logged into the system through the WAN interface. The replacement card shows up as a new ethernet interface but it says "no link" on the IP Settings even though I've configured it for a static IP. I booted the machine off a Linux Live DVD and the card's ok.

    Where to next?


  • Question : how to replace a network card?

    Hi all

    The LAN card in my ClearOS 6.9 server/gateway has died. I can still access it through the WAN port.

    So I've dug out an old LAN card from my box of bits, tossed it (gently) into an old desktop, installed 6.9 and yes, that card works and is recognised.

    Now I want to put it in my server to get the LAN interface back. I imagine it will need some sort of configuration change and that's beyond my linux skill set. I have the old computer with the card working, so I can at least copy something - if I know what to copy, that is.

    Can anyone suggest how to go about this?

    Thanks in advance.

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    Nick Howitt wrote:

    I do compile a forcedeth driver here and the issue in that thread you linked to has gone away as the devs have dropped the plan to revert to a stock kernel in 7.x and will instead, do it in 8 from the outset. This is the safer option. However there is still a risk. These days RedHat only seem to be keeping ABI compatibility in the kernels within their point releases, so many of the drivers need to be recompiled when a kernel goes up along with EL7 going up a point release. This means, as an example, the forcedeth driver is fine for the 7.4 kernels (kernel-3.10.0-693.x.y.v7.x86_64) but needs to be recompiled (with slightly modified sources) for the 7.5 kernel (3.10.0-862.x.y.v7). The risk for you is not spotting the kernel update and the machine rebooting in your absence which will put the new kernel into effect and cut your internet. If it happens, it can be salvaged if you can talk your user through booting to an older kernel (just hitting the down arrow at a critical time during the boot process).

    Apologies about the chkconfig command. It worked with 7.x. In 6.x if you turn it off and on again, it also enables runlevel 2 :S

    Can you check that all your interfaces are valid in /etc/clearos/network.conf

    Thanks Nick. Yes, network.conf looks sensible.

    The only worry with the reboot to old kernel option is that someone has to climb up to the top of the shelves and connect a monitor/keyboard/mouse. The grizzling I'd have to put up with isn't worth it!

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    eth0 External Static
    eth1 LAN Static

    eth0 connects to my ADSL2+ modem with a static IP. The modem's DHCP is set to
    eth1 provides DHCP to my LAN

    The nVidia is the NIC on the motherboard, it's the one not detected by ClearOS 7. This is an old Compaq presario CQ3000.

    I appreciate that it's not that difficult, once the procedure is documented, to rebuild it after updates. The issue is that if I'm away then nobody else in the house knows anything about how to do it, so stability is very important. I don't want to have to drive 5 1/2 hours home from the snow next August to fix the internet LOL

    Also it's the external NIC because it's only 10/100 and that's what passes for high speed broadband in Australia, meaning it can't be fixed from outside. The other NIC is gigabit, so it's better for the LAN.

    Hence ClearOS 6.9 was the easier path.

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    Tony Ellis wrote:

    By the way - there is a kmod driver for forcedeth available for ClearOS 7.4 if that is the reason for not installing 7.4...

    I did find this thread on that but the thread also warned that updates could mean it needs to be reinstalled, so I didn't follow it up. This machine is the firewall/gateway for the whole house (1 university professor, 1 uni student and my own computer repair business) and the ear-bashing I got when it went down last week put me off doing anything too complex in case it causes more problems.

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    [root@server ~]# chkconfig --list | grep smb
    smb 0:off 1:off 2:off 3:on 4:on 5:on 6:off
    [root@server ~]#

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    Thanks for the reply

    Havcing already done a "service smb start" from the command line (yesterday) I now get :

    [root@server ~]# service smb status
    smbd (pid 8509) is running...
    [root@server ~]# chkconfig smb
    [root@server ~]# lspci -knn | grep Eth -A 3
    00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
    Subsystem: Hewlett-Packard Company Device [103c:2a99]
    Kernel driver in use: forcedeth
    Kernel modules: forcedeth
    01:0a.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller [10ec:8169] (rev 10)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8169/8110 Family PCI Gigabit Ethernet NIC [10ec:8169]
    Kernel driver in use: r8169
    Kernel modules: r8169
    [root@server ~]#

    As you can see, chkconfig smb returns nothing.

  • Scumbag
    Scumbag replied to a discussion, Problems accessing shares

    I don't know if it helps, but I;ve just done a clean install of ClearOS 6.9 (because 7 doesn't recognise one of my NICs) and had the same problem I;ve had with every ClearOS install l've done for the last few years - the smb service doesn't start when the machine is booted. I've fixed it each time by editing one of the init files to do a "service smb start" (can't remember which one - it's actually a job for tomorrow for me) and then it works fine.

  • Scumbag
    Scumbag likes the reply for the discussion, Re: Best way to dodge geolocation

    If you have the bandwidth, it is easiest achieved through OpenVPN to your own server then onto the internet, but you need to make your client redirect all its traffic through the OpenVPN server.

    The simplest way to do this is to add the following line to /etc/openvpn/clients.conf:Then restart OpenVPN.

    There are alternative ways:
    1 - If your client is Android, use this client where there is an option to redirect all traffic through the VPN. You then don't need to do anything special in ClearOS.
    2 - If you want to leave the default clients.conf in place, clone it to a new file, change the port and the line which points to ipp.txt, and add the 'push "redirect-gateway def1"' line. Restart openVPN. Then open the new incoming port. In the .ovpn file you download, change port and import the new profile into what ever machine you want. Android and iOS both allow you to rename the profile once imported.

  • Scumbag
    Scumbag replied to a discussion, Best way to dodge geolocation

    Brilliant! I'm moving next week to a 100/35Mbps cable connection so the speed shouldn't be an issue. I will give this a try.