Profile Details

Toggle Sidebar
Recent updates
  • Expand the APC UPS Backup Manager app to allow for at least network connectivity to an APC Network Management Card. Not just USB.

  • Feature Request with a How-To Setup APC Network Management Card With ClearOS 7

    The APC Battery Backup Manager provided by Clear is quite rudimentary for a system used by many people, businesses and institutions. Most users use one UPS to connect multiple pieces of equipment and it is weird to just shutdown one piece of (Linux) equipment connected via USB. ClearOS uses apcupsd which can allow for network connections to an APC Network Management Card, USB and serial. The APC Network Management Card brand new is quite expensive, IMHO, but used or refurbished it is quite a good deal and can be very helpful in managing a compatible UPS.

    My request is to simply expand the edit and configuration of the app so that one can use SNMP, direct network connectivity, USB or serial. Please don't make it just USB only.

    In any event, I thought I'd do a little write-up on how to use the APC Network Management Card with ClearOS and apcupsd. I have learned so much from this community so I hope this will help someone.

    1). First and foremost, white space is not universally liked by configuration files. In the UPS management card webgui, login and go to Configuration -> Shutdown and change the default passphrase at the bottom of the page. The default passphrase is "admin user phrase". Eliminate the white space with dashes, i.e., "admin-user-phrase" or enter your own pass phrase of at least 16 characters as I recall.

    2). In the UPS management card webgui, go to Configuration -> PowerChute Clients. Add the IP address of your ClearOS box and select the outlet group it is connected to. Selecting the oulet group really does not matter in this application.

    3). In ClearOS, goto System -> Backup -> APC Battery Backup Manager. Hopefully you installed the app from the Market Place. Make sure the service is running and go to/click on Edit. Add only an email address for alerts at this time. Not mandatory but it will send emails to root, as I recall, by default. Click Save.

    4). Now... STOP the service!

    5). Using your favorite method to edit Linux files, putty, winscp, nano, vi, etc. edit, /etc/apcupsd/apcupsd.conf Enter edit the proper lines with the following:

    UPSNAME APC SMT2200 Whatever you want to name your UPS, Mine is an APC SMT2200
    UPSCABLE ether.
    UPSTYPE pcnet
    DEVICE IP 192.168.50.25:apc:admin-user-phrase Don't forget colons between YOUR UPS IP address, User and passphrase.
    UPSCLASS standalone
    UPSMODE disable

    The remainder of the file can remain as-is unless you want to change some of the battery remaining times before your ClearOS box shuts down.

    6). Come back to your ClearOS GUI and the APC app. START the service. When the service is running, click on Edit. DO NOTHING in the Edit screen but click on Cancel. You should see the summary come alive and the UPS online with your ClearOS.

    Again, I truly hope this helps someone.

    John

  • Thanks again Nick! I was sort of figuring as much.

    In re folder creation, I did have to move all of the web files manually but I did not have to do anything in the GUI to create the web site or virtual web site. All was there in the GUI, except the files.

    John

  • In restoring from 6.9 to 7.6 Web Site mispelled (dropped a letter). How to fix?

    Recently I backed up my old 6.9 ClearOS box with two websites, one virtual. In restoring to 7.6, in dropped a letter in the virtual website name and the directory name (however placed in the misspelled directory). Aliases was spelled fine.

    Example: (fake website names, but kind of similar... just examples)

    Web Site Host Name: man-suces.com Suces is NOT correct
    Aliases: man-sauces.com Note that sauces is spelled correctly.
    Full Path /var/www/virtual/man-suces.com

    Simply put, one cannot edit Website Host Name to correct it. The directory path doesn't matter at all and could be any name really. The problem is that by having the host name misspelled, there is no DNS set for man-suces.com. There is DNS set for man-sauces.com BUT you have to use an alias like, "http://www.man-sauces.com"" target="_blank">www.man-sauces.com"; or "site.man-sauces.com", since I have a wildcard set in my GoDaddy DNS settings so any alias will make it.

    Simply put, you could not enter just "http://man-sauces.com"; and get the website. You have to enter "http://http://www.man-sauces.com"" target="_blank">www.man-sauces.com"; OR "httpd://figs.man-sauces.com" and etc.

    I was able to correct this by editing //etc/httpd/conf.d/flex-80.conf and restarting Apache. Now one can access the site without a www. or figs. or mail or whatever....

    The problem is, I would really like to correct what ClearOS reports the website name is so if some change comes down the pike it won't overwrite the flex-80.conf file. Since it is read only you can't do it via the GU..I. grayed out. But there has to be a file somewhere that ClearOS reads and is editable to show this information correclty.

    Any help or suggestions would really be appreciated.

    BTW, I checked the original 6.9 ClearOS box and man-sauces was spelled correctly and showed correctly in the GUI as well as in the actual files and path/directory location. There may be a bug that drops a character when restoring or backing up.

    John

  • Nick, YOU are the man!! I Love it! I will give it a try and after reading everything and looking at the code it seems as htough it will work well. I will let you know in a few days!

    John

    PS.. THANK-YOU SIR! And the feature request.

  • There may be another way round this which is safe and repeatable and won't ever get stomped on. I bumped into this post and it gave me an idea. The commands:Need to be run when networking is down. You only need one of them, so let's use the ifconfig one.

    If you don't have one, create a file /usr/sbin/ifup-pre-local and make it executable. In it put:Obviously change eth0 and the MAC address to suit.

    Once you have created the file, to test do:

    The /usr/sbin/ifup script is already set to call /usr/sbin/ifup-pre-local, if it exists, before it does the business of bring up the interface

  • WOW! and BUMMER!

    Locking eth0 down really disables quite a few modules with "oops. Invalid interface!" Including DMZ and 1 to 1 NAT, AND IP Settings, (obviously), and more! A lot of cable companies may not be relying on MACs behind their modems that much anymore, but I know, or believe, my ISP DHCP assigned static address is linked to my router/gateway's MAC.

    I am really disappointed, (not that one user being disappointed will really matter), having used Clear since way back when good ol' ClarkConnect. I am a bit chicken to remove my MAC setting and see what happens.... but probably will.

    I truly hope that one can someday easily configure a MAC address and have things work. Clear... PLEASE?!

    On the bright side, absolutely no issues in moving a couple ClearOS 6.9 boxes to 7.6.

    John

  • Thanks again Nick!

    If I heard nothing on this issue, I was going to try to just make the file read-only for all... Not certain if that is what is called the immutable bit, but doing so would server the same purpose I suppose.

    Still have a few things to go in ClearOS! Weird change and it should only be rewritten, IMHO, when you set/change the parameters/settings of the NIC/Interface.

    Thanks!

    John

  • In ClearOS 7.6, Has Setting MACADDR changed or does modifiying ifcfg-enp2s0 still "stick"

    I need to change my MACADDR and in the past one would just add MACADDR=NewMac to the ifcfg-eth0 file. In ClearOS7.6, that file name has changed a bit.

    I did change my MAC using MACADDR in this file, it did change the MAC when I did am ifconfig to check to check it, but when I look at my ifcfg-enp2s0, MACADDR= is no there.

    How do we make this stick for multiple reboots? I have not rebooted my Clear Box yet so the MAC is still what I set it at. But where did my setting go?

    John