Profile Details

Toggle Sidebar
Recent updates
  • Do I've been investigating a little.

    My NAS is on LAN1 and LAN3 and works fine. I can ping ether interface from any network, its routing table is below



    So I see some differences with the flags and lo interface. Any idea how I might copy this table to my ubuntu machine but altered slightly to fit LAN2? Again the ubuntu routing table is below



    Any one got any idea's for me?

  • Thanks for taking the time. ;) nick

  • The routing tables I posted are from my ubuntu system.
    Sorry was not clear on the last post.

    I affraid I also don't follow.... "code" tags?

  • Any thing that can run DD-WRT.
    Got a Netgear WNR3500v2 at the mo, doing nothing more than being an AP with a built in 5 port gigabyte switch.
    And if my server goes down for any reason i just switch it to router mode and move it to the cabinet.
    Just keeps on going with out needing reboots

    Simmples :)

  • Thanks for the reply Nick
    I used the command "netstat -rn". the first one is when only the LAN2 is ative

    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    0.0.0.0 10.15.0.1 0.0.0.0 UG 0 0 0 p2p4
    10.15.0.0 0.0.0.0 255.255.255.240 U 0 0 0 p2p4

    And this one is when both LAN1 & LAN2 are connected

    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    0.0.0.0 10.15.0.1 0.0.0.0 UG 0 0 0 p2p4
    10.15.0.0 0.0.0.0 255.255.255.240 U 0 0 0 p2p4
    192.168.15.0 0.0.0.0 255.255.255.0 U 0 0 0 p2p3

    Routing tables I still just don't get! :p

  • Duncan Rix
    Duncan Rix replied to the discussion, Which ISP do you use?
    • 299 Hits
    • 9 Replies
      Replied on Wednesday, 15 July 2015

    Having purchased my first house I'm now on VDSL with eclipse. Tech support is brill but they have a bandwidth bucketing system which I did not realize at first. Because of this I will be moving to BT business later this year

  • Duncan Rix
    Duncan Rix replied to a discussion, Where is all the documentation?

    Nothing constructive to say.

    Just want it out there that I also agree with Nick

  • Try enabling all the repos, came up with zabbix then for me

    yum install --enablerepo=* zabbix

  • Strainge networking issue with multiple LAN's

    "Hi community.
    Like the look of the new site dev guys.... will take me some getting used to though! As I might have all ready posted this somewhere in the forum's all ready. Sorry if i have but its a no show if I click "show my posts" option. "

    I have a ClearOS gateway with multiple NIC's set-up for multiple LAN's. I have provided a brief description of the layout below.

    ClearOS Gateway
    LAN1 in LAN mode
    192.168.15.1
    255.255.255.0

    I use LAN1 for the local network, no restrictions just a simple LAN for all my home devices.

    LAN2 in LAN mode
    10.15.0.1
    255.255.255.240

    Will become a DMS once I switch ISP in September. For now I will more than likely change to HOTLAN mode at a later date, as will be used for internet facing services E.g game servers

    I have an ubuntu 14 server also with multiple NIC's and this is where the problem starts

    NIC1 connected to LAN1
    Static config
    192.168.15.254
    255.255.255.0

    NIC2 connected to LAN2
    Static config
    10.15.0.2
    255.255.255.240

    Now onto the problem.

    If I have just one NIC configured say NIC2 I am able to ping it using my windows machine connected to LAN1 and am able to access the services on it say game servers.
    If I then enable both NIC's in the ubuntu server I can no longer ping NIC2 but I can ping NIC1.

    When I connect my laptop to LAN2 the same is ture for that network. I can ping NIC2 but not NIC1, and If just NIC1 is connected I can ping NIC1.

    I then connected my laptop to both networks and this showed the same result.
    Windows machine could only ping the laptops conection to LAN1 and the ubuntu machine which at this time only had NIC2 configured could only ping the laptop on its LAN2 connection.

    When both NIC's are configured on the ubuntu server I can no longer access its services via LAN2, however they are still available to the internet and systems connected to LAN2 only.

    I think this might be a routing issue and have found lots of info regarding setting routes too and from certain networks, and default NIC's for said network traffic. Of witch I have tried many and none have made any change to the behaviour of he network.

    So far these routes have only been applied to the ubuntu server machine but I'm not sure that’s where the problem is.

    If any one cloud point me in the right direction, or shed some light on this I'd be grateful l.