ClearOS 7 Business Edition is Officially Released! SEE WHAT'S NEW
Toggle Bar

Profile Details

Toggle Sidebar
Recent updates
  • Paul
    Paul replied to a discussion, RAID Manager Notification Issue

    Hi here are my results

    and for completeness

  • Paul
    Paul replied to a discussion, RAID Manager Notification Issue

    I have the almost same error in my system log (md0 rather than md1) so your not alone. I wouldnt of known without seeing your post and checking my log. if you run "parted -l" to list your disk partitions you can see the error there too. I ran "mdadm --detail /dev/md0" and it shows me that my array is clean and in sync. My storage seems to be working fine so I will just keep an eye on it unless someone posts here it is a problem that needs fixing.

  • Paul
    Paul replied to a discussion, DNSCRYPT-PROXY usage

    got it all working including a startup script. Now I just need to pick a long term dns provider who I can trust from This list

    Eventually I will have to look at adding more than one dns server but that can wait

  • Paul
    Paul replied to a discussion, DNSCRYPT-PROXY usage

    Hi Nick

    Your link was enough info for me to get it working. Now to get it all to load on boot which I should be able to manage always rc.local if I get stuck


  • Paul
    Paul replied to a discussion, DNSCRYPT-PROXY usage

    Thanks Nick that looks like something I can try. I have proved the my dnscrypt-proxy works by
    1. netstat -nlp|grep :53 to confirm dnsmasq was on that port
    2. stopping dnsmasq
    3. pinging and name was not resolved
    4. bringing up the dnscrpt-proxy on port 53
    5. pinging and name was resolved

    but as your link says "every single query will make a round-trip to the upstream resolver."

    So I will give the dnmasq config changes a go.

  • Paul
    Paul started a new discussion, DNSCRYPT-PROXY usage


    Hi I am trying to set up dnscrypt-proxy on my clearos server so that my dns queries will be encrypted. I have downloaded and compiled the source libsodium and dnscrypt-proxy and I can run it fine on say port 54. So I have got most of the way there and using a nslookup and specifying port 54 it works :).

    Now the question bind runs on port 53 I had hoped to update my /etc/resolv-peers.conf file to use my dnscrypt-proxy but it appears you cant specify a port number (54) in the conf file. So what I need is some help to get from where I am to my server using the proxy. How would I alter my bind config to use my dnscrypt-proxy?

    Thanks in advance for any help :)

  • Paul

    Any links/information on how to configure the network on your host when using Vitrualisation. I got in a right mess trying to configure a bridge using ClearOS 6 so much so that I abandoned setting it up. Something I didnt want to do but had to due to demands from the rest of the family on using the server.

    I had one server with one nic in gateway mode(I think) and I seem to remember I had problems getting the server to recognise and use a default gateway.

  • Nick Howitt wrote:

    On my system I have a yum.conf and a yum.conf.rpmnew. It is only the yum.conf.rpmnew which has a line "distroverpkg=centos-release". Did you by and chance notice the new file then swap them round? Can I suggest you reset your yum.conf to be the same as mine (from 6.6.0):

    Hi Nick I have done as you suggested and replaced my yum.conf with yours and yum still works. I didnt have a yum.conf.rpmnew and didnt swap them at all so not sure how it happened.

    Thanks again for your help much appreciated.


  • Tim Burgess wrote:

    I have the same yum package here from clearos-updates and is OK. The file /etc/centos-release is usually provide by a package called 'centos-release-xxx.rpm' do you have this installed? Perhaps in setting up Zabbix it may have messed up your mirror config. If so... you'll need to remove the package

    You should have clearos-release-community installed, if not you will need to as this contains the clearos repos for updating.
    [root@leonardo ~]# rpm -qf /etc/clearos-release

    Hi Tim


    So I will just put it down to a strange oddity and carry on actually using the server :)

  • Well I have had a dig around and discovered that yum-3.2.29-69.el6.centos.noarch was installed as part of my update which was when I started having problems. I do have Zabbix installed but from the commands below you can see that yum-3.2.29-69.el6.centos.noarch came from clearos-updates.