Profile Details

Toggle Sidebar
Recent updates
  • John
    John replied to a discussion, Unable to use DNS aliases in browser

    I've made some progress after making a few changes.
    First I changed the static IP- & DNS of my clients to Automatic and setup the DHCP server to hand out static ip addresses to my specific MAC addresses.
    But when ever I connect with VPN from one of my Win10 clients, the setting of obtaining a DNS automatically changes to the DNS of the VPN service (supposedly required for VPN), so I will have to manually add my COS DNS server to it after every time I connect with it.
    I am consulting the support desk of my VPN for this issue.
    It is currently not yet solved, but I have a work-a-round for now ... I hate it, but at least it works.

  • John
    John replied to a discussion, Unable to use DNS aliases in browser

    First I want to add something, because I am using COS version 7.9.1 (Final) and not 7.2 like I mentioned earlier.
    Your remark made me think and I realized that I didn't have the COS box as an additional DNS server on my Windows clients.
    After adding that to it's IP4 settings, I was able to access the COS web configuration page with the correct aliases, so I think that solved the problem.

    The only problem that remains is that even after adding an additional ip address to the Windows clients (192.168.178.# of the router), I am still unable to access the router page directly.
    If I want to do that I have to connect my workstation directly to my router, after manually giving it an ip address in the same range (192.168.178.# of the router).
    It would be nice if this could be solved too, but I don't know if this is a COS problem.

    Please advice,

    John

  • John
    John replied to a discussion, Unable to use DNS aliases in browser

    So why does it still not work when I shutdown my NordVPN ... ?!?

  • John
    John replied to a discussion, Unable to use DNS aliases in browser

    I use NordVPN, installed on my clients only, so I assume that this has nothing to do with my COS box.

  • John
    John started a new discussion, Unable to use DNS aliases in browser

    Unable to use DNS aliases in browser

    Hi all,

    Can someone please explain to me why I cannot get the DNS aliases to work ... ?!?
    I have read several other posts about related issues, but I was unable to find a solution.
    I also followed the instructions of the DNS Server documentation.

    I am using COS 7.2 as a gateway box with Windows 10 clients with static ip addresses (in the same subnet).
    According to "/etc/hosts" all entries are looking correct and it does not matter if I use <alias.lan> or <alias> on the Windows clients.

    I do admit that I use VPN on the clients, but AFAIK this should not affect the local network.
    When I attempt "nslookup" on one of the clients with VPN activated I get the following result:

    When I attempt "nslookup" on one of the clients with VPN deactivated I get the following result:

    I am able to access the following in my browser on my clients:


    But when I attempt to use one of the aliases from the DNS Server, it does not work.
    Rebooting did not solve the problem.
    DHCP Server is up and running, same goes for my website that I host on my COS box.

    This has never worked before.
    Please advice so I can solve this issue once and for all,

    John

  • Thanks Nick,

    That solved it for me.

    Greetings,

    John

  • Thanks Nick,

    According to the "Attack Detector", the local ip address attempted to do a SSHD & SSHD-DDOS recently.
    When I temporary disabled these 2 I was able to connect to the Web interface from that client again, what confirmed the cause of the problem, but that is not a solution I am happy with.
    Adding the local ip address to the "Intrusion Prevention System" White List did not solve the problem.

    Please advice,

    John

  • John
    John replied to a discussion, Certificate not in use

    Thanks for all your responses guys ... I really appreciate it,

    It seemed that the Web Server was stopped, so after manually starting it, my default website was working again.
    This time with a secure connection as you can see in the picture.

    I still need to recreate the certificate to make sure that when someone types www, it still works.
    Can someone please advice on what other things I need to prepare for when doing this, so I don't have to redo this several times ... ?!?

    I would additionally like to ask how to setup my Web Server so that it always goes to https ... even when not typed by the user.
    Closing port 80 is not enough ... or is that a bad idea ... ?!?

    For the rest I could not really understand the stuff you where talking about ... not sure if it's a good idea to start fooling around with the command line if I don't understand what I am doing.
    Please don't be offended, but especially when you guys contradict each other.

    Please assist,

    John

  • John
    John replied to a discussion, Certificate not in use

    Thanks Nick,

    I will have to delete and recreate the certificate, because I don't know how to edit it.

    Yesterday I was still able to access the default web page from my LAN ... I don't know what changed that could have affected that.

    I am also new to Serviio, so I will ask around on their forum if they can enlighten me about certificates, but I doubt that they know anything about it.

    Greetings,

    John

  • John
    John replied to a discussion, Certificate not in use

    Thanks Nick,

    I was able to partially use my new certificate for the webconfig.
    With Tor I have a green lock, but with FireFox I get a grey lock (both report a secure connection).
    This happens when I use https://<domain.com>:81 (see pictures)
    When I type www.<domain.com>;:81" target="_blank">https://www.<domain.com>;:81 I still get a warning from my browser.
    I don't know why this happens, because I have an A & AAAA record for <domain.com>, www.<domain.com>; and for *.<domain.com>

    For unknown reasons I was unable to access the default website at http:// & https://.
    I closed port 80, because it does not seem to work at all.
    Yesterday i was able to access the default web page.

    The Media Browser from Serviio works (not the certificate), but I do not know where to start adding the certificate to it.
    The only place in the webconfig that I could find it is for the Web Flexshare that I use for the Serviio Media Browser, but that does not work.
    I tried reading your HowTo, but that was way too complicated for it to make any sense to me.

    Please advice,

    John