Profile Details

Toggle Sidebar
Recent updates
  • Hi Tony,
    I want keep the mail on ZEG.
    Though I would like to be able to authenticate against ClearOS ldap.
    So I would not have to keep two copies of user data, one on ZEG and one on ClearOS.
    Thank you.

  • Hi Tony,
    How is this been working for you? Any issues? How is sync with iphone/android?

    I tried to use ZEG VM and authenticate to COS. btw: I kind of like the idea of keeping the mail separate from the clearos.

    I was able to login with my clear user/password but got an error:
    = <0x0x5633e96d06d0[NGImap4Client]: login=robert(pwd) socket=<NGActiveSocket[0x0x5633e9a74e20]: mode=rw address=<0x0x5633e9a74ec0[NGInternetSocketAddress]: host=localhost port=33062> connectedTo=<0x0x5633e96d08a0[NGInternetSocketAddress]: host=127.0.0.1 port=1143>>>
    Feb 18 21:18:02 sogod [1821]: <0x5633e9684b70[SOGoMailAccount]:0> renewing imap4 password
    Feb 18 21:18:02 sogod [1821]: [ERROR] <0x0x5633e9c86060[NGImap4ConnectionManager]> IMAP4 login failed:
    host=127.0.0.1, user=robert, pwd=yes
    url=imap://robert@127.0.0.1:1143/
    base=(null)
    base-class=(null))

    I think this is telling me that I do not have an account on ZEG .... any idea on how to fix that?
    In your solution creation of the user on Cos creates users in SOGO?
    Thanks

  • Augustynr
    Augustynr started a new discussion, Downstream rules do not work?

    Downstream rules do not work?

    Hi,

    I have been playing with qos on 7.2 and cannot get this to work as I would expect.
    I am trying simple test where I would limit the speed to an IP address goin up and down but it seems like going down it does not work.
    Is this by design? Am I missing something?
    With following configuration I would expect my up and down speed from 192.168.1.156 be at 100% up and down but it is 50% down and 100% up.

    QOS_ENABLE="on"
    QOS_UPSTREAM="eth0:auto"
    QOS_DOWNSTREAM="eth0:auto"
    QOS_UPSTREAM_BWRES="*:15:15:14:14:14:14:14"
    QOS_DOWNSTREAM_BWRES="*:15:15:14:14:14:14:14"
    QOS_UPSTREAM_BWLIMIT="*:15:15:14:100:14:14:50:14"
    QOS_DOWNSTREAM_BWLIMIT="*:15:15:14:100:14:14:50:14"
    # IPv4
    QOS_PRIOMARK4="\
    All_ICMP_Down|*|1|1|0|icmp|-|-|-|- \
    All_ICMP_Up|*|1|0|0|icmp|-|-|-|- \
    DNS|*|1|0|0|udp|-|-|-|53 \
    test_down|*|1|1|3|-|-|-|192.1.199.156|- \
    testup|*|1|0|3|-|192.1.199.156|-|-|- \
    "
    # TODO: IPv6
    QOS_PRIOMARK6="\
    "
    QOS_PRIOMARK4_CUSTOM="\
    TCP_ACK_Up|*|1|0|1|-p tcp -m length --length :64
    TCP_ACK_Down|*|1|1|1|-p tcp -m length --length :64
    "
    # TODO: IPv6
    QOS_PRIOMARK6_CUSTOM="\
    "
    QOS_ENGINE="/usr/clearos/apps/qos/deploy/libqos.lua"

  • Augustynr
    Augustynr unlocked the badge Bookworm
    Bookworm
    Loves reading the forums.
  • Augustynr
    Augustynr replied to a discussion, Bridging with PPPoE and how?

    Nick and Tony,
    Thank you.
    I have tried it all and since the provider assigns the pppoe IP from the same subnet as the rest of the ips the only thing which seems to work is 1to1.

    Thanks for you help.

  • Augustynr
    Augustynr replied to a discussion, Bridging with PPPoE and how?

    Hi Nick,
    The setup I have been trying in the first place is Transparent In-line Bridge, which works ok but not with pppoe as per my original message.
    Maybe I am wrong but if I have two interfaces on the box ( in a stand alone mode ) and setup the static routing then why would that not work as a router?
    I am referring to just the routing part of traffic in and out with nothing else which is what I need.

    If I use the DMZ how would I route it? my wan and Lan would be on the same subnet?
    Thanks again.

  • Augustynr
    Augustynr replied to a discussion, Bridging with PPPoE and how?

    Thanks Nick :)
    The WAN interface if PPPoE. The PPPoE is giving us always the same IP. So that works ok.
    I would like to avoid the 1to1 Nat app if possible.

    How about setting the machine up as a standallone with not firewall?
    External interface would do the PPPoE (2.8.161.137) LAN could have 2.8.161.138 and that leaves me with 4 more ips to work with.
    Do you see any issues with that? How about routing ?

    Thanks again.

  • Augustynr
    Augustynr replied to a discussion, Bridging with PPPoE and how?

    I tired to add the ppp0 from the command line and it does not work:
    [root@router-01 network-scripts]# brctl addif br1 ppp0
    can't add ppp0 to bridge br1: Invalid argument

    Not much on the net on the subject ....

    Can I then bridge the actual interface which ppp0 is attached to?

  • Augustynr
    Augustynr started a new discussion, Bridging with PPPoE and how?

    Bridging with PPPoE and how?

    Hi,
    I have a problem which I am not sure what right solution should be used to solve it ...
    I am switching to a fiber connection which is delivered over PPPoE.
    That connection creates one external IP. We need more so we have ordered 5 ...
    Now how do I make it work?
    I was thinking that setting up a box in bridge mode would work, though I tried to follow this:
    https://www.clearos.com/resources/documentation/clearos/content:en_us:kb_o_clearbox_as_a_transparent_inline_bridge
    It does not seem to work for me.
    Having ppp interface may have played a role in me configuring it wrong.

    The PPPoE once configured gets 2.8.161.137 ip. then we have 2.8.161.137-41.
    So idea is to bridge two ports connected it to the switch and have other servers which need external ips to connect to that with 2.8.161.137 as gateway address.
    Once I configured it as per below the connection on the second port ( enp3s0 ) went out
    Any idea how to do it correctly, or is there a better easier way to do it?
    Thanks,

    /etc/sysconfig/network-scripts/ifcfg-br0
    DEVICE=br0
    TYPE="Bridge"
    ONBOOT="yes"
    USERCTL="no"
    BOOTPROTO="static"
    STP="on"
    IPADDR="2.8.161.137"
    NETMASK="255.255.248.0"
    GATEWAY="2.8.161.137"


    The ppp is connected to network port enp2s0 the second port is enp3s0

    /etc/sysconfig/network-scripts/ifcfg-enp2s0
    DEVICE=enp2s0
    BOOTPROTO="none"
    ONBOOT="no"

    /etc/sysconfig/network-scripts/ifcfg-enp3s0
    DEVICE=enp3s0
    TYPE="Ethernet"
    ONBOOT="yes"
    USERCTL="no"
    BRIDGE=br0

  • Hi Nick,
    Thanks, I have tried that and it seems to work :)
    The side effects of this is a delivery of undeliverable email message :(
    So for example if spammers use my email or a valid email address as from that address will get following email:

    "This is the mail system at host mail.sendingdomain.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system"

    Any easy ways of dealing with it?