Profile Details

Toggle Sidebar
Recent updates
  • Thanks great news.

    I guess I've solved this in the apache root configuration file while preventing all http (only) communications.

  • Nick Howitt wrote:

    Thanks for that. To make my life easy, is there any chance that you can e-mail your /usr/clearos/apps/flexshare/libraries/Flexshare.php to me at support@clearcenter.com?


    Sure !

    I've done. Please confirm reception...

    I hope it will helps.

    Taryck.

  • Thanks for that. To make my life easy, is there any chance that you can e-mail your /usr/clearos/apps/flexshare/libraries/Flexshare.php to me at support@clearcenter.com?

  • Hi Developpers,

    I've fixed the /usr/clearos/apps/flexshare/libraries/Flexshare.php
    with line 3282 : I've add the variable $options like this :


    Instead of :


    So naturaly I've extended the function line 3433 with :

    Instead of


    And at last I do the job with an insert before line 3549 :
    Insted of :

    I've set :


    And job done.

    I hope it will helps to include this in the nex release of Flexshare.

  • Taryck BENSIALI
    Taryck BENSIALI's reply was accepted as an answer

    Re: Alternative URL no longer working

    Hi All,

    I've google a little and find this post :
    https://serverfault.com/questions/786371/apache-2-4-options-indexes-inside-virtualhost



    So I've fixed this issue with adding this at the end :


    So now the question is how could we fix the flexshare apps ?



    Any help will be apreciated

  • Hi All,

    I've google a little and find this post :
    https://serverfault.com/questions/786371/apache-2-4-options-indexes-inside-virtualhost



    So I've fixed this issue with adding this at the end :


    So now the question is how could we fix the flexshare apps ?



    Any help will be apreciated

  • Alternative URL no longer working

    Hi All,

    The Alternative url : [share].server.sufix
    is no longer working while the base url : server.sufix/flexshare/[share]/
    is working

    The appache error is :

    Because the appache configuration is generated by flexshare webconfig in /etc/httpd/conf.d/flex-443.conf
    I can't fix it.
    The generated configation is :
    Alias /flexshare/[share] /var/flexshare/shares/[share]

    <VirtualHost *:443>
    ServerName [share].server.sufix
    DocumentRoot /var/flexshare/shares/[share]
    ErrorLog /var/log/httpd/server.sufix_error_log
    CustomLog /var/log/httpd/server.sufix_access_log common
    SSLEngine on
    # No weak export crypto allowed
    SSLHonorCipherOrder on
    SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
    SSLCipherSuite ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+A$
    SetEnvIf User-Agent ".*MSIE.*"nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
    DefineExternalAuth pwauth pipe /usr/bin/pwauth
    DefineExternalGroup pwauth pipe /usr/bin/unixgroup
    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/server.sufix/cert.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/server.sufix/privkey.pem
    SSLCertificateChainFile /etc/letsencrypt/live/server.sufix/chain.pem
    </VirtualHost>

    <Directory /var/flexshare/shares/[share]>
    Options +Indexes +FollowSymLinks -IncludesNOExec
    AuthName "my share"
    AuthType Basic
    AuthBasicProvider external
    AuthExternal pwauth
    <RequireAll>
    Require unix-group moi
    </RequireAll>
    <FilesMatch \.php$>
    SetHandler None
    ForceType text/plain
    SetHandler application/x-httpd-php-source
    </FilesMatch>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    </Directory>

    I also do not understand why the configuration is different as they both target the same folder and so the same configuration directives ?!?
    What did I miss ?

    Why this working feature is now down ?

    As the user get a 403 error :
    92.184.105.74 - - [17/Jun/2022:10:06:46 +0200] "GET / HTTP/1.1" 403 4897

  • Hi Nick,

    I do not want to use ISP or GMAIL service for sending.
    I'm sending from my own domain a message to a gmail adress.

    The error comes from postfix who constanly try to contact port 25 in order to see if the target SMTP server support TLS.
    I don't know why but because Google no longer responding on port 25 the sending process stop here what ever I configure on postfix this damn software still try to connect on port 25 !

    After a new try I realize that this is a new FW rules that my IPS add to the internet box :
    Block all traffic on port 25 & 445
    What a brillant idea... :-/
    So big loss of time !

  • Hi Nick,

    Thanks. I've backup my .cf file.

    I don't know why The tutorials told to remove them but I guess it's because package named postfix3 instead of postfix.

    I was able to remove the postfix and install postfix3

    However I still have timeout on port 25 for google smtp.

    I do not realy use the mail app I just need to be able to send notification email to alert me on issues on the server. So I don't think i'm using ldap integration at all.

    I'll try your hack if I do not have any other option but at first I would like to keep track of the sender root or aprwatch or ...
    and I do not which (if I can avoid it) to hide them behind my IPS email

  • Taryck BENSIALI
    Taryck BENSIALI replied to a discussion, Webconfig is very slow

    Thanks Nick. I had the same issue