Profile Details

Toggle Sidebar
Recent updates
  • Hi Mike....... From my limited experience/understanding of SIP, when your WAN fails-over onto WAN2, your phones will need to re-register with the hosted VoIP server, so that your change of public IP address is updated. Could it be that your phones are not automatically re-registering when they lose service, or that some default registration timeout is set quite high?

  • This post caught my eye..... we have had similar experiences on several COS6 sites when installing the latest version of Sage Accounting and Payroll applications. They'll install fine on Windows 7 clients, however on Windows 10, at the end of the install they're unable to communicate with Sage's licensing/activation server and run in trial mode. Like Jeff, the workaround we discovered was to login with a local admin non domain account to activate the product, after which the application worked fine with any domain user account. I should add that the domain user accounts all had full local admin rights.

    Installing the same Sage products on a COS7 site with Windows 10 clients, we did not have this problem. At all our sites COS is the PDC.

    Sorry not to be able to add any real technical input to this, other than like Nick said, COS7 may well resolve this for you, as indicated by our experiences with Sage.


    Cheers....... Andy

  • Hi Andrea,

    If you've got ClearOS set up in gateway mode, when you come to initialise Windows Networking you need to make sure you have something connected to the LAN network interface. This caught me out a couple of times in the past, when on a new build I was accessing the WebConfig via the WAN interface, and had nothing connected to the LAN. Windows networking will sit indefinitely trying to initialise, the moment you connect say a network switch to the LAN interface, initialisation will instantly complete.

    Hope this helps.


    Cheers...... Andy

  • One of my team got the following response from Support at Clearcenter today...

    "We just had a Innovation conference in Toronto with the ClearOS development team there and the new direction that was decided is with a docker-based method for Samba directory. There are a couple of reasons for that; one of them being security isolation and the other is being able to partition the directory in a way that is more scalable. We will have further guidance by Monday, June 11."


    Light at the end of the tunnel hopefully...... Dev's, How can we assist with this?.... we can run live environments if this helps....?


    Cheers..... Andy

  • Hi Nick,

    Thanks for the "heads-up" on this.... it save me a lot of time this week when I ran into issues joining some new Windows 10 clients to one of my customers domains. Luckily, we were able to roll these back to an earlier build, but this is going to be a major headache when PC's ship with a 1803 build pre-installed, and the only option will be to send someone to site to flatten and rebuild with a 1709 ISO.

    Any word from the Dev's on moving forward with Samba 4 AD...... ?

    Cheers.... Andy

  • On the CoS server: -


    In DHCP what is the Domain?
    In Directory Server what is the Base domain?
    In Windows Networking, what is the Windows Domain?



    From your workstation can you screenshot the output of ipconfig /all

    Is your workstation currently a member of a domain or a workgroup?

  • Is your CoS server providing DHCP and DNS services on your network?

  • What error/response do you get when attempting to join a workstation to the domain?

  • Hi Ralph,

    In your re-installation you've chosen to install the single Samba Directory app to achieve your Windows Domain/Networking environment, rather than the Directory Server (OpenLDAP) and the Windows Networking (Samba) apps you originally used.

    Please be aware that the Samba Directory app is still in Beta, my understanding is that it doesn't play nicely with some of the other Marketplace apps, so not recommended for a production server.

    I’ve not played with the Samba Directory for quite a while so can’t comment on the correctness of your installation procedure, although I’m a little surprised you needed to manually edit the hosts and smb.conf files, but like I said I’ve not played with this for a while.

    Cheers.... Andy