Profile Details

Toggle Sidebar
Recent updates
  • Robert Moskowitz

    I have Cubieboard2 and Cubietruck that I can easily test on. If you can build on the Centos7 image, and add to it via a specific repo we can easily jumpstart the work. Using the Gnome image would give a nice remote desktop. I have finally figured out vncserver as I explain on my web page.

    Cubies are nice because how easy the image install to sata is. I just dd to the sata via usb, then use gparted to adjust partitions as I want.

    Noarch rpms are really nice. Unless they have dependencies in EPEL that have compiled. I was burnt with that trying to get Xfce desktop going.

    I have some time next week. Then the Jewish Holidays start and I am very stressed until into the 1st week of Oct.

    So please keep me in the loop. Meanwhile I have a Zotac Zbox nano...

  • Robert Moskowitz

    Support for ARM architecture

    I tried some searches on "arm", but only found one reference of attempting a port to arm by Sergei Pupykin back in May in the "Clearsync repository missing build tags" thread.

    The Centos ARM SIG has made great strides in the ARM images: (for armv7) (for armv8 64 bit)

    I have my own howto at:

    and I really need to update:
    as it should be easier now than a year ago....

    It would be really great to at least have the basic server functions on arm boards for small home office use.

    If this has come up elsewhere, please point me to the discussion.


  • Join Window 7 workstation to ClearOS7 domain

    This is a new server with all updates applied.

    And the workstation is a recent build and registered with MS. All updates applied.

    The server is homebase.home.htt (

    The client is on the same subnet ( and can ping homebase.

    \\homebase.home.htt on the start programs box opens up explore showing all my shares and I have no trouble opening up public shares.

    I have made the registry hack via regedit. I go to Windows Explore> Computer > System Properties > Computer Name, domain, workgroup settings and select Network ID and follow the wizard.

    I have tried both HOMEBASE and HOMEBASE.HOME.HTT for the Computer Domain. The error I get is that teh AD DC cannot be contacted.

    What do I do to get the computer to join the server?



  • I have a howto on setting up a Centos7 multidomain mail server at:

    This is on a CubieTruck armv7, but it is Centos7 which SHOULD mean that you can install the whole suite on a ClearOS7 box.

    This is an improvement on my Redsleave6 mailserver. So I have been using this sort of setup for a lot of years.

    Just note that amavis and clamav can eat up 2 cores easily.

  • Yes, you have the ClearOS CA cert. This shows how to create server certs, using a private CA cert for signing. That is the 'key' part. I have plenty of examples of self-signing certs at:

    I need to add running a private CA like the OP is asking.

  • has an example of creating your own CA cert and then signing your own server certs with it. See:


    Private Certification Authority

    I need to work some on developing this.

    Probably later next week.

  • Make sure you have adequate random entropy to strongly create all those certs. Consider installing haveged. In fact install it on all your servers, as randomness is needed for every TLS setup and message.

    I really don't think the cert management interface is rich enough. I don't expect to dig into this for a couple weeks so could be wrong on my assessment.

  • After base install, add windows networks and flexshare from the marketplace and you are set to configure your NAS. Set up for 'simple' windows file sharing and web access.

    Or you can run as a full NT-style domain PDC with roaming profiles support (how I do it).

  • Robert Moskowitz
    Robert Moskowitz's reply was accepted as an answer

    Re: Postfix not forwarding loqwatch report

    Yeah, telnet is like that; so easy to forget you have to provide a port. Been there, done that too often.

    z9m9z is only as complex as it needs to be. I run a number of virtual hosts from it. The challenge here is what has been done to the default Centos postfix configuration by ClearOS.

    I took a quick look at /etc/postfix/ and saw that I had set the domain to That would convince postfix to do a local delivery. So I changed it to home.htt and ran a test with:

    sendmail -i < xfce.lst

    and that was properly relayed through z9m9z. So the problem was mine in ClearOS in improper configuration of the Mail Settings dialog.

    One for your tips and tricks for those that use an external (to ClearOS) mail service. The ClearOS mail domain MUST be different from your external mail service domain.

    Oh, and if you want help developing a rich featured email service, I am available.

  • In my set up, ClearOS is not a gateway. It is just a server. And servers have processes that generate mail reports to forward to the admin.

    On a more 'normal' server setup, the server may well be in the same domain as all of the other systems, thus this problem. home.htt domain is just a hold over from my setup some 7 - 8 years back.

    I think a regular admin, would fall into the same setup I did.

    Say Google is hosting your mail service. And you have a Sonicwall gateway (my brother-in-law has a number of clients like this). Then you setup ClearOS as your file/print server and maybe another function or two (local Cloud?). I might think the common thought would be to use your domain name in the mail setup, just as I did. Should be some subzone like

    Anyway, one more little change. Now all I have to do is either buy one of the cheap OEM copies of Win7 and install it on an old box here, or buy a reconditioned box with Win7 installed. Then I can start testing out an actual client.