My Community Dashboard

  • Teamspeak 3 Server Question


    I recently installed 7.2, and I'm getting it all set back up to my previous setup. I'm currently trying to setup a teamspeak 3 server. Previously I had done this as root, and just had it running as root every time the box would reboot, or go down. Now, in the name of security, I've decided to try and set it up as it's own little daemon user, but I'm running into issues. I started by creating the user "tsdaemon", adding the password, then downloading the server file for linux for the website into the "/home/tsdaemon" directory. Once it was down I attempted to tar xvfj the file (it was a bz2 zip), doing that returned an error that said no permission allowed. So I backed out and added the daemon account to my sudoers file, just to get the setup done. Tried again, and I didn't have bzip installed, so I installed bzip, and got my package unzipped.

    Next I went into the freshly unzipped folder and tried to run the start script, again issues with permission denied, so I ran it as sudo, success. So I tried backing out again, and changing the owner of the directory to my tsdaemon user (chown tsdaemon /home/tsdaemon/teamspeak_directory_here). Switched back to my daemon user and attempted the start script again, still no luck. Ultimately I want to get this setup to start on reboot automatically by adding a cronjob, but if it can't start by manually running the start script, I don't have a ton of faith in that cronjob working.

    What do I need to do to give my daemon user the proper permissions to successfully run that start script? My cron job is just going to be:

    I'm not yet super well versed in linux permissions systems, but here's the output of my ls -al on the folder:

    Anyone have any suggestions?