My Community Dashboard

  • Fargo2
    Fargo2 started a new discussion, Any Luck with afpfs-ng ?

    Any Luck with afpfs-ng ?

    I want to copy some 1TB of files from Apple Time Capsule to my clearOS server. I have a gigabit ethernet link between the two machines. I did a test using ipref, and found that Time Capsule is capable of pushing upto 650mb/s (~80MB/s) via its network ports.

    I tried SMB, but got around 17MB/s only of transfer speed using rsync with all possible optimization I know. So, I decided to try AFP instead knowing that Apple always prefers its own tech! (I'm aware that Apple decided to drop AFP in favor of SMB3, but my time capsule is an old fellow!)

    I downloaded and compiled afpfs-ng ver. 0.8.2 (updated 2 years ago) using the following commands:

    Then started the daemon:

    and it worked :) So, I mounted the Time Capsule:

    and started synchronizing the files:

    What an improvement! It started from 25MB/s and escalated up to 80MB/s!

    But that did not have a happy ending! The transfer is always interrupted with an error message saying: Danger, recursive loop

    When I look at the log, I find complaints from afpfsd saying: I have no idea what this is a reply to, id 3148.

    I'd like to know if anyone here has tried this afpfs-ng with clearOS 7.3, and how was it?

    Thank you.