My Community Dashboard

  • I've tried an update to Kopano (so not the Webapp or z-push yet) on a VM and I've found the following:


    • The initial installation was missing php-soap and php-mbstring which stopped z-push from working. Installing them and restarting httpd fixed it.
    • server.cfg has four obsolete parameters, but they don't matter as we do not specify them so the defaults are used
    • All the userscripts (e.g.createuser) have moved from /etc/kopano/userscripts to /usr/lib/kopano/userscripts so the entries in server.cfg need updating. Probably a better idea than moving the scripts.
    • ical.cfg has 4 obsolete parameters which need to be changed as noted by Patrick, but note that icals never worked as it was set to disable to enable it you also have to set ssl_private_key_file and ssl_certificate_file. I used the values from gateway.cfg. This still had another issue. See next point.
    • Kopano could never read the certificates as presented for icals, imaps and pop3s as they had root:root ownership and 0700 permissions. kkopano was unable to read the files as it runs as user kopano. You can set the permissions to 0744, but, perhaps better is to change the ownership to root:ssl-cert, permissions to 0740 and add kopano to the ssl-cert group.
    • gateway.cfg had 8 obsolete parameters as noted by Patrick
    • The webconfig will need updating to allow reading the new parameters in gateway.cfg and ical.cfg. The fields change from just being a straight port value to being ip:port but the ip can be defaulted to *, so "*:110" for pop3 etc.
    • Optionally the webconfig could be changed to allow a blank port to write a blank value to the parameter to disable the setting, or some other method used to disable the setting. This is not currently done in the webconfig so could be skipped.
    • All the changes to the parameters and sorting out the certificates could be scripted in a deploy/upgrade routine in the webconfig.


    I still need to do some proper testing, then move onto z-push.

    Patrick, can you remind me of the field which needed to be changed in the configuration so it just read the username and not the full e-mail address?