'Cross-site scripting (XSS) vulnerability in the mod_negotiation module in the Apache HTTP Server 2.2.6 and earlier in the 2.2.x series, 2.0.61 and earlier in the 2.0.x series, and 1.3.39 and earlier in the 1.3.x series allows remote authenticated users to inject arbitrary web script or HTML by uploading a file with a name containing XSS sequences and a file extension, which leads to injection within a (1) “406 Not Acceptable” or (2) “300 Multiple Choices” HTTP response when the extension is omitted in a request for the file.'
This issue was resolved in a backported fix. Current up to date versions not affected.
This issue was resolved in httpd-2.2.3-74.el5 (ClearOS 5.x) and httpd-2.2.15-26.el6 (ClearOS 6.x). Current versions meet or exceed this minor release.
To validate that you are running httpd-2.2.3-74.el5 (ClearOS 5.x) and httpd-2.2.15-26.el6 (ClearOS 6.x) or later, run the following:
rpm -qi httpd
If you need to update, run the following: