ClearOS Documentation

×

Warning

301 error for file:https://clearos.com/dokuwiki2/lib/exe/css.php?t=dokuwiki&tseed=82873f9c9a1f5784b951644363f20ef8

User Tools

Site Tools


CVE 2014-8109

'mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.'

ClearCenter response

This issue affects ClearOS 7. No version of ClearOS 6 was affected by this issue.

Short response

This issue occurs when the http module for lua and other versions of lua are out of phase in feature and control sets. On ClearOS, this doesn't happen since updates are generationally added.

Long response

This issue occurs when the http module for lua and other versions of lua are out of phase in feature and control sets. On ClearOS, this doesn't happen since updates are generationally added. Users who are using custom versions of lua outside of what is available from the ClearOS Marketplace and updates system are advised to consider the security implications of potentially disparate versions.

Resolution

Nothing is required if using ClearOS modules from the ClearOS Marketplace. If you are using custom lua libraries, validate that all functions exist in a one to one relationship between your custom code and the coordinated libraries in ClearOS.

content/en_us/announcements_cve_cve-2014-8109.txt · Last modified: 2018/10/01 10:37 by dloper

https://clearos.com/dokuwiki2/lib/exe/indexer.php?id=content%3Aen_us%3Aannouncements_cve_cve-2014-8109&1558513153