Community Forum

Resolved
1 votes
I just made a fresh installation, update, and I set Samba directly.

Groups show always "No data available in table"

2.3.24-1

The groups are created, I can see from Windows Domain Controller manager

I tried reinstalling Samba via https://www.clearos.com/clearfoundation/social/community/ldap-is-a-pita-account-system-is-offline#reply-129011

But it still the same
In Groups
Tuesday, August 08 2017, 06:39 PM
Share this post:
Responses (1)
  • Accepted Answer

    Sunday, October 01 2017, 09:01 AM - #Permalink
    Resolved
    0 votes
    Hi!
    I have same issue.
    I'm tried to fix groups plugin, but fail :)
    But i have workaround for openvpn_plugin and certificates_manager plugins:
    1. Add user to vpn groups via windows mgmt console
    2. Disable group verification in plugins:

    [root@dc ~]# diff /usr/clearos//apps/user_certificates/controllers/openvpn.php_orig /usr/clearos//apps/user_certificates/controllers/openvpn.php
    145c145
    < $is_cert_user = ($user_info['plugins']['user_certificates']) ? TRUE : FALSE;
    ---
    > $is_cert_user = ($user_info['plugins']['user_certificates']) ? TRUE : TRUE;
    [root@dc ~]# diff /usr/clearos//apps/user_certificates/controllers/certificates.php /usr/clearos//apps/user_certificates/controllers/certificates.php_orig
    156,157c156,157
    < #else if (!$is_cert_user)
    < # $this->page->view_form('disabled', $data, lang('user_certificates_app_name'));
    ---
    > else if (!$is_cert_user)
    > $this->page->view_form('disabled', $data, lang('user_certificates_app_name'));


    It's very bad workaround, but it helps me with openvpn.
    The reply is currently minimized Show
Your Reply