Community Forum

Resolved
0 votes
Greetings,

I setup the install then accidentally deleted p2p1, so now I only have p1p1 and p3p1.

How can I re-add this? I tried reboots and looking for a button to rescan, etc.

It seems people reinstall, seems a bit harsh... can I avoid this or?

thanks for your help!
Monday, August 07 2017, 06:30 AM
Share this post:
Responses (7)
  • Accepted Answer

    Monday, August 07 2017, 09:52 PM - #Permalink
    Resolved
    0 votes
    You have to restart the firewall service as well:

    systemctl restart firewall
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 07:14 PM - #Permalink
    Resolved
    0 votes
    Dave's append was to do after you did my bit creating the ifcfg-p2p1 file and making the necessary edits to it.

    Not sure about the Broadcom driver. You can try loading it with a "modprobe tg3". Otherwise what is the output to:
    lspci -knn | grep Eth -A 3


    To be honest, at this stage of a fresh installation, as reinstall may be easier!
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 07:02 PM - #Permalink
    Resolved
    0 votes
    I tried both solutions.

    The first one does not help because there is no p2p1 to add as an LANIF.

    The second, I did the steps, restarted services, restarted the server and no luck.

    It’s simply not even loading the Broadcom driver. It’s loaded into the kernel but not actually working. The system shows the right driver (I didn’t load the ELRepo ones). I mentioned it as they’re both the newest version.

    I just went and grabbed an Intel card. While I am technical, my time is precious even when tinkering some, so I’m trying to evaluate the Home Essentials version and this was hindering it.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 06:09 PM - #Permalink
    Resolved
    0 votes
    Please don't use the ElRepo drivers unless you compile them yourself as their compiled ones are not fully compatible with ClearOS. I believe the one in the ClearOS kernel is pretty much up to date - so much so that I don't compile them.

    Did you make the edit Dave suggested. You probably need to restart the network after making the changes.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 04:04 PM - #Permalink
    Resolved
    0 votes
    Neither worked... looks like there is some problem with the tg3 driver for the Broadcom card... the deletion of the interface just complicated my troubleshooting.

    It's a Broadcom BCM5761. The dmesg output is:

    [ 0.578845] tg3.c:v3.137 (May 11, 2014)
    [ 0.580552] tg3 0000:03:00.0: phy probe failed, err -19
    [ 0.630472] tg3 0000:03:00.0: VPD access failed. This is likely a firmware bug on this device. Contact the card vendor for a firmware update
    [ 0.630555] tg3 0000:03:00.0: Problem fetching invariants of chip, aborting

    Since this is the latest driver on ELRepo... I guess I'll try a reinstall. I can't find a "firmware upgrade" for this card in the white-box form I bought it - guess I can try throwing it into a windows PC and trying a Dell copy I found. Linux always makes me want to drink when dealing with driver issues.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 03:01 PM - #Permalink
    Resolved
    0 votes
    Make sure to update /etc/clearos/network.conf everything you manually edit interfaces in network-scripts.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, August 07 2017, 02:36 PM - #Permalink
    Resolved
    0 votes
    I have not found a way it through the webconfig. Go to /etc/sysconfig/network-scripts and copy the file ifcfg-p1p1 or ifcfg-p3p1, whichever is your LAN. In it change the DEVICE to p2p1 and change the IPADDR so something in a different LAN subnet. If you're in luck, when you navigate to network settings in the webconfig, the interface will reappear. If not try a "service network restart" from the command line then see if it reappears. As a last resort reboot the server.

    If any of these work, please post back with the one which worked.
    The reply is currently minimized Show
Your Reply