Forums

Resolved
0 votes
I Just installed a new server and purchased the Roundcube app, the I'm able to login but the user email shows up wrong.

It shows user@com.br (Brazilian domain in this case). Note that it is missing even the dot before the "com". Basically it's missing the domain name before the .TLD

At first I thought it was just a matter of editing the users preferences, but I tested it on mail-tester.com and even then it showed up as user@com.br, missing part of the domain.

I then tested it with an email client (Thunderbird) and it was fine.

I guess it's a problem with Roundcube package.

Any thoughts?
Wednesday, July 31 2019, 05:06 AM
Share this post:
Responses (13)
  • Accepted Answer

    Saturday, August 17 2019, 01:43 AM - #Permalink
    Resolved
    0 votes
    Did you really mean you went to "Settings -> Preferences"?

    If I ever saw the user email messed up on creating an email inside RC for the first time, I was always able to resolve it by going to "Settings -> Identities", not preferences.

    B
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 15 2019, 10:05 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I'm afraid I still think it is not a Roundcube issue, but to look at its configs, they are in /usr/share/roundcubemail/config but there is nothing there with your domain name. If you want to look at the database, the best thing to do is install the MariaDB app as this comes preconfigured to be able to access system-mariadb (choose the System database). User name is "roundcube" and the password is embedded in the $config['db_dsnw'] string in /usr/share/roundcubemail/config/config.inc.php between the ":" and the "@", or you can find it in /var/clearos/system_database/roundcubemail.

    The main reason I don't think it is Roundcube is that it only sets itself up with new users when they log in, so it must be deriving the e-mail address from somewhere or reading it from LDAP. It may be worth asking Roundcube support where they get the e-mail address from.


    I can give you access to the server in the name of debugging and learning. Its a new server without any data on it,
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 15 2019, 07:38 AM - #Permalink
    Resolved
    0 votes
    I'm afraid I still think it is not a Roundcube issue, but to look at its configs, they are in /usr/share/roundcubemail/config but there is nothing there with your domain name. If you want to look at the database, the best thing to do is install the MariaDB app as this comes preconfigured to be able to access system-mariadb (choose the System database). User name is "roundcube" and the password is embedded in the $config['db_dsnw'] string in /usr/share/roundcubemail/config/config.inc.php between the ":" and the "@", or you can find it in /var/clearos/system_database/roundcubemail.

    The main reason I don't think it is Roundcube is that it only sets itself up with new users when they log in, so it must be deriving the e-mail address from somewhere or reading it from LDAP. It may be worth asking Roundcube support where they get the e-mail address from.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, August 14 2019, 11:38 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I have no idea where it is picking its entries up from. Perhaps the Base Domain in the Directory Server settings. I don't know. It reads this when a new user logs in and gets set up in the Identities in Roundcube. I know mine is working correctly as I tested earlier today. Since then I have upgraded to the contribs-testing version of Roundcube.


    I'm sorry for the long wait time. I had a serious family health emergency to deal with.

    I have just uninstalled and reinstalled the app, still does not work. and it's using the updated version (released today)

    I wonder if i can manage to look at the config files and database to fix the issue. Mailing from thunderbird works.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 08:02 PM - #Permalink
    Resolved
    0 votes
    I have no idea where it is picking its entries up from. Perhaps the Base Domain in the Directory Server settings. I don't know. It reads this when a new user logs in and gets set up in the Identities in Roundcube. I know mine is working correctly as I tested earlier today. Since then I have upgraded to the contribs-testing version of Roundcube.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 05:58 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    If you just install yum i don't think you get the integration with system-mariadb.

    Have you checked the user's email address as it shows in the Users webconfig?


    I have checked. It's a new server and I've double checked everything in the webconfig. all users have the correct email
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 05:23 PM - #Permalink
    Resolved
    0 votes
    If you just install yum i don't think you get the integration with system-mariadb.

    Have you checked the user's email address as it shows in the Users webconfig?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 03:12 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    On my set up, my domain does not appear in any roundcube configs, unless they are hidden in a system-mysql database. Also, within Roundcube I log in with a username only. My e-mail address is in the Users webconfig, so check and see what yours says. Otherwise, I'd expect it to pick up from the Mail Domain in the SMTP Server or Mail Settings screens (they are the same data).

    I've just tried it with a new user who has never used Roundcube before and it automatically used her e-mail address from Users.


    I just checked, even created a new user for that, same issue.

    Perhaps i should try to create a vm locally and test the centos to clearos script and see if that creates the same issue. but idk if installing the rpm via yum instead of market place will do any difference
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 02:00 PM - #Permalink
    Resolved
    0 votes
    On my set up, my domain does not appear in any roundcube configs, unless they are hidden in a system-mysql database. Also, within Roundcube I log in with a username only. My e-mail address is in the Users webconfig, so check and see what yours says. Otherwise, I'd expect it to pick up from the Mail Domain in the SMTP Server or Mail Settings screens (they are the same data).

    I've just tried it with a new user who has never used Roundcube before and it automatically used her e-mail address from Users.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 01:14 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    Can you check your Mail Settings and SMTP Srever settings for the correct domain information? I don't think this is any part of Roundcubemail.


    I did and it looks fine. I guess if it was the smtp settings sending emails with a desktop client would fail as well. I could be wrong
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 12:56 PM - #Permalink
    Resolved
    0 votes
    Can you check your Mail Settings and SMTP Srever settings for the correct domain information? I don't think this is any part of Roundcubemail.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 12:44 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I thought settings like that were done manually in the Roundcube interface in Settings > Identities and each user and to set them up themselves.


    If that was the case it would be fine, but the fact that it sends out emails without the domain is a big problem. It's not just a preferences setting. I have updated the missign information manually and it still sends out the wrong email address..

    On the message header itself there is no domain.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, July 31 2019, 07:33 AM - #Permalink
    Resolved
    0 votes
    I thought settings like that were done manually in the Roundcube interface in Settings > Identities and each user and to set them up themselves.
    The reply is currently minimized Show
Your Reply