Forums

Resolved
0 votes
Community Meetings are held every Saturday at noon UTC. You can join the meeting here:

https://meet.google.com/xnp-upsa-jcz
+1 470-228-6361‬ PIN: ‪966 984 580‬#

Previous minutes

- Introductions.
Meeting was attended by Nick Howitt, Marcel Van Leeuwen and Patrick de Brabander.

- Review recent progress
Release of ClearOS 7.7 to Home and Business.

app-sia is in beta but has not had any progress for a couple of weeks

No progress with app-network but still hoping for a code review.

Reviewed a potential upgrade issue to z-push (part of the kopano suite) and did some live bug testing.

- Merge Request Status
Merge of app-network complete (big thanks to Todd Lewis) but there is a blocking bug from previous updates.

- Bug Report Status
Hoping for a community fix for #40 and #41. Josue said he may be able to review my code for #40 and I took the DRC contingent through the issue with #41.

Still have critical bugs and missing functionality in app-sia

- Training

- Features Review

- Notes:

- Work in Progress and team commits:
Kopano 8..5.8 is scheduled for release on 10th Dec. This may be skipped because it will introduce an issue that I've been able to resolve in 8.7.x

Kopano 8.7.5 is scheduled for release on 17th Dec. Because of a packaging bug we may have to stick with 8.7.5 and not release 8.7.7 for the moment.

New app-network is plodding along. Current issue is with External VLANs (#40)

The new app-sia needs more feedback but appears to have some issues. Also, documentation needed

app-clearshare phase1: To be released soon

=======================================

Here is a tentative agenda for next week's meeting:

- Introductions
- Review of last week's progress
- Status Report on 7.7 Release
- Review apps/bugs to be fixed in the near future
- Merge Request Status
- Bug Report Status

- Localization Review
- Features Review

- Continue to gather goals for the Rest of the Year
- Continue to gather goals for Quarter
- Continue to gather goals for Month
- Continue to gather goals for the Week
Monday, December 09 2019, 09:01 PM
Share this post:
Responses (19)
  • Accepted Answer

    Tuesday, December 17 2019, 07:13 PM - #Permalink
    Resolved
    0 votes
    Patrick de Brabander wrote:
    So, we have found a bug ?
    Only what you found - that not all packages in the repo are been presented through yum. Really this is a paid repo problem, but the solution is to create another package, app-kopano-extras, as part of app-kopano. Then the paid repos will get tweaked to show all packages listed as required by app-kopano-extras, but there will be no requirement for app-kopano-extras. This means that all the extra packages will be presented through yum but only updates if they are already installed. This will get round you issue, but it is currently untried. Shad still has to do his bits to the repos, so it is a bit late to release today..
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 06:37 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    It is a repo problem. There is no harm in you uninstalling the file, but I am just building another app-kopano to see if we can cheat the repos (at Shad's suggestion)

    Uninstalled the kopano-migration-pst package and performed the upgrade according the instruction (Title).
    Server is running on 8.7.5 now
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 06:26 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    I've rebuilt app-kopano a couple of times. It does not directly cheat the system so needs Shad to do an update to the marketplace before yum will give you access to kopano-migration-pst.

    This is all such a late change, I will probably delay release until tomorrow as I really want to test out the changes.

    So, we have found a bug ?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 05:56 PM - #Permalink
    Resolved
    0 votes
    I've rebuilt app-kopano a couple of times. It does not directly cheat the system so needs Shad to do an update to the marketplace before yum will give you access to kopano-migration-pst.

    This is all such a late change, I will probably delay release until tomorrow as I really want to test out the changes.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 04:47 PM - #Permalink
    Resolved
    0 votes
    It is a repo problem. There is no harm in you uninstalling the file, but I am just building another app-kopano to see if we can cheat the repos (at Shad's suggestion)
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 02:19 PM - #Permalink
    Resolved
    0 votes
    It is in the repo but it is not being presented to yum. FWIW, I don't have it installed on my 8.4.5. I'll ask some questions tonight as our repo man will be in. In the meanwhile, I'll try regenerating the repo, but I don't think that is it.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 11:28 AM - #Permalink
    Resolved
    0 votes
    Hi Nick,

    The output of yum upgrade
    yum update
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-amsterdam.clearos.com
    * clearos-centos-sclo-rh: download4.clearsdn.com
    * clearos-centos-verified: mirror2-amsterdam.clearos.com
    * clearos-contribs: mirror2-amsterdam.clearos.com
    * clearos-contribs-paid: mirror2-amsterdam.clearos.com
    * clearos-epel-verified: mirror2-amsterdam.clearos.com
    * clearos-fast-updates: download4.clearsdn.com
    * clearos-infra: mirror2-amsterdam.clearos.com
    * clearos-paid: mirror2-amsterdam.clearos.com
    * clearos-verified: mirror2-amsterdam.clearos.com
    * private-clearcenter-antimalware: download1.clearsdn.com:80
    * private-clearcenter-antispam: download3.clearsdn.com:80
    * private-clearcenter-content-filter: download1.clearsdn.com:80
    * private-clearcenter-dyndns: download1.clearsdn.com:80
    * private-clearcenter-home: download3.clearsdn.com:80
    * private-clearcenter-ids: download4.clearsdn.com:80
    * private-clearcenter-kopano-basic: download3.clearsdn.com:80
    * private-clearcenter-owncloud: download4.clearsdn.com:80
    * private-clearcenter-rbs: download1.clearsdn.com:80
    * private-clearcenter-verified-updates: download4.clearsdn.com:80
    No packages marked for update


    The output of yum update *kopano* --enablerepo=clearos-paid-testing

    yum update *kopano* --enablerepo=clearos-paid-testing
    Loaded plugins: clearcenter-marketplace, fastestmirror
    ClearCenter Marketplace: fetching repositories...
    Loading mirror speeds from cached hostfile
    * clearos: mirror2-amsterdam.clearos.com
    * clearos-centos-sclo-rh: download3.clearsdn.com
    * clearos-centos-verified: mirror2-amsterdam.clearos.com
    * clearos-contribs: mirror2-amsterdam.clearos.com
    * clearos-contribs-paid: mirror2-amsterdam.clearos.com
    * clearos-epel-verified: mirror2-amsterdam.clearos.com
    * clearos-fast-updates: download3.clearsdn.com
    * clearos-infra: mirror2-amsterdam.clearos.com
    * clearos-paid: mirror2-amsterdam.clearos.com
    * clearos-paid-testing: mirror2-amsterdam.clearos.com
    * clearos-verified: mirror2-amsterdam.clearos.com
    * private-clearcenter-antimalware: download4.clearsdn.com:80
    * private-clearcenter-antispam: download4.clearsdn.com:80
    * private-clearcenter-content-filter: download1.clearsdn.com:80
    * private-clearcenter-dyndns: download2.clearsdn.com:80
    * private-clearcenter-home: download2.clearsdn.com:80
    * private-clearcenter-ids: download3.clearsdn.com:80
    * private-clearcenter-kopano-basic: download3.clearsdn.com:80
    * private-clearcenter-owncloud: download4.clearsdn.com:80
    * private-clearcenter-rbs: download3.clearsdn.com:80
    * private-clearcenter-verified-updates: download2.clearsdn.com:80
    clearos-paid-testing | 3.5 kB 00:00:00
    clearos-paid-testing/updateinfo | 96 B 00:00:00
    clearos-paid-testing/primary_db | 67 kB 00:00:00
    Resolving Dependencies
    --> Running transaction check
    ---> Package app-kopano.noarch 1:2.3.10-1.v7 will be updated
    ---> Package app-kopano.noarch 1:2.3.23-1.v7 will be an update
    ---> Package app-kopano-basic.noarch 1:2.3.6-1.v7 will be updated
    ---> Package app-kopano-basic.noarch 1:2.3.8-1.v7 will be an update
    ---> Package app-kopano-basic-core.noarch 1:2.3.6-1.v7 will be updated
    ---> Package app-kopano-basic-core.noarch 1:2.3.8-1.v7 will be an update
    ---> Package app-kopano-core.noarch 1:2.3.10-1.v7 will be updated
    ---> Package app-kopano-core.noarch 1:2.3.23-1.v7 will be obsoleting
    ---> Package kopano-backup.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-backup.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-client.x86_64 0:8.4.5.0-33.1 will be updated
    --> Processing Dependency: kopano-client = 8.4.5.0 for package: php-mapi-8.4.5.0-33.1.x86_64
    --> Processing Dependency: kopano-client = 8.4.5.0 for package: python-mapi-8.4.5.0-33.1.x86_64
    ---> Package kopano-client.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: libgsoapssl++-kopano-2.8.86.so(GSOAPSSLXX)(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcrosie.so.0(KC_8.7.3)(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcsoap.so.0(KC_8.7.3)(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcutil.so.0(KC_8.7.3)(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libmapi.so.1(KC_8.7.3)(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libHX.so.28()(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libgsoapssl++-kopano-2.8.86.so()(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libjsoncpp.so.19()(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcrosie.so.0()(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libtidy.so.5()(64bit) for package: kopano-client-8.7.5.0-43.1.x86_64
    ---> Package kopano-common.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-common.x86_64 0:8.7.5.0-43.1 will be obsoleting
    ---> Package kopano-contacts.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-contacts.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-dagent.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-dagent.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: libkcpyplug0 = 8.7.5.0 for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: kopano-dagent-pytils for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcarchiver.so.0(KC_8.7.3)(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcarchivercore.so.0(KC_8.7.3)(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcinetmapi.so.0(KC_8.7.3)(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libical.so.3()(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libicalss.so.3()(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libicalvcal.so.3()(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libvmime-kopano.so.2()(64bit) for package: kopano-dagent-8.7.5.0-43.1.x86_64
    ---> Package kopano-gateway.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-gateway.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-ical.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-ical.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: libkcfreebusy.so.0(KC_8.7.3)(64bit) for package: kopano-ical-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcicalmapi.so.0(KC_8.7.3)(64bit) for package: kopano-ical-8.7.5.0-43.1.x86_64
    ---> Package kopano-lang.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-lang.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-monitor.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-monitor.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-presence.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package kopano-search.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-search.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: poppler-utils for package: kopano-search-8.7.5.0-43.1.x86_64
    ---> Package kopano-server.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-server.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: libkcserver.so.0(KC_8.7.3)(64bit) for package: kopano-server-8.7.5.0-43.1.x86_64
    --> Processing Dependency: libkcoidc.so.0()(64bit) for package: kopano-server-8.7.5.0-43.1.x86_64
    ---> Package kopano-server-packages.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-server-packages.x86_64 0:8.7.5.0-43.1 will be an update
    --> Processing Dependency: kopano-python-utils for package: kopano-server-packages-8.7.5.0-43.1.x86_64
    ---> Package kopano-spooler.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-spooler.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-utils.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package kopano-utils.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package kopano-webapp.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-lang.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-lang.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-contactfax.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-contactfax.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-filepreviewer.noarch 0:2.1.0.26-20.7 will be updated
    ---> Package kopano-webapp-plugin-filepreviewer.noarch 0:2.2.0.26-24.2 will be an update
    ---> Package kopano-webapp-plugin-folderwidgets.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-folderwidgets.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-gmaps.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-gmaps.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-pimfolder.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-pimfolder.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-quickitems.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-quickitems.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-titlecounter.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-titlecounter.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package kopano-webapp-plugin-webappmanual.noarch 0:3.5.6.2298-94.1 will be updated
    ---> Package kopano-webapp-plugin-webappmanual.noarch 0:3.5.12.2482-108.1 will be an update
    ---> Package libkchl0.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package libkcmapi0.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package libkcssl0.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package libkcsync0.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package python-kopano.x86_64 0:8.4.5.0-33.1 will be obsoleted
    --> Processing Dependency: python-kopano = 8.4.5.0 for package: kopano-migration-pst-8.4.5.0-33.1.x86_64
    ---> Package python2-kopano.x86_64 0:8.7.5.0-43.1 will be obsoleting
    --> Running transaction check
    ---> Package kopano-dagent-pytils.x86_64 0:8.7.5.0-43.1 will be installed
    ---> Package kopano-python-utils.x86_64 0:8.7.5.0-43.1 will be installed
    ---> Package libHX.x86_64 0:3.22-9.el7 will be installed
    ---> Package libgsoap-kopano-2_8_86.x86_64 0:2.8.86-1.1 will be installed
    ---> Package libical.x86_64 0:3.0.3-2.el7 will be installed
    ---> Package libjsoncpp19.x86_64 0:1.8.4-3.8 will be installed
    ---> Package libkcarchiver0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcarchiver0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcarchivercore0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcarchivercore0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcfreebusy0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcfreebusy0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcicalmapi0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcicalmapi0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcinetmapi0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcinetmapi0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcoidc0.x86_64 0:0.4.4-3.3 will be installed
    ---> Package libkcpyplug0.x86_64 0:8.7.5.0-43.1 will be installed
    ---> Package libkcrosie0.x86_64 0:8.7.5.0-43.1 will be installed
    ---> Package libkcserver0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcserver0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcsoap0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcsoap0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libkcutil0.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libkcutil0.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libmapi1.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package libmapi1.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package libtidy.x86_64 0:5.4.0-1.el7 will be installed
    ---> Package libvmime-kopano2.x86_64 0:0.9.2.85-7.1 will be installed
    ---> Package php-mapi.x86_64 0:8.4.5.0-33.1 will be updated
    ---> Package php-mapi.x86_64 0:8.7.5.0-43.1 will be an update
    ---> Package poppler-utils.x86_64 0:0.26.5-38.el7 will be installed
    --> Processing Dependency: poppler(x86-64) = 0.26.5-38.el7 for package: poppler-utils-0.26.5-38.el7.x86_64
    --> Processing Dependency: libopenjpeg.so.1()(64bit) for package: poppler-utils-0.26.5-38.el7.x86_64
    --> Processing Dependency: libpoppler.so.46()(64bit) for package: poppler-utils-0.26.5-38.el7.x86_64
    ---> Package python-kopano.x86_64 0:8.4.5.0-33.1 will be obsoleted
    --> Processing Dependency: python-kopano = 8.4.5.0 for package: kopano-migration-pst-8.4.5.0-33.1.x86_64
    ---> Package python-mapi.x86_64 0:8.4.5.0-33.1 will be obsoleted
    ---> Package python2-mapi.x86_64 0:8.7.5.0-43.1 will be obsoleting
    --> Running transaction check
    ---> Package openjpeg-libs.x86_64 0:1.5.1-18.el7 will be installed
    ---> Package poppler.x86_64 0:0.26.5-38.el7 will be installed
    --> Processing Dependency: poppler-data >= 0.4.0 for package: poppler-0.26.5-38.el7.x86_64
    ---> Package python-kopano.x86_64 0:8.4.5.0-33.1 will be obsoleted
    --> Processing Dependency: python-kopano = 8.4.5.0 for package: kopano-migration-pst-8.4.5.0-33.1.x86_64
    --> Running transaction check
    ---> Package poppler-data.noarch 0:0.4.6-3.el7 will be installed
    ---> Package python-kopano.x86_64 0:8.4.5.0-33.1 will be obsoleted
    --> Processing Dependency: python-kopano = 8.4.5.0 for package: kopano-migration-pst-8.4.5.0-33.1.x86_64
    --> Finished Dependency Resolution
    Error: Package: kopano-migration-pst-8.4.5.0-33.1.x86_64 (@private-clearcenter-kopano-basic)
    Requires: python-kopano = 8.4.5.0
    Removing: python-kopano-8.4.5.0-33.1.x86_64 (@private-clearcenter-kopano-basic)
    python-kopano = 8.4.5.0-33.1
    Obsoleted By: python2-kopano-8.7.5.0-43.1.x86_64 (clearos-paid-testing)
    python-kopano = 8.7.5.0-43.1
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:app-kopano-core-2.3.10-1.v7.noarch has missing requires of zarafa-z-push


    The z-push should not cause the problem to my opinion.


    When in remove "yum remove kopano-migration-pst" , i can do the update (will execute it tonight.....)
    Is yum remove kopano-migration-pst missing in 8.7.5 ?
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, December 17 2019, 09:35 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    How are you doing the update? I suspect you've missed the * in front of kopano:
    yum update *kopano* --enablerepo=clearos-paid-testing
    If that is missed you won't bring down the app-packages. app-kopano-2.3.10 should be replaced removing the requires.
    I've just tried this again and it worked immediately. :S
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 16 2019, 09:21 PM - #Permalink
    Resolved
    0 votes
    Is it pulling down app-kopano-2.3.23-1.v7 and app-kopano-basic-2.3.8-1.v7? If not, try:
    yum update app-kopano app-kopano-basic *kopano* --enablerepo=clearos-paid-testing
    If it does not pull down the app- packages then there may be a problem. Is his subscription up-to-date? Also did you remove the old zarafa-z-push yourself manually?

    [edit]
    Can you give the full output from the yum update?
    [/edit]
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 16 2019, 07:49 PM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    How are you doing the update? I suspect you've missed the * in front of kopano:
    yum update *kopano* --enablerepo=clearos-paid-testing
    If that is missed you won't bring down the app-packages. app-kopano-2.3.10 should be replaced removing the requires.


    I did
    yum upgrade *kopano* --enablerepo=clearos-paid-testing

    could z-push cause the problem ?
    1:app-kopano-core-2.3.10-1.v7.noarch has missing requires of zarafa-z-push

    This has been updated with the Kopano Repos.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 16 2019, 07:44 PM - #Permalink
    Resolved
    0 votes
    How are you doing the update? I suspect you've missed the * in front of kopano:
    yum update *kopano* --enablerepo=clearos-paid-testing
    If that is missed you won't bring down the app-packages. app-kopano-2.3.10 should be replaced removing the requires.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, December 16 2019, 06:08 PM - #Permalink
    Resolved
    0 votes
    Nick,

    I'm trying to update a server with Kopano 8.4.5 to 8.7.5 (8.5.8 is not available anymore) and getting the following error
    Error: Package: kopano-migration-pst-8.4.5.0-33.1.x86_64 (@private-clearcenter-kopano-basic)
    Requires: python-kopano = 8.4.5.0
    Removing: python-kopano-8.4.5.0-33.1.x86_64 (@private-clearcenter-kopano-basic)
    python-kopano = 8.4.5.0-33.1
    Obsoleted By: python2-kopano-8.7.5.0-43.1.x86_64 (clearos-paid-testing)
    python-kopano = 8.7.5.0-43.1
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    1:app-kopano-core-2.3.10-1.v7.noarch has missing requires of zarafa-z-push
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2019, 01:37 PM - #Permalink
    Resolved
    0 votes
    I already had a snapshot of 8.7.5 and it is now in clearos-paid-testing. The user will always download from our repos and not Kopano's so we can test for webconfig breakages before releasing an update.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2019, 11:31 AM - #Permalink
    Resolved
    0 votes
    Nick Howitt wrote:

    But that puts the upgrade on hold unless I fix the dependency issue in apo-kopano (which is not really the right way of going about it). Do you see a problem going to 8.7.5?

    If 8.7.5. has not a dependency issue, it makes sense to proceed.
    Only thing is that the repos of kopano install the latest version,So you need to use the COS dependency.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2019, 11:06 AM - #Permalink
    Resolved
    0 votes
    But that puts the upgrade on hold unless I fix the depenency issue in apo-kopano (which is not really the right way of going about it). Do you see a problem going to 8.7.5?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2019, 10:59 AM - #Permalink
    Resolved
    0 votes
    That doesn't surprise me.
    Best i think to skip all the previous version and go straight to 8.7.9, one the dependencies of course are solved.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, December 12 2019, 09:06 AM - #Permalink
    Resolved
    0 votes
    8.7.9 has the same dependency issue so it does not install libkcpyplug0 when updating from 8.4.5 or 8.5.8. If you are already on 8.7.x then you are OK as it will get updated. Following my report to Kopano they have created a bug report (against 8.7.7, but I hope they carry it forward).
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 11 2019, 08:37 PM - #Permalink
    Resolved
    0 votes
    Oh crumbs. More testing ....... It should just drop in. I hope it does not have the same dependency issues. I am getting into overload and may just let 8.7.5 run. Let me think about it.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, December 11 2019, 08:27 PM - #Permalink
    Resolved
    0 votes
    The reply is currently minimized Show
Your Reply