Profile Details

Toggle Sidebar
Recent updates
  • Jeff1965
    Jeff1965 started a new discussion, PHP Upgrade

    PHP Upgrade

    Are there any "current" how to's on upgrading php in COS7. I did a search and I can only find stuff on 6 and before. Currently on 5.4.16 and wanting to go to 5.6 without breaking everything

  • Jeff1965
    Jeff1965 started a new discussion, .htaccess not redirecting

    .htaccess not redirecting

    I have my wifes crafts site hosted in a virtual domain in a sub folder. Configed a .htaccess and dropped it in the VD root with a copy of the index.php. Im getting a blank web page.
    Is there something in cos preventing it from redirecting by default?
    admin/allusers has ownership of the subdirectory and files. Not sure if apache/allusers should have ownership.

  • Jeff1965
    Jeff1965 replied to a discussion, Zarafa-Server won't start anymore

    Ben Chambers wrote:

    For anyone coming across this thread, before repairing the proc table as one of the post in here advises, can you try:



    And upgrade to 2.1.7-1.

    Then, try restarting Zarafa server:



    And report back here and let me know if that too, resolves the proc issue.

    Also, if anyone who had the 'proc' corruption in the past, upgrading may prevent the issue from occurring in the future.

    According to this thread on the Zarafa forums, we should have this issue with the version of MariaDB we're running...however, we should have been running the mysql_upgrade script when upgrading the internal database.

    All this update does it provide an automated script that will run the mysql_upgrade command.



    That you can also run with the --force flag, if desired.

    It does nothing if nothing is required, so a fairly innocuous script.

    I'd like to know two things:

    1. Confirm that running this script fixes the proc table corruption
    2. Longer term, I'd like to hear back on users who have upgraded, whether they ever see the proc corruption again or not...ideally, this issue 'goes away'. If it occurs to users who have upgraded, but #1 confirms it repairs the proc table, my next step is to add the calling of this script to the Zarafa server stop/start, that will fix the situation when the user tries starting Zarafa server.

    Thanks,

    B

    Thanks Ben,
    I had a power loss at the house and it obviously knocked the server down. I had this proc problem on reboot. Your command line update fixed it good as new

  • Jeff1965
    Jeff1965 started a new discussion, Owncloud Users

    Owncloud Users

    Running Home 7.2 w/essentials. For some reason something is breaking the link to ldap on my machine (i think) for my users to login to owncloud. I do a fresh install and install the directory then Windows networking than all other software and I do own cloud last I create my users and my users are able to login to own cloud through the web page just fine then later no user can log in only the admin account can. It's stating incorrect username or password when I know they are correct. Not sure if it's getting an update that's killing the link or what. anyone else having this problem I've done a fresh install 3 times now and all three times it's done this I have no way of knowing or tracking down where it's taking place

  • Tim,
    To uncomment this line in the script is ## correct?

  • Jeff1965
    Jeff1965 replied to a discussion, Owncloud users

    Damn this still isnt working for my users. I ran both of the posted scripts Tim posted up and its still not letting anyone in.

  • Jeff1965
    Jeff1965 replied to a discussion, DB not starting

    Ben Chambers wrote:

    Try:




    Any joy?

    B.


    Thanks Ben

    Heres what Ive got for both

    [root@server ~]# systemctl status mariadb
    ● mariadb.service - MariaDB database server
    Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
    Active: active (running) since Tue 2016-04-19 11:30:59 CDT; 6h ago
    Process: 994 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=0/SUCCESS)
    Process: 647 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
    Main PID: 993 (mysqld_safe)
    CGroup: /system.slice/mariadb.service
    ├─ 993 /bin/sh /usr/bin/mysqld_safe --basedir=/usr
    └─1468 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysq...

    Apr 19 11:30:34 server.the-killians.com systemd[1]: Starting MariaDB database server...
    Apr 19 11:30:38 server.the-killians.com mysqld_safe[993]: 160419 11:30:38 mysqld_safe Logging to '/var/...g'.
    Apr 19 11:30:39 server.the-killians.com mysqld_safe[993]: 160419 11:30:39 mysqld_safe Starting mysqld d...sql
    Apr 19 11:30:59 server.the-killians.com systemd[1]: Started MariaDB database server.
    Apr 19 17:35:50 server.the-killians.com systemd[1]: Started MariaDB database server.
    Hint: Some lines were ellipsized, use -l to show in full.




    Ben Chambers wrote:

    Try:



    Any joy?

    B.


    [root@server ~]# cd /var/lib/system-mysql/
    [root@server system-mysql]# /usr/clearos/sandbox/usr/bin/innochecksum -d ibdata1
    file ibdata1 = 60817408 bytes (3712 pages)...
    checking pages in range 0 to 3711
    page 0: log sequence number: first = 265548142; second = 265531498
    page 0 invalid (fails log sequence number check)
    [root@server system-mysql]# service mariadb start
    Redirecting to /bin/systemctl start mariadb.service
    [root@server system-mysql]#

  • Jeff1965
    Jeff1965 replied to a discussion, DB not starting

    Im guessing theres no way to fix this?

    Output of my system-mariadb log after reboot
    Not much showing




    160419 11:30:39 mysqld_safe Starting mysqld daemon with databases from /var/lib/system-mysql
    160419 11:30:46 InnoDB: The InnoDB memory heap is disabled
    160419 11:30:46 InnoDB: Mutexes and rw_locks use GCC atomic builtins
    160419 11:30:46 InnoDB: Compressed tables use zlib 1.2.7
    160419 11:30:46 InnoDB: Using Linux native AIO
    160419 11:30:47 InnoDB: Initializing buffer pool, size = 500.0M
    160419 11:30:47 InnoDB: Completed initialization of buffer pool
    InnoDB: Error: checksum mismatch in data file ./ibdata1
    160419 11:30:47 InnoDB: Could not open or create data files.
    160419 11:30:47 InnoDB: If you tried to add new data files, and it failed here,
    160419 11:30:47 InnoDB: you should now edit innodb_data_file_path in my.cnf back
    160419 11:30:47 InnoDB: to what it was, and remove the new ibdata files InnoDB created
    160419 11:30:47 InnoDB: in this failed attempt. InnoDB only wrote those files full of
    160419 11:30:47 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
    160419 11:30:47 InnoDB: remove old data files which contain your precious data!
    160419 11:30:47 [ERROR] Plugin 'InnoDB' init function returned error.
    160419 11:30:47 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    160419 11:30:48 [Note] Plugin 'FEEDBACK' is disabled.
    160419 11:30:49 [ERROR] Unknown/unsupported storage engine: InnoDB
    160419 11:30:49 [ERROR] Aborting

    160419 11:30:49 [Note] /usr/clearos/sandbox/usr/libexec/mysqld: Shutdown complete

    160419 11:30:49 mysqld_safe mysqld from pid file /var/run/system-mariadb/mariadb.pid ended

  • Jeff1965
    Jeff1965 updated their profile
  • Jeff1965
    Jeff1965 replied to a discussion, DB not starting

    Did anyone come up with a fix for this? My system-mariadb has crashed and wont restart. Naturally my zarafa server is offline as well.
    Try to start either one and Im getting "command execution failed"
    My regular mariadb is running but the system one is dead.
    I noticed that a few days ago mariadb got an update.

    Anyone
    TIA