Profile Details

Toggle Sidebar
Recent updates
  • Well, I had a quick look at it and it was easier to fix the certificate problem than I thought. A new version of app-domoticz is just built. I might ask for it to be released already tomorrow, we will see. However, as before the Domoticz certificate handling is not integrated into the clearos-certificate-manager. It will still give you 3 choices:

    1. The same certificate that is used by the ClearOS server (Webconfig). If this changes (for instance by the clearos certificate-manager) it may take up to 24 hours until the change is cascaded to Domoticz. You can force the cascading by pressing "Edit" and then "Update" at the app-domoticz webconfig page. (No need to change the parameters.)

    2. The standard certificate that ships with Domoticz

    3. A customized certificate that the user need to prepare himself (read the instructions in the app-domoticz documentation that is available from the webconfig page)

    /Fred

  • I will see what I can do to make the domoticz certificate handling to work better with the new ClearOS customized certificate system.
    I am quite busy right now, so it will likely take 1-2 weeks.
    /Fred

  • it looks that the RPM in not containing the /usr/share/open-zwave/config content.
    The directory is not made, but the link is available in /usr/share/domoticz


    Not sure if I understand you correctly. But I will try to explain how it designed today:
    The domoticz source code requires the libopenzwave installation to be in place to enable z-wave, which is fine. However, then it supplies its own copy of the libopenzwave files which if you ask me is not how things should be done. Furthermore, domoticz require those libopenzwave files to be in its own "home directory". I guess this works if you compile all the stuff yourself, but it tends to get very nasty in a modular environment using rpm or apt.

    I have solved it by omitting the domoticz version of the libopenzwave config files at compile time of the domoticz.rpm, and instead create a soft link pointing to the /usr/share/open-zwave/config directory instead where the "original" libopenzwave files reside.

    So:
    1. domoticz.rpm requires libopenzwave.rpm at installation time
    2. libopenzwave.rpm creates the directory (and the content in it) /usr/share/open-zwave/config
    3. domoticz.rpm creates the directory /usr/share/domoticz (and the soft link to /usr/share/open-zwave/config "fooling" domoticz that the config files are under /usr/share/domoticz/config)

    In this way libopenzwave can be updated with new config files (as long as we are talking stepping of the minor version) while still having the same domoticz version. Since new z-wave config files are added at least every week and domoticz is not released more often than once or twice a year, this will allow a possibility to keep the environment up to date. However, if/when libopenzwave API is changed then the release needs to be syncronized with a new domoticz release. I will look after that part.

    /Fred

  • Patrick,
    Nice to hear that it is working again. I have already made a couple of tweaks in my development branch so the code will be a bit more robust in the next release of app-domoticz (I have nothing planned right now so it may take some time).
    /Fred

  • Patrick,
    Oh, you managed to get the unfinished reply that I posted. I had some browser issues (or maybe a problem with the ClearOS forum server) so I posted the unfinished post. I corrected it, but you managed to get started with the uncomplete version...

    Please look again at my post or just add:
    /Fred

  • Patrick,
    Yes, something is not OK in your setup now. I suggest you do this:
    1. Restore the file /usr/clearos/sandbox/etc/httpd/conf.d/framework.conf so that it only contains the only two rows that you have used before.
    2. Run this from command line (as root):3. Go to the webconfig ->app-domoticz and press "Edit" and then press "Update" (I assume you have selected SSL cert = "Same as for this ClearOS server")
    4. Look at the Domoticz log (restart it if neccessary)

    Now it should be ok (if your SSL-cert itself is OK, which I guess it is).
    /Fred

  • Patrick,
    app-domoticz should "fix itself" in 24 hours.
    But you can force an update by selecting "Edit" in the app-domoticz and then press "Update" (no need to change parameters).

    /Fred

  • Patrick,
    Yes it is probably related to that last minute change. I am not using your setup, so I have not experienced it.

    The reason why you get the error is that the file /usr/clearos/sandbox/etc/httpd/conf.d/framework.conf does not contain a valid certificate file name after a heading "SSLCertificateKeyFile". That should normally never happen... But I am not sure exactly what the clearos team did with this "last minute change"...

    Please check the file /usr/clearos/sandbox/etc/httpd/conf.d/framework.conf . Does it contain valid entries for:

    SSLCertificateFile
    SSLCertificateKeyFile
    SSLCertificateChainFile (might be missing, and that is OK)
    SSLCACertificateFile (might be missing, and that is OK)

    If you find the "SSL-keywords" with a valid file path after them, then please check that the actual files exist.
    Example: It should look something like this:
    In this example, please check that the files /etc/pki/CA/sys-0-cert.pem , /etc/pki/CA/private/sys-0-key.pem and /etc/pki/ca-cert.pem actually exist.

    The content of the file /usr/clearos/sandbox/etc/httpd/conf.d/framework.conf should normally only be changed by the ClearOS webconfig settings. App-domoticz will NEVER change it, only read the information in order to use copy the certificate for domoticz usage too. However, this time it did not work for you for some reason...

    /Fred

  • Patrick,
    If you get the screen below "Domoticz Offline", then it is most likely your browser cache that needs to be refreshed (press <Ctrl> + <F5> ). This is due to that Domoticz is using your browser cache for its html5 coding, and if the code in your browser cache cannot communicate with Domoticz then you get this message. It can also happen if the Domoticz server is not running any longer. In your case I think a browser refresh should do the trick.

    /Fred

  • Hi,
    I have had the same? problem in 7.2 too. Never thought it could be browser related. In my case ALL entries are to be found, however they do not appear in order... Try to select to see ALL messages and see if you find the "missing" packages further down the list.

    I reported this to Ben that fixed one bug but then he could not reproduce the wrong order. Maybe we were just using different browsers...

    Could this be a date format issue mm/dd/yy vs. dd/mm/yy or yy/mm/dd vs yy/dd/mm ?

    In my case the packages order is different in the software uppdate app compared to the recent sw list on the dashboard

    I am normally using Edge browser.

    /Fred